Bug 194031 - net/miniupnpc: update to 1.9.20140911
Summary: net/miniupnpc: update to 1.9.20140911
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks: 194029
  Show dependency treegraph
 
Reported: 2014-09-30 08:37 UTC by Jan Beich
Modified: 2014-11-23 08:43 UTC (History)
0 users

See Also:
dinoex: maintainer-feedback-


Attachments
update (2.73 KB, patch)
2014-09-30 08:37 UTC, Jan Beich
no flags Details | Diff
|poudriere testport -P| master log (9.3R i386) (15.11 KB, text/plain)
2014-09-30 08:39 UTC, Jan Beich
no flags Details
update (2.98 KB, patch)
2014-09-30 09:05 UTC, Jan Beich
no flags Details | Diff
|poudriere testport -P| slave log (9.3R i386) (15.86 KB, text/plain)
2014-09-30 09:08 UTC, Jan Beich
no flags Details
update, v2 (3.11 KB, patch)
2014-09-30 09:29 UTC, Jan Beich
no flags Details | Diff
|poudriere testport| slave log (9.3R i386) (18.44 KB, text/plain)
2014-09-30 09:33 UTC, Jan Beich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2014-09-30 08:37:53 UTC
Created attachment 147825 [details]
update

- update
- strip per stage-qa warning
- kill @dirrm per CHANGES from 20140922
Comment 1 Bugzilla Automation freebsd_committer 2014-09-30 08:37:53 UTC
Auto-assigned to maintainer dinoex@FreeBSD.org
Comment 2 Jan Beich freebsd_committer 2014-09-30 08:39:01 UTC
Created attachment 147826 [details]
|poudriere testport -P| master log (9.3R i386)
Comment 3 Jan Beich freebsd_committer 2014-09-30 09:05:34 UTC
Created attachment 147827 [details]
update

Oops, missed USE_PYTHON being deprecated.
Comment 4 Jan Beich freebsd_committer 2014-09-30 09:08:35 UTC
Created attachment 147828 [details]
|poudriere testport -P| slave log (9.3R i386)

I have no clue why the following happens but it was there before

===> Checking for items in STAGEDIR missing from pkg-plist
Error: Orphaned: %%PYTHON_SITELIBDIR%%/miniupnpc-1.9-py%%PYTHON_VER%%.egg-info/PKG-I
NFO
Error: Orphaned: %%PYTHON_SITELIBDIR%%/miniupnpc-1.9-py%%PYTHON_VER%%.egg-info/SOURC
ES.txt
Error: Orphaned: %%PYTHON_SITELIBDIR%%/miniupnpc-1.9-py%%PYTHON_VER%%.egg-info/dependency_links.txt
Error: Orphaned: %%PYTHON_SITELIBDIR%%/miniupnpc-1.9-py%%PYTHON_VER%%.egg-info/top_level.txt
Comment 5 Jan Beich freebsd_committer 2014-09-30 09:29:53 UTC
Created attachment 147829 [details]
update, v2

As pointed out by mva@ on #freebsd-python that error was due to PYDISTUTILS_PKGVERSION not being set correctly, similar to issue fixed in r285752.
Comment 6 Jan Beich freebsd_committer 2014-09-30 09:33:19 UTC
Created attachment 147830 [details]
|poudriere testport| slave log (9.3R i386)
Comment 7 commit-hook freebsd_committer 2014-10-11 09:12:49 UTC
A commit references this bug:

Author: dinoex
Date: Sat Oct 11 09:12:20 UTC 2014
New revision: 370628
URL: https://svnweb.freebsd.org/changeset/ports/370628

Log:
  - update miniupnpc to 1.9
  - bump users of shared lib version
  PR:		194031

Changes:
  head/irc/iroffer-dinoex/Makefile
  head/net/miniupnpc/Makefile
  head/net/miniupnpc/distinfo
  head/net/miniupnpc/files/patch-Makefile
  head/net/miniupnpc/pkg-plist
  head/net/py-miniupnpc/Makefile
Comment 8 Dirk Meyer freebsd_committer 2014-10-11 09:15:06 UTC
This patch introduces regressions on FreeBSD-9.

I commited an update based on your patch.