Bug 194038 - [exp-run] update and split up devel/gettext and USES=gettext
Summary: [exp-run] update and split up devel/gettext and USES=gettext
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tijl Coosemans
URL:
Keywords:
: 193919 (view as bug list)
Depends on: 190676
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-30 11:56 UTC by Tijl Coosemans
Modified: 2014-11-29 19:30 UTC (History)
2 users (show)

See Also:


Attachments
patch (65.00 KB, patch)
2014-09-30 11:56 UTC, Tijl Coosemans
no flags Details | Diff
patch2 (65.06 KB, patch)
2014-10-10 10:18 UTC, Tijl Coosemans
no flags Details | Diff
patch3 (63.94 KB, patch)
2014-10-10 10:28 UTC, Tijl Coosemans
no flags Details | Diff
patch4 (112.42 KB, patch)
2014-10-13 18:44 UTC, Tijl Coosemans
no flags Details | Diff
patch5 (112.71 KB, patch)
2014-10-13 21:09 UTC, Tijl Coosemans
no flags Details | Diff
patch6 (113.60 KB, patch)
2014-11-23 15:20 UTC, Tijl Coosemans
no flags Details | Diff
patch7 (140.97 KB, patch)
2014-11-25 13:59 UTC, Tijl Coosemans
no flags Details | Diff
patch8 (141.08 KB, patch)
2014-11-25 20:08 UTC, Tijl Coosemans
no flags Details | Diff
patch9 (141.26 KB, patch)
2014-11-26 19:52 UTC, Tijl Coosemans
no flags Details | Diff
patch10 (143.32 KB, patch)
2014-11-27 08:24 UTC, Tijl Coosemans
no flags Details | Diff
patch11 (143.60 KB, patch)
2014-11-29 12:00 UTC, Tijl Coosemans
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tijl Coosemans freebsd_committer 2014-09-30 11:56:27 UTC
Created attachment 147839 [details]
patch

In the gettext distfile there's a file named PACKAGING which recommends to split up the gettext package into gettext-runtime (libintl) and gettext-tools (development/translation tools).  Normally subpackages would be used for this, but since the distfile basically consists of two subdirectories each with their own configure script it is relative easy to create separate ports.

Moreover, there's a minor issue with the combination of USES=autoreconf with USES=gettext hidden behind an NLS option.  If a port uses gettext, autoreconf requires autopoint (part of gettext-tools) even if the NLS option is off.  A port like net-mgmt/nagios-plugins now does the following:

USES=         autoreconf
NLS_USES=     gettext
NLS_USES_OFF= gettext:build

This isn't very intuitive and I've had people asking questions about this.  It could be made more elegant by splitting up USES=gettext into USES=gettext-runtime and USES=gettext-tools that correspond to the ports.  Then you would have:

USES=         autoreconf gettext-tools
NLS_USES=     gettext-runtime

The attached patch splits up devel/gettext into devel/gettext-runtime and devel/gettext-tools and USES=gettext into USES=gettext-runtime and USES=gettext-tools.  It leaves devel/gettext as a meta port/package and USES=gettext as a meta USES.  The ports are updated to version 0.19.2.

The patch also removes :oldver from gettext-runtime and libiconv.  To prevent bumping PORTREVISION on a lot of ports they still install a symlink with the old .so version.  As soon as most ports that depend on them have had an version update (for other reasons) the remaining ports (small number) can get a PORTREVISION bump and these links can be removed.
Comment 1 Tijl Coosemans freebsd_committer 2014-09-30 11:58:09 UTC
*** Bug 193919 has been marked as a duplicate of this bug. ***
Comment 2 Tijl Coosemans freebsd_committer 2014-10-10 10:18:59 UTC
Created attachment 148158 [details]
patch2

Rebased against r370567
Comment 3 Tijl Coosemans freebsd_committer 2014-10-10 10:28:01 UTC
Created attachment 148159 [details]
patch3

net-mgmt/nagios-plugins and net-mgmt/monitoring-plugins no longer use autoreconf so adjust patch a bit.  An example of a port that still does is sysutils/pinfo.
Comment 4 Tijl Coosemans freebsd_committer 2014-10-10 10:29:14 UTC
(In reply to Tijl Coosemans from comment #3)
> sysutils/pinfo

misc/pinfo
Comment 5 Antoine Brodin freebsd_committer 2014-10-11 21:51:54 UTC
Take for exp-run
Comment 7 Antoine Brodin freebsd_committer 2014-10-13 05:32:18 UTC
New failures:

+ {"origin"=>"audio/ardour", "pkgname"=>"ardour-2.8.14_6", "phase"=>"stage", "errortype"=>"???"}
+ {"origin"=>"audio/aumix", "pkgname"=>"aumix-2.9.1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"audio/clementine-player", "pkgname"=>"clementine-player-1.2.3_7", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"audio/gbemol", "pkgname"=>"gbemol-0.3.2_12", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"audio/gkrellmms2", "pkgname"=>"gkrellmms2-2.1.22_12", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"audio/gkrellmss2", "pkgname"=>"gkrellmss-2.7_4", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"audio/gkrellmvolume2", "pkgname"=>"gkrellmvolume2-2.1.13_9", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"audio/pms", "pkgname"=>"pms-0.42_2", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"audio/ripperx", "pkgname"=>"ripperx-2.7.3_1", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"comms/xnec2c", "pkgname"=>"xnec2c-2.9", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"deskutils/logjam", "pkgname"=>"logjam-4.6.2_4", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"devel/geany-plugins-l10n", "pkgname"=>"geany-plugins-l10n-1.23", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"devel/libvirt-glib", "pkgname"=>"libvirt-glib-0.1.8_2", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"finance/homebank", "pkgname"=>"homebank-4.6.3", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"ftp/wzdftpd", "pkgname"=>"wzdftpd-0.8.3_2", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"games/bygfoot", "pkgname"=>"bygfoot-2.2.1_7", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"games/gbottler", "pkgname"=>"gbottler-0.1.7_1", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"games/ggz-sdl-games", "pkgname"=>"ggz-sdl-games-0.0.14.1_9", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"games/scourge", "pkgname"=>"scourge-0.21.1_11", "phase"=>"build", "errortype"=>"makefile"}
+ {"origin"=>"games/xboard-devel", "pkgname"=>"xboard-devel-4.7.3.20140909.8", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"graphics/gtkam", "pkgname"=>"gtkam-0.2.0_1", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"japanese/fcitx-mozc", "pkgname"=>"ja-fcitx-mozc-1.15.1868.102_2", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"japanese/im-ja", "pkgname"=>"ja-im-ja-1.5_11", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"japanese/mecab", "pkgname"=>"ja-mecab-0.996_2", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"korean/gtkcomm", "pkgname"=>"ko-gtkcomm-0.8.1_1", "phase"=>"build", "errortype"=>"clang"}
+ {"origin"=>"mail/faces", "pkgname"=>"faces-1.7.7_10", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"mail/milter-manager", "pkgname"=>"milter-manager-2.0.4", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"math/galculator", "pkgname"=>"galculator-2.1.3", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"misc/gnome-devel-docs", "pkgname"=>"gnome-devel-docs-2.32.0", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"misc/gnome-icon-theme", "pkgname"=>"gnome-icon-theme-3.6.2", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"misc/gnome-user-docs", "pkgname"=>"gnome-user-docs-2.32.0", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"misc/lingoteach", "pkgname"=>"lingoteach-0.3.9_15", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"multimedia/audiopreview", "pkgname"=>"audiopreview-0.6_1", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"multimedia/handbrake", "pkgname"=>"handbrake-0.9.9_2", "phase"=>"build", "errortype"=>"configure_error"}
+ {"origin"=>"multimedia/pitivi", "pkgname"=>"pitivi-0.13.4.2_3", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"net-im/licq-osd", "pkgname"=>"licq-osd-1.8.2,1", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"net-im/telepathy-logger", "pkgname"=>"telepathy-logger-0.4.0_3", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"net-p2p/linuxdcpp", "pkgname"=>"linuxdcpp-1.1.0_3", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"net-p2p/microdc2", "pkgname"=>"microdc2-0.15.6_5", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"net/minidlna", "pkgname"=>"minidlna-1.1.4,1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"net/remmina-plugin-i18n", "pkgname"=>"remmina-plugin-i18n-1.0.0_4", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"science/chemical-mime-data", "pkgname"=>"chemical-mime-data-0.1.94_6", "phase"=>"package", "errortype"=>"install_error"}
+ {"origin"=>"security/gringotts", "pkgname"=>"gringotts-1.2.10_3", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"security/gtkpasman", "pkgname"=>"gtkpasman-0.12.1", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"security/openvas-client", "pkgname"=>"openvas-client-2.0.4_4", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"security/openvpn-admin", "pkgname"=>"openvpn-admin-1.9.4_5", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"security/suricata", "pkgname"=>"suricata-2.0.3", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"sysutils/e2fsprogs", "pkgname"=>"e2fsprogs-1.42.12_1", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"sysutils/libgksu", "pkgname"=>"libgksu-2.0.12_1", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"sysutils/policykit", "pkgname"=>"policykit-0.9_8", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"sysutils/system-tools-backends", "pkgname"=>"system-tools-backends-2.10.1_1", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"textproc/gtk-doc", "pkgname"=>"gtk-doc-1.18_1", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"textproc/hs-html-conduit", "pkgname"=>"hs-html-conduit-1.1.0.5_1", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"textproc/libtranslate", "pkgname"=>"libtranslate-0.99_7", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"textproc/openjade", "pkgname"=>"openjade-1.3.3p1_3", "phase"=>"build", "errortype"=>"linker_error"}
+ {"origin"=>"textproc/uim-el", "pkgname"=>"uim-el-emacs24-1.8.6_1", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"www/cherokee", "pkgname"=>"cherokee-1.2.104", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"www/cssed", "pkgname"=>"cssed-0.4.0_9", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"www/sarg", "pkgname"=>"sarg-2.3.9", "phase"=>"stage", "errortype"=>"???"}
+ {"origin"=>"x11-fonts/font-manager", "pkgname"=>"font-manager-0.5.7_5", "phase"=>"build", "errortype"=>"coredump"}
+ {"origin"=>"x11-themes/gtk-murrine-engine", "pkgname"=>"gtk-murrine-engine-0.98.2_4", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"x11-themes/icons-tango", "pkgname"=>"icons-tango-0.8.90_2", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"x11-themes/nimbus", "pkgname"=>"nimbus-0.1.7_2", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"x11-toolkits/wxgtk28-common", "pkgname"=>"wx28-gtk2-common-2.8.12_4", "phase"=>"stage", "errortype"=>"process_failed"}
+ {"origin"=>"x11-wm/libcompizconfig", "pkgname"=>"libcompizconfig-0.8.8", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"x11/wdm", "pkgname"=>"wdm-1.28_13", "phase"=>"package", "errortype"=>"PLIST"}
Comment 8 Tijl Coosemans freebsd_committer 2014-10-13 18:44:32 UTC
Created attachment 148271 [details]
patch4

This patch should fix the errors above.  There were two main classes of errors:
- ports that use the gettext tools but didn't have a build dependency on them
- crashes in gettext libraries when they tried to detect if threads were available or not

I've added patches to the gettext ports to fix the crashes on FreeBSD 9.1 and later.  On older versions and DragonFly threading support has been disabled again (as in the old gettext port).

A full exp-run is needed.
Comment 9 Antoine Brodin freebsd_committer 2014-10-13 19:32:25 UTC
I am not sure about a few changes:

% pkg query -F /poudriere/data/packages/head-amd64-default-baseline/All/clementine-player-1.2.3_7.txz %B | grep intl
libintl.so.9

% pkg query -F /poudriere/data/packages/head-amd64-default-baseline/All/tarantool-1.5.3.txz  %B | grep intl
libintl.so.9

% pkg query -F /poudriere/data/packages/head-amd64-default-baseline/All/telepathy-logger-0.4.0_3.txz  %B | grep intl
libintl.so.9

% pkg query -F /poudriere/data/packages/head-amd64-default-baseline/All/system-tools-backends-2.10.1_1.txz  %B | grep intl
libintl.so.9

% pkg query -F /poudriere/data/packages/head-amd64-default-baseline/All/wx28-gtk2-2.8.12_4.txz  %B | grep intl
libintl.so.9
Comment 10 Tijl Coosemans freebsd_committer 2014-10-13 21:09:16 UTC
Created attachment 148280 [details]
patch5

I've only changed tarantool to USES=gettext:
- clementine-player: uses gettext tools to create Qt translation files.  Overlinks to libintl when GIO option is enabled because "pkgconf --libs glib-2.0" includes -lintl
- tarantool: does indeed link to libintl in src/CMakeLists.txt
- telepathy-logger: overlinks to libintl via glib, but doesn't use translations in C source code, only in gschema file
- system-tools-backends: overlinks to libintl via glib, but doesn't use translations in C source code, only in gschema file
- wx28-gtk2: overlinks to libintl via gtk/glib.  Contains its own (gettext compatible) parser for message catalogs (*.mo files).  wx28-gtk2-common port uses gettext tools to generate *.mo files.
Comment 11 Baptiste Daroussin freebsd_committer 2014-10-13 21:46:34 UTC
this looks rather complicated for maintainers while technical going in the right direction, I am just catching up on this, I'll try to see if we can simplify the user view of it
Comment 12 Tijl Coosemans freebsd_committer 2014-10-13 22:21:48 UTC
Most ports will just continue to use USES=gettext, a lib dependency on libintl and a build dependency on gettext development tools.  And then I think it's just a matter of understanding what devel/gettext-runtime provides and what devel/gettext-tools provides.

gettext-runtime: libraries (libintl.so) and programs needed at runtime so programs can display messages in the locale of the user.  Typically you need a lib or run dependency on this.  USES=gettext-runtime allows you to set build, run and/or lib dependencies on this port.  By default USES=gettext-runtime adds a lib dependency.

gettext-tools: development tools for instance to extract strings from source code or to create or update translations.  Typically you only need a build dependency on this.  USES=gettext-tools allows you to set build and/or run dependencies on this port.  By default USES=gettext-tools adds a build dependency.

USES=gettext is a shorthand for "USES=gettext-runtime gettext-tools", the most common case.
Comment 13 Antoine Brodin freebsd_committer 2014-10-14 22:56:21 UTC
I would like to wait that gnome 3.12 (PR 190676) is ready and has entered the tree before doing the exp-run again, to avoid lost fixes.
Comment 14 Tijl Coosemans freebsd_committer 2014-11-23 15:20:15 UTC
Created attachment 149748 [details]
patch6

Rebased against r373142.
Comment 15 Baptiste Daroussin freebsd_committer 2014-11-24 09:42:20 UTC
I could not find easier, let's go with that version :)
Comment 16 Antoine Brodin freebsd_committer 2014-11-25 08:52:56 UTC
Exp-run results:

http://package18.nyi.freebsd.org/build.html?mastername=101amd64-default-PR194038&build=2014-11-24_13h43m47s

New failures:

+ {"origin"=>"audio/kstreamripper", "pkgname"=>"kstreamripper-0.7.1_5", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"audio/pavucontrol", "pkgname"=>"pavucontrol-0.9.10_2", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"audio/streamtuner", "pkgname"=>"streamtuner-0.99.99_20", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"deskutils/basket", "pkgname"=>"basket-1.81_4", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"deskutils/fusenshi", "pkgname"=>"fusenshi-0.9.0_13", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"deskutils/homerun", "pkgname"=>"homerun-0.2.3", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"deskutils/kchmviewer-kde4", "pkgname"=>"kchmviewer-7.1", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"deskutils/kdeconnect", "pkgname"=>"kdeconnect-kde-0.7.2", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"devel/appstream-glib", "pkgname"=>"appstream-glib-0.2.6", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"devel/poxml", "pkgname"=>"poxml-4.14.2", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"editors/gwrite", "pkgname"=>"gwrite-0.5.1_3", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"editors/kile-kde4", "pkgname"=>"kile-2.1.3_4", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"editors/klat4", "pkgname"=>"klat4-0.6.1_13", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"finance/moneymanagerex", "pkgname"=>"mmex-0.9.9.0_1", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"graphics/kcoloredit", "pkgname"=>"kcoloredit-2.0.0.4.4.0_5", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"graphics/kiconedit", "pkgname"=>"kiconedit-4.4.0_5", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"graphics/skanlite", "pkgname"=>"skanlite-1.1_3", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"japanese/fcitx-mozc", "pkgname"=>"ja-fcitx-mozc-1.15.1868.102_2", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"misc/gnome-devel-docs", "pkgname"=>"gnome-devel-docs-3.14.1", "phase"=>"build", "errortype"=>"process_failed"}
+ {"origin"=>"multimedia/kmplayer-kde4", "pkgname"=>"kmplayer-kde4-0.11.3d_3,3", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"multimedia/xbmc", "pkgname"=>"xbmc-13.2_5", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"net-im/finch", "pkgname"=>"finch-2.10.10_6", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"net-im/pidgin", "pkgname"=>"pidgin-2.10.10_1", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"net/grilo-plugins", "pkgname"=>"grilo-plugins-0.2.13", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"net/knemo-kde4", "pkgname"=>"knemo-0.7.6_4", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"net/kwooty", "pkgname"=>"kwooty-0.8.3_4", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"net/libzapojit", "pkgname"=>"libzapojit-0.0.3_1", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"net/liferea", "pkgname"=>"liferea-1.10.8_3", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"sysutils/k3b-kde4", "pkgname"=>"k3b-2.0.2_21", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"sysutils/kdirstat", "pkgname"=>"kdirstat-2.7.5_2", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"sysutils/krename-kde4", "pkgname"=>"krename-4.0.9_8", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"sysutils/kshutdown-kde4", "pkgname"=>"kshutdown-3.2", "phase"=>"build", "errortype"=>"???"}
+ {"origin"=>"sysutils/plasma-applet-apcups", "pkgname"=>"plasma-applet-apcups-0.2.1_3", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"www/rekonq", "pkgname"=>"rekonq-2.4.2_3", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"x11-fm/rox-session", "pkgname"=>"rox-session-0.40.0_2", "phase"=>"package", "errortype"=>"PLIST"}
+ {"origin"=>"x11-themes/adwaita-icon-theme", "pkgname"=>"adwaita-icon-theme-3.14.0", "phase"=>"configure", "errortype"=>"configure_error"}
+ {"origin"=>"x11-themes/kde-gtk-config", "pkgname"=>"kde-gtk-config-2.2.1_3", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"x11-themes/kde4-style-polyester", "pkgname"=>"kde4-style-polyester-2.0.0_9", "phase"=>"configure", "errortype"=>"???"}
+ {"origin"=>"x11-themes/qtcurve-kde4", "pkgname"=>"kde4-style-qtcurve-1.8.14_4", "phase"=>"package", "errortype"=>"PLIST"}

Failure logs:

http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kstreamripper-0.7.1_5.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/pavucontrol-0.9.10_2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/streamtuner-0.99.99_20.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/basket-1.81_4.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/fusenshi-0.9.0_13.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/homerun-0.2.3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kchmviewer-7.1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kdeconnect-kde-0.7.2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/appstream-glib-0.2.6.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/poxml-4.14.2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/gwrite-0.5.1_3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kile-2.1.3_4.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/klat4-0.6.1_13.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/mmex-0.9.9.0_1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kcoloredit-2.0.0.4.4.0_5.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kiconedit-4.4.0_5.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/skanlite-1.1_3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/ja-fcitx-mozc-1.15.1868.102_2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/gnome-devel-docs-3.14.1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kmplayer-kde4-0.11.3d_3,3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/xbmc-13.2_5.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/finch-2.10.10_6.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/pidgin-2.10.10_1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/grilo-plugins-0.2.13.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/knemo-0.7.6_4.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kwooty-0.8.3_4.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/libzapojit-0.0.3_1.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/liferea-1.10.8_3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/k3b-2.0.2_21.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kdirstat-2.7.5_2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/krename-4.0.9_8.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kshutdown-3.2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/plasma-applet-apcups-0.2.1_3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/rekonq-2.4.2_3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/rox-session-0.40.0_2.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/adwaita-icon-theme-3.14.0.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kde-gtk-config-2.2.1_3.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kde4-style-polyester-2.0.0_9.log
http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-24_13h43m47s/logs/errors/kde4-style-qtcurve-1.8.14_4.log
Comment 17 Tijl Coosemans freebsd_committer 2014-11-25 13:59:10 UTC
Created attachment 149825 [details]
patch7

This patch should fix the above errors.
Comment 18 Antoine Brodin freebsd_committer 2014-11-25 18:05:55 UTC
Hi,
For x11-themes/adwaita-icon-theme,  isn't something like intlhack needed too?  currently it creates lots of empty directories in lib/locale/
Comment 19 Tijl Coosemans freebsd_committer 2014-11-25 20:08:12 UTC
Created attachment 149851 [details]
patch8

x11-themes/adwaita-icon-theme:
- Add USE_GNOME=intlhack
- Add CONFIGURE_ARGS=ac_cv_path_GTK_ENCODE_SYMBOLIC_SVG=false so 
gtk-encode-symbolic-svg from gtk30 is never detected
Comment 20 Antoine Brodin freebsd_committer 2014-11-26 19:02:05 UTC
Exp-run results:

http://package18.nyi.freebsd.org/build.html?mastername=101amd64-default-PR194038&build=2014-11-26_00h01m25s

1 new failure:

+ {"origin"=>"devel/appstream-glib", "pkgname"=>"appstream-glib-0.2.6_1", "phase"=>"package", "errortype"=>"PLIST"}

failure log:

http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-26_00h01m25s/logs/errors/appstream-glib-0.2.6_1.log
Comment 21 Tijl Coosemans freebsd_committer 2014-11-26 19:52:43 UTC
Created attachment 149912 [details]
patch9

devel/appstream-glib:
- Patch configure after generating it.  The configure script is generated in pre-configure so USE_GNOME=intlhack has no effect.
Comment 22 Antoine Brodin freebsd_committer 2014-11-26 20:28:00 UTC
New failure:

+ {"origin"=>"devel/appdata-tools", "pkgname"=>"appdata-tools-0.1.8", "phase"=>"configure", "errortype"=>"???"}

Failure log:

http://package18.nyi.freebsd.org/data/101amd64-default-PR194038/2014-11-26_20h03m24s/logs/errors/appdata-tools-0.1.8.log
Comment 23 Tijl Coosemans freebsd_committer 2014-11-27 08:24:40 UTC
Created attachment 149933 [details]
patch10

Fix devel/appdata-tools like devel/appstream_glib.  Also add USES=gettext to games/aisleriot.
Comment 24 Antoine Brodin freebsd_committer 2014-11-29 06:54:30 UTC
On freebsd 9,  there is 1 new failure (port is broken on 10):

+ {"origin"=>"multimedia/bombono", "pkgname"=>"bombono-1.2.2_5", "phase"=>"build", "errortype"=>"process_failed"}

Failure log:

http://package22.nyi.freebsd.org/data/91amd64-default-PR194038/2014-11-29_06h12m58s/logs/errors/bombono-1.2.2_5.log
Comment 25 Tijl Coosemans freebsd_committer 2014-11-29 12:00:37 UTC
Created attachment 149987 [details]
patch11

Add USES=gettext to multimedia/bombono
Comment 26 Antoine Brodin freebsd_committer 2014-11-29 12:08:32 UTC
ok approved
Comment 27 commit-hook freebsd_committer 2014-11-29 18:23:14 UTC
A commit references this bug:

Author: tijl
Date: Sat Nov 29 18:22:45 UTC 2014
New revision: 373636
URL: https://svnweb.freebsd.org/changeset/ports/373636

Log:
  Split devel/gettext in devel/gettext-runtime and devel/gettext-tools.  The
  first contains runtime libraries such as libintl and the latter contains
  developer tools such as msgfmt.  Ports that use gettext will usually need
  a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools.

  USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on
  devel/gettext-runtime and USES=gettext-tools can be used to set a
  BUILD/RUN_DEPENDS on devel/gettext-tools.  USES=gettext is now the same
  as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on
  devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools.

  Update gettext to 0.19.3.

  Remove :oldver from converters/libiconv and devel/gettext-runtime.  Leave
  symlinks with the old library versions to avoid the need to bump
  PORTREVISION on a large number of dependent ports.  When most of the
  dependent ports have had normal version updates, PORTREVISION can be
  bumped on the remaining ones (low number) and the links can be removed.

  Fix some ports that installed files in lib/locale instead of share/locale.

  PR:		194038
  Reviewed by:	bapt
  Exp-run:	antoine
  Approved by:	portmgr (antoine)

Changes:
  head/CHANGES
  head/Mk/Uses/autoreconf.mk
  head/Mk/Uses/gettext-runtime.mk
  head/Mk/Uses/gettext-tools.mk
  head/Mk/Uses/gettext.mk
  head/UPDATING
  head/archivers/gtar/Makefile
  head/audio/clementine-player/Makefile
  head/audio/gbemol/Makefile
  head/audio/gkrellmms2/Makefile
  head/audio/gkrellmss2/Makefile
  head/audio/gkrellmvolume2/Makefile
  head/audio/kstreamripper/Makefile
  head/audio/pavucontrol/Makefile
  head/audio/pavucontrol/pkg-plist
  head/audio/pms/Makefile
  head/audio/streamtuner/Makefile
  head/comms/xnec2c/Makefile
  head/converters/libiconv/Makefile
  head/converters/libiconv/files/patch-lib_Makefile.in
  head/converters/libiconv/files/patch-src__Makefile.in
  head/converters/libiconv/pkg-plist
  head/databases/tarantool/Makefile
  head/deskutils/basket/Makefile
  head/deskutils/fusenshi/Makefile
  head/deskutils/homerun/Makefile
  head/deskutils/kchmviewer-kde4/Makefile
  head/deskutils/kdeconnect/Makefile
  head/deskutils/logjam/Makefile
  head/devel/appdata-tools/Makefile
  head/devel/appdata-tools/pkg-plist
  head/devel/appstream-glib/Makefile
  head/devel/appstream-glib/pkg-plist
  head/devel/avr-libc/Makefile
  head/devel/geany-plugins/files/Makefile.common
  head/devel/gettext/Makefile
  head/devel/gettext/Makefile.common
  head/devel/gettext/distinfo
  head/devel/gettext/files/
  head/devel/gettext/pkg-descr
  head/devel/gettext/pkg-plist
  head/devel/gettext-lint/Makefile
  head/devel/gettext-runtime/
  head/devel/gettext-runtime/Makefile
  head/devel/gettext-runtime/files/
  head/devel/gettext-runtime/files/patch-configure
  head/devel/gettext-runtime/files/patch-intl-threadlib.c
  head/devel/gettext-runtime/pkg-descr
  head/devel/gettext-runtime/pkg-plist
  head/devel/gettext-tools/
  head/devel/gettext-tools/Makefile
  head/devel/gettext-tools/files/
  head/devel/gettext-tools/files/patch-configure
  head/devel/gettext-tools/files/patch-gnulib-lib_glthread_threadlib.c
  head/devel/gettext-tools/files/patch-libgettextpo_glthread_threadlib.c
  head/devel/gettext-tools/pkg-descr
  head/devel/gettext-tools/pkg-plist
  head/devel/libvirt-glib/Makefile
  head/devel/poxml/Makefile
  head/devel/py-itools/Makefile
  head/devel/subversion/Makefile
  head/devel/subversion17/Makefile
  head/editors/gwrite/Makefile
  head/editors/kile-kde4/Makefile
  head/editors/klat4/Makefile
  head/finance/homebank/Makefile
  head/finance/moneymanagerex/Makefile
  head/ftp/wzdftpd/Makefile
  head/games/aisleriot/Makefile
  head/games/anki/Makefile
  head/games/bygfoot/Makefile
  head/games/bygfoot/files/
  head/games/cuyo/Makefile
  head/games/gbottler/Makefile
  head/games/ggz-sdl-games/Makefile
  head/games/gnomebreakout/Makefile
  head/games/live-f1/Makefile
  head/games/pythonsudoku/Makefile
  head/games/scourge/Makefile
  head/games/unknown-horizons/Makefile
  head/games/xboard-devel/Makefile
  head/graphics/digikam-kde4-l10n/Makefile
  head/graphics/gtkam/Makefile
  head/graphics/kcoloredit/Makefile
  head/graphics/kiconedit/Makefile
  head/graphics/libGL/bsd.mesalib.mk
  head/graphics/skanlite/Makefile
  head/japanese/im-ja/Makefile
  head/japanese/mecab/Makefile
  head/japanese/mecab/files/
  head/japanese/mecab/pkg-plist
  head/japanese/mozc-server/Makefile
  head/korean/gtkcomm/Makefile
  head/lang/gcc-aux/Makefile
  head/lang/gcc47-aux/Makefile
  head/mail/faces/Makefile
  head/mail/milter-manager/Makefile
  head/math/galculator/Makefile
  head/misc/gimp-help-en/Makefile
  head/misc/gnome-devel-docs/Makefile
  head/misc/gnome-icon-theme/Makefile
  head/misc/gnome-user-docs/Makefile
  head/misc/pinfo/Makefile
  head/multimedia/audiopreview/Makefile
  head/multimedia/bombono/Makefile
  head/multimedia/handbrake/Makefile
  head/multimedia/kmplayer-kde4/Makefile
  head/multimedia/pitivi/Makefile
  head/multimedia/xbmc/Makefile
  head/net/grilo-plugins/Makefile
  head/net/knemo-kde4/Makefile
  head/net/kwooty/Makefile
  head/net/libzapojit/Makefile
  head/net/liferea/Makefile
  head/net/minidlna/Makefile
  head/net/remmina-plugin-i18n/Makefile
  head/net/remmina-plugins/bsd.plugin.mk
  head/net-im/libpurple/Makefile
  head/net-im/libpurple/pkg-plist
  head/net-im/licq-osd/Makefile
  head/net-im/pidgin/Makefile
  head/net-im/telepathy-logger/Makefile
  head/net-mgmt/monitoring-plugins/Makefile
  head/net-mgmt/nagios-plugins/Makefile
  head/net-p2p/linuxdcpp/Makefile
  head/science/chemical-mime-data/Makefile
  head/science/chemical-mime-data/pkg-plist
  head/security/clamtk/Makefile
  head/security/gringotts/Makefile
  head/security/gtkpasman/Makefile
  head/security/openvpn-admin/Makefile
  head/sysutils/froxlor/Makefile
  head/sysutils/k3b-kde4/Makefile
  head/sysutils/kdirstat/Makefile
  head/sysutils/krename-kde4/Makefile
  head/sysutils/kshutdown-kde4/Makefile
  head/sysutils/libgksu/Makefile
  head/sysutils/plasma-applet-apcups/Makefile
  head/sysutils/policykit/Makefile
  head/sysutils/system-tools-backends/Makefile
  head/textproc/gnome-doc-utils/Makefile
  head/textproc/gtk-doc/Makefile
  head/textproc/libtranslate/Makefile
  head/textproc/libtranslate/files/patch-configure
  head/textproc/libtranslate/pkg-plist
  head/textproc/openjade/Makefile
  head/textproc/openjade/files/patch-Makefile.comm.in
  head/textproc/uim-el/Makefile
  head/www/cssed/Makefile
  head/www/py-formencode/Makefile
  head/www/rekonq/Makefile
  head/www/sarg/Makefile
  head/x11/wdm/Makefile
  head/x11/xkeyboard-config/Makefile
  head/x11-fm/rox-session/Makefile
  head/x11-themes/adwaita-icon-theme/Makefile
  head/x11-themes/gnome-themes-standard/Makefile
  head/x11-themes/gtk-murrine-engine/Makefile
  head/x11-themes/icons-tango/Makefile
  head/x11-themes/kde-gtk-config/Makefile
  head/x11-themes/kde4-style-polyester/Makefile
  head/x11-themes/nimbus/Makefile
  head/x11-themes/qtcurve-kde4/Makefile
  head/x11-toolkits/wxgtk28/Makefile
  head/x11-wm/libcompizconfig/Makefile