Bug 194130 - lang/expect: manpage conflicts with net/whois
Summary: lang/expect: manpage conflicts with net/whois
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Martin Wilke
URL:
Keywords: needs-patch, needs-qa
: 194129 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-04 00:47 UTC by Walter Schwarzenfeld
Modified: 2016-01-17 12:44 UTC (History)
5 users (show)

See Also:
koobs: maintainer-feedback? (tcltk)
koobs: maintainer-feedback? (coco)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Schwarzenfeld freebsd_triage 2014-10-04 00:47:43 UTC
FreeBSD-9.3 amd64
lang/expect:
Registering installation for expect-5.45_1
pkg-static: expect-5.45_1 conflicts with whois-5.1.5 (installs files into the same place).  Problematic file: /usr/local/man/man1/mkpasswd.1.gz
*** [fake-pkg] Error code 70

Same with net/whois.

(If I am remember right, seems an old bug).
Comment 1 Warren Block freebsd_committer 2014-10-04 03:45:27 UTC
This is a ports issue.
Comment 2 Walter Schwarzenfeld freebsd_triage 2014-10-07 21:15:14 UTC
sometimes I wonder: where's the problem:

changed in net/whois/files/patch-Makefile to

install-mkpasswd: mkpasswd
        $(INSTALL) -d $(BASEDIR)$(prefix)/bin/
-       $(INSTALL) -d $(BASEDIR)$(prefix)/share/man/man1/
+       $(INSTALL) -d $(BASEDIR)$(prefix)/man/man2/
        $(INSTALL) -m 0755 mkpasswd $(BASEDIR)$(prefix)/bin/
-       $(INSTALL) -m 0644 mkpasswd.1 $(BASEDIR)$(prefix)/share/man/man1/
+       $(INSTALL) -m 0644 mkpasswd.1 $(BASEDIR)$(prefix)/man/man2/


and in net/whois/pkg-plist the line
to
man/man2/mkpasswd.1.gz


maybe I choosed the wrong man-directory, but and it's solved.
Comment 3 John Marino freebsd_committer 2014-10-31 18:09:14 UTC
*** Bug 194129 has been marked as a duplicate of this bug. ***
Comment 4 John Marino freebsd_committer 2014-10-31 18:11:11 UTC
notifying maintainer of net/whois
Comment 5 Marco Steinbach 2014-11-12 21:50:03 UTC
Hi.

Thanks for the report and notification -- I'm on it.
Comment 6 Mark Linimon freebsd_committer freebsd_triage 2014-11-23 07:59:59 UTC
Notify maintainers of lang/expect, too.
Comment 7 Walter Schwarzenfeld freebsd_triage 2015-04-02 22:32:53 UTC
Nothing happened till now.
Comment 8 Martin Wilke freebsd_committer 2016-01-16 06:38:41 UTC
Hey,

Still valid I guess?
Comment 9 w.schwarzenfeld 2016-01-16 10:38:47 UTC
Yes, nothing changed.
Comment 10 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-16 15:44:12 UTC
Request feedback from both maintainers
Comment 11 Kubilay Kocak freebsd_committer freebsd_triage 2016-01-16 15:45:37 UTC
@Martin, feel free to maintainer timeout both (since they were CC'd)
Comment 12 commit-hook freebsd_committer 2016-01-17 12:39:17 UTC
A commit references this bug:

Author: gahr
Date: Sun Jan 17 12:38:25 UTC 2016
New revision: 406307
URL: https://svnweb.freebsd.org/changeset/ports/406307

Log:
  lang/expect: install manpages along with sample tools

  PR:		194130
  Submitted by:	w.schwarzenfeld@utanet.at

Changes:
  head/lang/expect/Makefile
  head/lang/expect/files/patch-Makefile.in
  head/lang/expect/files/patch-configure
  head/lang/expect/files/patch-exp_main_sub.c
  head/lang/expect/pkg-plist
Comment 13 w.schwarzenfeld 2016-01-17 12:44:58 UTC
Thank you!