Bug 194139 - devel/liballium: fix style and add TEST option
Summary: devel/liballium: fix style and add TEST option
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: John Marino
URL:
Keywords:
: 194138 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-04 11:00 UTC by Jan Beich
Modified: 2014-10-31 13:27 UTC (History)
2 users (show)

See Also:
fk: maintainer-feedback+


Attachments
fix (886 bytes, patch)
2014-10-04 11:01 UTC, Jan Beich
no flags Details | Diff
|poudriere testport -P| log (9.3R i386) (29.13 KB, text/plain)
2014-10-04 11:03 UTC, Jan Beich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2014-10-04 11:00:44 UTC
See bug 187926 comment 32 for belated review of new port. Also, properly use pathfix.
Comment 1 Bugzilla Automation freebsd_committer 2014-10-04 11:00:44 UTC
Maintainer CC'd
Comment 2 Jan Beich freebsd_committer 2014-10-04 11:01:04 UTC
Created attachment 147963 [details]
fix
Comment 3 Jan Beich freebsd_committer 2014-10-04 11:03:21 UTC
Created attachment 147964 [details]
|poudriere testport -P| log (9.3R i386)
Comment 4 Jan Beich freebsd_committer 2014-10-04 11:04:52 UTC
I haven't fixed the following because it's up to maintainer whether to break partial updates per changes from 20140922.

pkg-static: Warning: @dirrm is deprecated please use @dir
pkg-static: Warning: @dirrm is deprecated please use @dir
Comment 5 Jan Beich freebsd_committer 2014-10-04 11:05:50 UTC
Err, /usr/ports/CHANGES at 20140922.
Comment 6 Fabian Keil 2014-10-04 11:33:16 UTC
Thanks for the hereby approved patch and the review on #187926.

I don't mind keeping the @dirrm directives until Redports properly deals with @dir.
Comment 7 Jan Beich freebsd_committer 2014-10-04 21:08:23 UTC
*** Bug 194138 has been marked as a duplicate of this bug. ***
Comment 8 John Marino freebsd_committer 2014-10-08 17:48:53 UTC
maintainer approved.  @dirrm should be remove though.
Comment 9 John Marino freebsd_committer 2014-10-27 15:52:07 UTC
I'll take it.
Comment 10 commit-hook freebsd_committer 2014-10-31 13:27:14 UTC
A commit references this bug:

Author: marino
Date: Fri Oct 31 13:26:35 UTC 2014
New revision: 371818
URL: https://svnweb.freebsd.org/changeset/ports/371818

Log:
  devel/liballium: Fix style and add TEST option

  PR:		194139
  Submitted by:	Jan Beich
  Approved by:	maintainer

Changes:
  head/devel/liballium/Makefile
Comment 11 John Marino freebsd_committer 2014-10-31 13:27:58 UTC
Thanks!  bapt already removed the @dirrm lines in an earlier commit.