Bug 194205 - [MAINTAINER-UPDATE] mail/nullmailer: broken - pkg-plist error
Summary: [MAINTAINER-UPDATE] mail/nullmailer: broken - pkg-plist error
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Baptiste Daroussin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-06 22:57 UTC by Uffe Jakobsen
Modified: 2014-10-17 23:42 UTC (History)
2 users (show)

See Also:


Attachments
nullmailer.patch.txt (1.01 KB, patch)
2014-10-06 22:57 UTC, Uffe Jakobsen
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Uffe Jakobsen 2014-10-06 22:57:57 UTC
Created attachment 148051 [details]
nullmailer.patch.txt

mail/nullmailer does not work any more:

new mails are queued into the queue but cannot be dequeued/sent


reason: svn change r369019 by bapt have broken mail/nullmailer


r369019 | bapt | 2014-09-23 11:56:54 +0200 (Tue, 23 Sep 2014) | 2 lines
Changed paths:
   M /head/mail/nullmailer/pkg-plist

Simplify plist


If you inspect the change to pkg-plist in svn r369019 - you'll see that the simplifications to pkg-plist does preserve all the features of the previous list.

Patch attached
Comment 1 John Marino freebsd_committer 2014-10-08 18:46:53 UTC
I don't know about this.  Assigning to bapt since you say he broke it.
Comment 2 Christoph H. Larsen 2014-10-09 21:05:33 UTC
Comment on attachment 148051 [details]
nullmailer.patch.txt

I can confirm the bug (actually reported it directly to Uffe today). 
The patch above look good - this should be committed, because the current version of nullmailer is completely dysfunctional, as described by Uffe.
Comment 3 Uffe Jakobsen 2014-10-15 08:48:57 UTC
Any news on this ?
Comment 4 mike 2014-10-17 21:23:12 UTC
How did bapt's patch make it in? How does the testing for this kind of thing get done?
Comment 5 commit-hook freebsd_committer 2014-10-17 23:33:42 UTC
A commit references this bug:

Author: bapt
Date: Fri Oct 17 23:33:09 UTC 2014
New revision: 371086
URL: https://svnweb.freebsd.org/changeset/ports/371086

Log:
  MFH: r371085

  Fix plist

  PR:		194205
  Pointyhat to:	bapt

Changes:
_U  branches/2014Q4/
  branches/2014Q4/mail/nullmailer/Makefile
  branches/2014Q4/mail/nullmailer/pkg-plist
Comment 6 commit-hook freebsd_committer 2014-10-17 23:35:44 UTC
A commit references this bug:

Author: bapt
Date: Fri Oct 17 23:35:23 UTC 2014
New revision: 371087
URL: https://svnweb.freebsd.org/changeset/ports/371087

Log:
  Fix harder

  PR:		194205

Changes:
  head/mail/nullmailer/pkg-plist
Comment 7 commit-hook freebsd_committer 2014-10-17 23:36:46 UTC
A commit references this bug:

Author: bapt
Date: Fri Oct 17 23:36:26 UTC 2014
New revision: 371088
URL: https://svnweb.freebsd.org/changeset/ports/371088

Log:
  MFH: r371087

  Fix harder

  PR:		194205

Changes:
_U  branches/2014Q4/
  branches/2014Q4/mail/nullmailer/pkg-plist
Comment 8 Baptiste Daroussin freebsd_committer 2014-10-17 23:42:22 UTC
Two screw on the same port, sorry about that, it should be fixed now.