Bug 194326 - [maintainer] www/subsonic: update to 5.0
Summary: [maintainer] www/subsonic: update to 5.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-13 06:26 UTC by Nicole Reid
Modified: 2014-10-26 07:24 UTC (History)
2 users (show)

See Also:


Attachments
Subsonic 5.0 port diff (7.62 KB, patch)
2014-10-13 06:26 UTC, Nicole Reid
no flags Details | Diff
Subsonic 5.0 test log (25.21 KB, text/plain)
2014-10-13 06:26 UTC, Nicole Reid
no flags Details
Subsonic 5.0 port diff (7.65 KB, patch)
2014-10-15 02:16 UTC, Nicole Reid
no flags Details | Diff
Subsonic 5.0 test log (26.07 KB, text/plain)
2014-10-15 02:17 UTC, Nicole Reid
no flags Details
Subsonic 5.0 port diff (109.92 KB, patch)
2014-10-25 20:50 UTC, Nicole Reid
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole Reid 2014-10-13 06:26:05 UTC
Created attachment 148227 [details]
Subsonic 5.0 port diff

- Update to 5.0 with new features like Chromecast support. Full changelog: http://www.subsonic.org/pages/changelog.jsp

- Use port skeleton from my www/madsonic to support more container servers
Comment 1 Bugzilla Automation freebsd_committer 2014-10-13 06:26:05 UTC
Maintainer CC'd
Comment 2 Nicole Reid 2014-10-13 06:26:45 UTC
Created attachment 148228 [details]
Subsonic 5.0 test log
Comment 3 Allison Nicole Reid 2014-10-13 06:41:32 UTC
Whoops, I have a duplicate account imported from the old PR system. Maintainer approves maintainer's patch :)
Comment 4 John Marino freebsd_committer 2014-10-14 17:17:41 UTC
This looks fine (I'd probably not modify $FreeBSD$ line in the future though, hopefully svn patch will deal with that)

Moving to patch-ready pool.
Comment 5 Nicole Reid 2014-10-15 02:16:40 UTC
Created attachment 148315 [details]
Subsonic 5.0 port diff

- Fix $FreeBSD$ line that got changed with port skeleton swap
- Add a run dependency on audio/alsa-plugins since jukebox mode can't see audio devices otherwise. Thanks for the report, Matt!
Comment 6 Nicole Reid 2014-10-15 02:17:28 UTC
Created attachment 148316 [details]
Subsonic 5.0 test log

Test log that covers alsa-plugins addition
Comment 7 Thomas Zander freebsd_committer 2014-10-25 07:50:21 UTC
I get a dependency build failure in the process:

===>   subsonic-jetty-5.0 depends on file: /usr/local/openjdk7/bin/java - found
===========================================================================
=======================<phase: stage          >============================
===>  Staging for subsonic-jetty-5.0
===>   subsonic-jetty-5.0 depends on file: /usr/local/share/java/classes/servlet-api.jar - found
===>   subsonic-jetty-5.0 depends on file: /usr/local/lib/alsa-lib/libasound_module_pcm_oss.so - found
===>   subsonic-jetty-5.0 depends on file: /usr/local/jetty/start.jar - found
===>   subsonic-jetty-5.0 depends on executable: ffmpeg - found
===>   subsonic-jetty-5.0 depends on file: /usr/local/openjdk7/bin/java - found
** Missing /usr/ports/www/subsonic/files/message-common.in for subsonic-jetty-5.0.
*** Error code 1

Stop.
make: stopped in /usr/ports/www/subsonic
Comment 8 Nicole Reid 2014-10-25 20:50:37 UTC
Created attachment 148648 [details]
Subsonic 5.0 port diff

Sorry, that was my fault. I neglected to diff with -N and it didn't descend into files/. I confirmed its presence in this diff.
Comment 9 commit-hook freebsd_committer 2014-10-26 07:18:13 UTC
A commit references this bug:

Author: riggs
Date: Sun Oct 26 07:17:20 UTC 2014
New revision: 371497
URL: https://svnweb.freebsd.org/changeset/ports/371497

Log:
  - Update to upstream version 5.0
  - Add LICENSE
  - Introduce OPTIONS for
    - Selecting application server
    - Selecting transcoders

  PR:		194326
  Submitted by:	freebsd@cooltrainer.org (maintainer)

Changes:
  head/www/subsonic/Makefile
  head/www/subsonic/distinfo
  head/www/subsonic/files/message-common.in
  head/www/subsonic/files/message-transcoding.in
  head/www/subsonic/files/pkg-message.in
  head/www/subsonic/pkg-descr
  head/www/subsonic/pkg-message-jetty
  head/www/subsonic/pkg-message-resin3
  head/www/subsonic/pkg-message-spacer
  head/www/subsonic/pkg-message-tomcat
  head/www/subsonic/pkg-plist
  head/www/subsonic/pkg-plist-chunk