Bug 194434 - [PATCH] databases/mariadb55-client update for 5.5.40
Summary: [PATCH] databases/mariadb55-client update for 5.5.40
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: John Marino
URL:
Keywords:
Depends on: 194435
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-17 21:23 UTC by Bernard Spil
Modified: 2014-11-22 18:48 UTC (History)
2 users (show)

See Also:
brnrd: maintainer-feedback? (never)


Attachments
patch mariadb55-client version to 5.5.40 (11.26 KB, patch)
2014-10-17 21:23 UTC, Bernard Spil
no flags Details | Diff
Build log (9.47 KB, application/x-gzip)
2014-10-17 21:25 UTC, Bernard Spil
no flags Details
Patch to upgrade mysql55-client port to 5.5.40 (10.63 KB, patch)
2014-11-16 20:18 UTC, Bernard Spil
no flags Details | Diff
Patch for mariadb55-client (6.52 KB, patch)
2014-11-21 21:25 UTC, Bernard Spil
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Spil freebsd_committer 2014-10-17 21:23:22 UTC
Created attachment 148408 [details]
patch mariadb55-client version to 5.5.40

MariaDB 5.5.40 was released Oct 9 2014
Patch attached, buildlog will follow.
Comment 1 Bugzilla Automation freebsd_committer 2014-10-17 21:23:22 UTC
Maintainer CC'd
Comment 2 Bernard Spil freebsd_committer 2014-10-17 21:25:54 UTC
Created attachment 148409 [details]
Build log
Comment 3 John Marino freebsd_committer 2014-10-17 21:34:33 UTC
*** Bug 194435 has been marked as a duplicate of this bug. ***
Comment 4 John Marino freebsd_committer 2014-10-31 18:47:42 UTC
It's been exactly 14 days, so this PR timed out.  Since other mariadb PRs have are also timed out, I'm moving this to patch-ready now (no maintainer approval needed)
Comment 5 John Marino freebsd_committer 2014-11-13 19:49:20 UTC
this is slightly messed up.
one patch was removed, and then replaced by two different patches with different names.  (three separate entries for cmake/jemalloc.cmake)

let me try to fix this, but I'll kick it back if I can't.  It helps to review the patches with the bugzilla diff viewer.
Comment 6 John Marino freebsd_committer 2014-11-13 20:13:58 UTC
I'm kicking this back to you.  Not only is something strange about the 3 entries cmake/jemalloc.cmake, the patch-scripts_CMakeLists.txt patch does not apply.

Please regenerate the diff against the current tree.
Comment 7 Bernard Spil freebsd_committer 2014-11-16 20:18:10 UTC
Created attachment 149491 [details]
Patch to upgrade mysql55-client port to 5.5.40

There were some issues with the patch, fixed these
Updated CONFLICTS as with the other MySQL/MariaDB/Percona ports

The now committed MariaDB 10.0 port was a nice source as well for jemalloc patch.
Comment 8 John Marino freebsd_committer 2014-11-16 21:12:02 UTC
this one passed but -server failed check-plist.  will post on bug 194435
Comment 9 John Marino freebsd_committer 2014-11-16 21:42:32 UTC
I spoke too soon.  scripts/CMakeLists.txt patch doesn't apply, it rejects.  The port built anyway

I'll repeat and svn update to make sure it's the latest, and post back.
Comment 10 John Marino freebsd_committer 2014-11-16 21:45:05 UTC
reproduced.  You had a reject file in your directory:

--- mariadb55-client.orig/files/patch-scripts_CMakeLists.txt.rej	1970-01-01 01:00:00.000000000 +0100
+++ mariadb55-client/files/patch-scripts_CMakeLists.txt.rej	2014-11-16 20:39:03.569199961 +0100
Comment 11 John Marino freebsd_committer 2014-11-16 21:48:19 UTC
I can remove the from the diff but maybe you meant to patch this file.  can you look again?
Comment 12 Bernard Spil freebsd_committer 2014-11-21 21:25:17 UTC
Created attachment 149694 [details]
Patch for mariadb55-client

Sorry for the unnecessary extra work, the rej file should not be there at all... Learned that kDiff3 by default hides .rej and .orig files!

Revised patch to remove the patch-scripts_CMakeLists.txt.rej bits
Comment 13 commit-hook freebsd_committer 2014-11-22 18:46:40 UTC
A commit references this bug:

Author: marino
Date: Sat Nov 22 18:46:08 UTC 2014
New revision: 373088
URL: https://svnweb.freebsd.org/changeset/ports/373088

Log:
  databases/mariadb55-(client,server): Upgrade version 5.5.39 => 5.5.40

  PR:		194434
  PR:		194435
  Submitted by:	Bernard Spil
  Approved by:	maintainer timeout (Ukraine)

Changes:
  head/databases/mariadb55-client/Makefile
  head/databases/mariadb55-client/files/patch-CMakeLists.txt
  head/databases/mariadb55-client/files/patch-cmake__jemalloc.cmake
  head/databases/mariadb55-client/files/patch-libservices_CMakeLists.txt
  head/databases/mariadb55-client/files/patch-scripts_mysql_config.sh
  head/databases/mariadb55-client/files/patch-support-files_CMakeLists.txt
  head/databases/mariadb55-server/Makefile
  head/databases/mariadb55-server/distinfo
  head/databases/mariadb55-server/files/patch-cmake__jemalloc.cmake
  head/databases/mariadb55-server/pkg-plist
Comment 14 John Marino freebsd_committer 2014-11-22 18:48:54 UTC
Thanks, it built cleanly in poudriere.