Bug 194547 - [patch] freebsd-update(8) do no invoke $PAGER with empty output
Summary: [patch] freebsd-update(8) do no invoke $PAGER with empty output
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL: https://reviews.freebsd.org/D18913
Keywords: patch
: 183579 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-23 08:55 UTC by TEUBEL György
Modified: 2019-03-05 18:24 UTC (History)
3 users (show)

See Also:


Attachments
freebsd-update $PAGER patch (1.46 KB, patch)
2014-10-23 08:55 UTC, TEUBEL György
no flags Details | Diff
freebsd-update.sh $PAGER patch (2.06 KB, patch)
2014-10-23 09:50 UTC, TEUBEL György
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description TEUBEL György 2014-10-23 08:55:23 UTC
Created attachment 148574 [details]
freebsd-update $PAGER patch

freebsd-update(8) utility shows the updatable/deletable etc. files at the fetch stage. This list is displayed using the $PAGER, even when there is no change. This is unnoticeable with more but, when the user sets less as the $PAGER then several empty pages are displayed.

This patch changes the freebsd-update script to invoke $PAGER only if there are displayable information.
Comment 1 TEUBEL György 2014-10-23 09:50:26 UTC
Created attachment 148575 [details]
freebsd-update.sh $PAGER patch

New patch without subshell usage
Comment 2 Derek Schrock 2016-12-30 07:22:59 UTC
dup of Bug 208497?
Comment 3 Ed Maste freebsd_committer 2019-01-21 17:47:06 UTC
*** Bug 183579 has been marked as a duplicate of this bug. ***
Comment 4 commit-hook freebsd_committer 2019-01-24 18:26:55 UTC
A commit references this bug:

Author: emaste
Date: Thu Jan 24 18:26:31 UTC 2019
New revision: 343407
URL: https://svnweb.freebsd.org/changeset/base/343407

Log:
  freebsd-update: open $PAGER only if necessary

  PR:		194547, 208497
  Submitted by:	Gerald Aryeetey <aryeeteygerald_rogers.com>
  Reviewed by:	delphij
  MFC after:	1 month
  Sponsored by:	The FreeBSD Foundation

Changes:
  head/usr.sbin/freebsd-update/freebsd-update.sh
Comment 5 commit-hook freebsd_committer 2019-01-24 20:36:52 UTC
A commit references this bug:

Author: ngie
Date: Thu Jan 24 20:35:59 UTC 2019
New revision: 343412
URL: https://svnweb.freebsd.org/changeset/base/343412

Log:
  Fix a typo/wordsmith a description modified in r343407

  r343407 accidentally introduced a typo (folling -> following). While
  reading the change out loud, I realized that the original sentence was
  wordy. almost sounding like a run-on sentence.

  Improve the flow by splitting up the two thoughts into two distinct sentence
  fragments.

  PR:		194547, 208497
  Reviewed by:	emaste
  Approved by:	emaste (mentor)
  MFC after:	1 month
  MFC with:	r343407
  Differential Revision: https://reviews.freebsd.org/D18947

Changes:
  head/usr.sbin/freebsd-update/freebsd-update.sh
Comment 6 commit-hook freebsd_committer 2019-03-05 18:20:19 UTC
A commit references this bug:

Author: emaste
Date: Tue Mar  5 18:19:27 UTC 2019
New revision: 344803
URL: https://svnweb.freebsd.org/changeset/base/344803

Log:
  MFC r343407: freebsd-update: open $PAGER only if necessary

  PR:		194547, 208497
  Submitted by:	Gerald Aryeetey <aryeeteygerald_rogers.com>
  Reviewed by:	delphij
  Sponsored by:	The FreeBSD Foundation

Changes:
_U  stable/12/
  stable/12/usr.sbin/freebsd-update/freebsd-update.sh
Comment 7 commit-hook freebsd_committer 2019-03-05 18:21:26 UTC
A commit references this bug:

Author: emaste
Date: Tue Mar  5 18:20:17 UTC 2019
New revision: 344804
URL: https://svnweb.freebsd.org/changeset/base/344804

Log:
  MFC r343407: freebsd-update: open $PAGER only if necessary

  PR:		194547, 208497
  Submitted by:   Gerald Aryeetey <aryeeteygerald_rogers.com>
  Reviewed by:	delphij
  Sponsored by:	The FreeBSD Foundation

Changes:
_U  stable/11/
  stable/11/usr.sbin/freebsd-update/freebsd-update.sh