Bug 194571 - [CHANGE-REQUEST] Update games/flightgear and devel/simgear to 3.2
Summary: [CHANGE-REQUEST] Update games/flightgear and devel/simgear to 3.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Ganael LAPLANCHE
URL:
Keywords:
: 194570 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-24 06:53 UTC by Michael Danilov
Modified: 2014-11-03 13:09 UTC (History)
1 user (show)

See Also:


Attachments
games/flightgear (8.10 KB, patch)
2014-10-24 06:55 UTC, Michael Danilov
no flags Details | Diff
games/flightgear-data (980 bytes, patch)
2014-10-24 06:55 UTC, Michael Danilov
no flags Details | Diff
devel/simgear (7.86 KB, patch)
2014-10-24 06:56 UTC, Michael Danilov
no flags Details | Diff
devel/simgear (9.10 KB, patch)
2014-10-29 11:35 UTC, Ganael LAPLANCHE
no flags Details | Diff
games/flightgear-data (1.28 KB, patch)
2014-10-29 11:36 UTC, Ganael LAPLANCHE
no flags Details | Diff
games/flightgear (13.97 KB, patch)
2014-10-29 11:36 UTC, Ganael LAPLANCHE
no flags Details | Diff
games/flightgear-aircraft (5.60 KB, patch)
2014-10-29 11:37 UTC, Ganael LAPLANCHE
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Danilov 2014-10-24 06:53:26 UTC
"Add an attachment" is greyed out, can not attach.
Comment 1 Bugzilla Automation freebsd_committer 2014-10-24 06:53:26 UTC
Maintainers CC'd
Comment 2 Michael Danilov 2014-10-24 06:55:16 UTC
Created attachment 148602 [details]
games/flightgear
Comment 3 Michael Danilov 2014-10-24 06:55:41 UTC
Created attachment 148603 [details]
games/flightgear-data
Comment 4 Michael Danilov 2014-10-24 06:56:05 UTC
Created attachment 148604 [details]
devel/simgear
Comment 5 Michael Danilov 2014-10-24 06:58:46 UTC
*** Bug 194570 has been marked as a duplicate of this bug. ***
Comment 6 Ganael LAPLANCHE freebsd_committer 2014-10-24 07:45:45 UTC
Hi Mike,

Thanks for your patch.

I am already working on updating Simgear & Co. Please be patient, as Simgear does not seem to build on 9.3. I am working on it...

Best regards.
Comment 7 Ganael LAPLANCHE freebsd_committer 2014-10-29 11:35:08 UTC
Created attachment 148760 [details]
devel/simgear
Comment 8 Ganael LAPLANCHE freebsd_committer 2014-10-29 11:36:05 UTC
Created attachment 148761 [details]
games/flightgear-data
Comment 9 Ganael LAPLANCHE freebsd_committer 2014-10-29 11:36:42 UTC
Created attachment 148762 [details]
games/flightgear
Comment 10 Ganael LAPLANCHE freebsd_committer 2014-10-29 11:37:10 UTC
Created attachment 148763 [details]
games/flightgear-aircraft
Comment 11 Ganael LAPLANCHE freebsd_committer 2014-10-29 11:37:28 UTC
Hi Mike,

Find attached to the bug report patches for version 3.2.0 of :

devel/simgear
games/flightgear-data
games/flightgear
games/flightgear-aircraft

Those build successfully on :

8.4 (i386/amd64)
9.3 (i386/amd64)
10.0 (i386/amd64)
11-CURRENT (tested on amd64 only)

Can you tell me if everything builds on your machine, and if the game runs correctly ?

Thanks,
Best regards,

Ganael.
Comment 12 Michael Danilov 2014-11-01 21:25:37 UTC
"make reinstall" does it. Could not check in vitro, because Poudriere does not want to build big packages (flightgear-data).
Comment 13 Ganael LAPLANCHE freebsd_committer 2014-11-02 13:42:19 UTC
Ok, thanks for your feedback.

I've already run a poudriere build and everything built fine, see the logs here, e.g. for 9.3/amd64 :

http://box.martymac.org/FreeBSD-Packages/bulk/FBSD93amd64-default/2014-10-28_11h39m29s/

Well, if the games runs fine for you, I think I'll commit everything on the next week (also depending on the answers I'll get from the CFT sent on ports@ : http://lists.freebsd.org/pipermail/freebsd-ports/2014-October/096288.html)

Thanks again,
Best regards,

Ganael.
Comment 14 commit-hook freebsd_committer 2014-11-03 13:08:20 UTC
A commit references this bug:

Author: martymac
Date: Mon Nov  3 13:07:23 UTC 2014
New revision: 372111
URL: https://svnweb.freebsd.org/changeset/ports/372111

Log:
  Update Simgear and Flightgear ports to 3.2.0

  PR:		194571
  Submitted by:	mike.d.ft402@gmail.com

Changes:
  head/devel/simgear/Makefile
  head/devel/simgear/distinfo
  head/devel/simgear/files/patch-CMakeLists.txt
  head/devel/simgear/files/patch-simgear-canvas-ShivaVG-src-shDefs.h
  head/devel/simgear/files/patch-simgear-debug-BufferedLogCallback.cxx
  head/devel/simgear/files/patch-simgear-timing-timestamp.cxx
  head/devel/simgear/pkg-plist
  head/games/flightgear/Makefile
  head/games/flightgear/distinfo
  head/games/flightgear/files/extra-patch-src-FDM-JSBSim-input_output-string_utilities.h
  head/games/flightgear/files/patch-3rdparty-hts_engine_API-lib-HTS_misc.c
  head/games/flightgear/files/patch-3rdparty-iaxclient-lib-CMakeLists.txt
  head/games/flightgear/files/patch-3rdparty-iaxclient-lib-iaxclient.h
  head/games/flightgear/files/patch-3rdparty-iaxclient-lib-libiax2-src-iax.c
  head/games/flightgear/files/patch-CMakeLists.txt
  head/games/flightgear/files/patch-JS_SERVER-CMakeLists.txt
  head/games/flightgear/files/patch-JS_SERVER-utils-CMakeLists.txt
  head/games/flightgear/files/patch-JS_SERVER-utils-js_server-CMakeLists.txt
  head/games/flightgear/files/patch-src-Airports-airports_fwd.hxx
  head/games/flightgear/files/patch-src-FDM-JSBSim-JSBSim.cxx
  head/games/flightgear/files/patch-utils-CMakeLists.txt
  head/games/flightgear/files/patch-utils-js_server-CMakeLists.txt
  head/games/flightgear-aircraft/Makefile
  head/games/flightgear-aircraft/distinfo
  head/games/flightgear-data/Makefile
  head/games/flightgear-data/distinfo
Comment 15 Ganael LAPLANCHE freebsd_committer 2014-11-03 13:09:01 UTC
Committed, thanks!