Bug 194639 - vt(4) does not properly clear the screen after switching from the splash screen in QEMU
Summary: vt(4) does not properly clear the screen after switching from the splash scre...
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Marcel Moolenaar
URL:
Keywords: vt
Depends on:
Blocks:
 
Reported: 2014-10-27 19:05 UTC by Ed Maste
Modified: 2015-08-12 16:03 UTC (History)
2 users (show)

See Also:


Attachments
QEMU screen grab after exiting splash mode (6.03 KB, image/png)
2014-10-27 19:05 UTC, Ed Maste
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Maste freebsd_committer 2014-10-27 19:05:13 UTC
Created attachment 148712 [details]
QEMU screen grab after exiting splash mode

vt(4) has nascent splash screen support - a compiled-in 2-colour bitmap of the FreeBSD logo. It is currently activated in boot -m ("mute") mode.

Some garbage is left on the screen when switching out of splash mode, as in the attachment.
Comment 1 Jean-Sébastien Pédron freebsd_committer 2014-11-02 11:06:00 UTC
I can't reproduce this issue with plain hardware. Is this specific to QEMU?
Comment 2 Ed Maste freebsd_committer 2014-11-03 21:27:35 UTC
> I can't reproduce this issue with plain hardware. Is this specific to QEMU?

Confirmed, it does not happen on my laptop w/ vt_vga.
Comment 3 Ed Maste freebsd_committer 2015-08-10 21:53:49 UTC
I cannot reproduce this with the candidate fix in PR191564.
Comment 4 Marcel Moolenaar freebsd_committer 2015-08-12 16:03:33 UTC
This is believed to be fixed for everybody in FreeBSD -current as of today (revision 286667). Please test at your earliest convenience.