Bug 194712 - Upgrade of lang/ruby19 fails miserably during install of new version
Summary: Upgrade of lang/ruby19 fails miserably during install of new version
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ruby mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-31 14:42 UTC by Trond.Endrestol
Modified: 2014-11-08 15:07 UTC (History)
1 user (show)

See Also:
Trond.Endrestol: maintainer-feedback? (ruby)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trond.Endrestol 2014-10-31 14:42:16 UTC
--->  Installation of lang/ruby19 started at: Fri, 31 Oct 2014 15:28:52 +0100
--->  Installing the new version via the port
===>  Installing for ruby-1.9.3.547_3,1
===>   ruby-1.9.3.547_3,1 depends on package: libffi>=0 - found
===>   ruby-1.9.3.547_3,1 depends on file: /usr/local/lib/libcrypto.so.8 - found
===>   ruby-1.9.3.547_3,1 depends on package: readline>=0 - found
===>   ruby-1.9.3.547_3,1 depends on shared library: libyaml.so - found (/usr/local/lib/libyaml-0.so.2.0.4)
===>   ruby-1.9.3.547_3,1 depends on shared library: libexecinfo.so - found (/usr/local/lib/libexecinfo.so.1)
===>   Registering installation for ruby-1.9.3.547_3,1
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/d0/d3e/vmtc_8inc__dep__incl.map): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/d0/d3e/vmtc_8inc__dep__incl.md5): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/d0/d3e/vmtc_8inc__dep__incl.png): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/d2/d75/structruby__method__ids__check.html): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/d2/dc2/ripper_8y__incl.map): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/d2/dc2/ripper_8y__incl.md5): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/d2/dc2/ripper_8y__incl.png): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/d4/db4/parse_8y__incl.map): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/d4/db4/parse_8y__incl.md5): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/d4/db4/parse_8y__incl.png): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/capi/html/functions_func.html): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/d0/d3e/vmtc_8inc__dep__incl.map): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/d0/d3e/vmtc_8inc__dep__incl.md5): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/d0/d3e/vmtc_8inc__dep__incl.png): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/d2/d75/structruby__method__ids__check.html): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/d2/dc2/ripper_8y__incl.map): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/d2/dc2/ripper_8y__incl.md5): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/d2/dc2/ripper_8y__incl.png): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/d4/db4/parse_8y__incl.map): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/d4/db4/parse_8y__incl.md5): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/d4/db4/parse_8y__incl.png): No such file or directory
pkg-static: lstat(/usr/ports/workdirs/usr/ports/lang/ruby19/work/stage/usr/local/share/doc/ruby19/html/functions_func.html): No such file or directory
*** [fake-pkg] Error code 74

Stop in /usr/ports/lang/ruby19.
*** [install] Error code 1

Stop in /usr/ports/lang/ruby19.
*** [reinstall] Error code 1

Stop in /usr/ports/lang/ruby19.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20141031-43420-1bzoihm env UPGRADE_TOOL=portupgrade UPGRADE_PORT=ruby-1.9.3.547_3,1 UPGRADE_PORT_VER=1.9.3.547_3,1 make DEPENDS_TARGET=package -DFORCE_PKG_REGISTER reinstall

=======================================================================

The system is amd64 stable/9 r273511.
The ports tree (ports/head) is at r371816.

I used: portupgrade -fprv lang/ruby19

The following options are set for lang/ruby19:

===> The following configuration options are available for ruby-1.9.3.547_3,1:
     CAPIDOCS=on: Build and install C API documents
     DEBUG=off: Build with debugging support
     DOCS=on: Build and/or install documentation
     EXAMPLES=off: Build and/or install examples
     RDOC=on: Build and install Rdoc indexes
====> Which line editing lib to use: you have to select exactly one of them
     LIBEDIT=off: Use libedit
     READLINE=on: Use libreadline
Comment 1 Bugzilla Automation freebsd_committer 2014-10-31 14:42:16 UTC
Auto-assigned to maintainer ruby@FreeBSD.org
Comment 2 Trond.Endrestol 2014-11-04 12:20:27 UTC
(In reply to Trond.Endrestol from comment #0)
> The following options are set for lang/ruby19:
> 
> ===> The following configuration options are available for
> ruby-1.9.3.547_3,1:
>      CAPIDOCS=on: Build and install C API documents
>      DEBUG=off: Build with debugging support
>      DOCS=on: Build and/or install documentation
>      EXAMPLES=off: Build and/or install examples
>      RDOC=on: Build and install Rdoc indexes
> ====> Which line editing lib to use: you have to select exactly one of them
>      LIBEDIT=off: Use libedit
>      READLINE=on: Use libreadline

A workaround is to disable the CAPIDOCS option.
Comment 3 commit-hook freebsd_committer 2014-11-08 15:05:58 UTC
A commit references this bug:

Author: swills
Date: Sat Nov  8 15:05:41 UTC 2014
New revision: 372322
URL: https://svnweb.freebsd.org/changeset/ports/372322

Log:
  Fix plist for CAPIDOCS option after update to doxygen.

  PR:		194712
  Reported by:	Trond Endrestol <Trond.Endrestol@ximalas.info>

Changes:
  head/Mk/bsd.ruby.mk
  head/lang/ruby19/pkg-plist
  head/lang/ruby20/pkg-plist
  head/lang/ruby21/pkg-plist
Comment 4 Steve Wills freebsd_committer 2014-11-08 15:07:38 UTC
Fix committed, thanks.