Bug 194738 - sysutils/htop 1.0.3: Doesn't show kernel threads any more
Summary: sysutils/htop 1.0.3: Doesn't show kernel threads any more
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords: patch-ready
Depends on:
Blocks:
 
Reported: 2014-11-01 11:44 UTC by Trond.Endrestol
Modified: 2016-02-05 22:31 UTC (History)
3 users (show)

See Also:
pi: maintainer-feedback-


Attachments
patch (6.57 KB, patch)
2015-10-28 20:02 UTC, Kurt Jaeger
no flags Details | Diff
patch-v2 (6.63 KB, patch)
2016-01-31 17:04 UTC, Kurt Jaeger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Trond.Endrestol 2014-11-01 11:44:01 UTC
sysutils/htop doesn't show kernel threads any more after upgrading to 1.0.3. This happens all across the board, be it base/head, base/stable/10, base/stable/9, etc.

No, I haven't disabled the htop display option "Hide kernel threads", nor the htop display option "Hide userland threads", for that matter. It doesn't matter if I enable "Tree view" or not.

Kernel threads are simply no longer being displayed.
Comment 1 Bugzilla Automation freebsd_committer 2014-11-01 11:44:01 UTC
Maintainer CC'd
Comment 2 John Marino freebsd_committer 2014-11-14 10:49:55 UTC
I'm moving this PR out of triage.  It timed out but there are no patches provided to promote.
Comment 3 Hung-Yi Chen 2015-02-06 18:49:44 UTC
I think it's a bug of htop 1.0.3.

I'm waiting for upstream patch.
Comment 4 Hung-Yi Chen 2015-07-16 19:21:33 UTC
It seems upstream fixed this issue.

I'll send a new patch for it.
Comment 5 Kurt Jaeger freebsd_committer 2015-10-28 20:02:35 UTC
Created attachment 162539 [details]
patch

Changed distfile to fetch latest commit from github.

Builds, and kernel thread numbers are displayed if "K" is typed, but I'm unsure
it does what submitter asked for. Can someone please test ?
Comment 6 Trond.Endrestol 2015-10-29 07:45:14 UTC
(In reply to Kurt Jaeger from comment #5)

Confirmed to "work" on FreeBSD/amd64 stable/10 r290090, i.e. the kernel processes are shown again. But, CPU and memory utilization are no longer shown. Back to the drawing board.

I'm not sure if the kernel process (PID 0) needs to be displayed. Previously, the kernel threads were shown at the bottom when the processes were displayed as a process tree.
Comment 7 Kurt Jaeger freebsd_committer 2016-01-24 12:21:36 UTC
(In reply to Trond.Endrestol from comment #6)
Have you tried to report this problem upstream ?
Comment 8 Kurt Jaeger freebsd_committer 2016-01-31 17:04:39 UTC
Created attachment 166359 [details]
patch-v2

updated to most recent commit at github, see

https://github.com/hishamhm/htop/issues/352

builds fine on 11, it looks like per-cpu load is displayed again.

Please check and confirm.
Comment 9 Kurt Jaeger freebsd_committer 2016-02-05 22:12:32 UTC
Run-tested on 11a, 10.2a for kernel-threads, per-cpu load. Seems fine.
Comment 10 Kurt Jaeger freebsd_committer 2016-02-05 22:18:35 UTC
Run-tested on 10.2i for kernel-threads, per-cpu load. Seems fine.
Comment 11 commit-hook freebsd_committer 2016-02-05 22:30:39 UTC
A commit references this bug:

Author: pi
Date: Fri Feb  5 22:29:42 UTC 2016
New revision: 408275
URL: https://svnweb.freebsd.org/changeset/ports/408275

Log:
  sysutils/htop: some fixes

  - re-enable kernel threads
  - update to very recent version
  - switch to github for distfiles

  PR:		194738
  Approved by:	Hung-Ti Chen <gaod@hychen.org> (maintainer timeout)

Changes:
  head/sysutils/htop/Makefile
  head/sysutils/htop/distinfo
  head/sysutils/htop/files/