Bug 194744 - [PATCH] allow to specify custom keymap when kbdmux used
Summary: [PATCH] allow to specify custom keymap when kbdmux used
Status: Closed DUPLICATE of bug 153459
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: amd64 Any
: --- Affects Many People
Assignee: Ed Maste
URL:
Keywords: patch
Depends on:
Blocks: 203349
  Show dependency treegraph
 
Reported: 2014-11-01 19:16 UTC by Oliver Pinter
Modified: 2016-03-21 17:42 UTC (History)
6 users (show)

See Also:
op: mfc-stable10?


Attachments
0001-HBSD-allow-to-specify-custom-keymap-to-kbdmux.patch (2.17 KB, patch)
2014-11-01 19:16 UTC, Oliver Pinter
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Pinter freebsd_committer 2014-11-01 19:16:57 UTC
Created attachment 148901 [details]
0001-HBSD-allow-to-specify-custom-keymap-to-kbdmux.patch

When kbdmux added to kernel config, it's override both ATKBD_DFLT_KEYMAP and UKBD_DFLT_KEYMAP.
The attached patch added new kernel config know: KBDMUX_DFLT_KEYMAP which allow to specify custom keymap.
Comment 2 Ed Maste freebsd_committer 2016-03-15 18:55:23 UTC
(In reply to Oliver Pinter from comment #0)
Is this patch functionally equivalent to the one in PR 153459?
Comment 3 op 2016-03-15 20:07:31 UTC
Not et all, without this patch you can't specify custom keyboard layout at compile time to kbdmux, because the keyboard layout does not inherited to kbdmux.
Comment 4 op 2016-03-15 20:09:55 UTC
Yes, sorry, I looked the wrong PR. This  PR is a dup of 153459.
Comment 5 Ed Maste freebsd_committer 2016-03-21 17:42:34 UTC
> Yes, sorry, I looked the wrong PR. This  PR is a dup of 153459.

Thanks for confirming, I will make it a dup. I expect to resolve this soon, after finishing off use of the new -P option added to kbdcontrol.

*** This bug has been marked as a duplicate of bug 153459 ***