Bug 194866 - x11/nvidia-driver-304 fails to compile on 10-stable
Summary: x11/nvidia-driver-304 fails to compile on 10-stable
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords:
: 194958 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-06 13:28 UTC by Robert Cina
Modified: 2014-11-15 16:55 UTC (History)
1 user (show)

See Also:
transitive: maintainer-feedback? (danfe)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cina 2014-11-06 13:28:18 UTC
The port x11/nvidia-driver-304 fails to compile on my 10-stable system.
The details follow below:
 
10.1-PRERELEASE FreeBSD 10.1-PRERELEASE #7 r274133

===>  Building for nvidia-driver-304-304.123
--- _sub.all ---
===> src (all)
--- nvidia_linux.o ---
--- nvidia_os_registry.o ---
--- nvidia_linux.o ---
cc -O2 -pipe -fno-strict-aliasing  -DNV_VERSION_STRING=\"304.123\" -D__KERNEL__ -DNVRM -Wno-unused-function -Wuninitialized -O -mno-red-zone -mcmodel=kernel -UDEBUG -U_DEBUG -DNDEBUG -Werror -D_KERNEL -DKLD_MODULE -nostdinc  -I. -I. -I@ -I@/contrib/altq -fno-common  -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer  -mno-aes -mno-avx -mcmodel=kernel -mno-red-zone -mno-mmx -mno-sse -msoft-float  -fno-asynchronous-unwind-tables -ffreestanding -fstack-protector -std=iso9899:1999 -Qunused-arguments  -fstack-protector -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes  -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual  -Wundef -Wno-pointer-sign -fformat-extensions  -Wmissing-include-dirs -fdiagnostics-show-option  -Wno-error-tautological-compare -Wno-error-empty-body  -Wno-error-parentheses-equality -Wno-error-unused-function   -c nvidia_linux.c
--- nvidia_os_registry.o ---
cc -O2 -pipe -fno-strict-aliasing  -DNV_VERSION_STRING=\"304.123\" -D__KERNEL__ -DNVRM -Wno-unused-function -Wuninitialized -O -mno-red-zone -mcmodel=kernel -UDEBUG -U_DEBUG -DNDEBUG -Werror -D_KERNEL -DKLD_MODULE -nostdinc  -I. -I. -I@ -I@/contrib/altq -fno-common  -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer  -mno-aes -mno-avx -mcmodel=kernel -mno-red-zone -mno-mmx -mno-sse -msoft-float  -fno-asynchronous-unwind-tables -ffreestanding -fstack-protector -std=iso9899:1999 -Qunused-arguments  -fstack-protector -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes  -Wmissing-prototypes -Wpointer-arith -Winline -Wcast-qual  -Wundef -Wno-pointer-sign -fformat-extensions  -Wmissing-include-dirs -fdiagnostics-show-option  -Wno-error-tautological-compare -Wno-error-empty-body  -Wno-error-parentheses-equality -Wno-error-unused-function   -c nvidia_os_registry.c
--- nvidia_linux.o ---
nvidia_linux.c:45:30: error: redefinition of 'rights'
    u_long cmd; cap_rights_t rights;
                             ^
nvidia_linux.c:43:18: note: previous definition is here
    cap_rights_t rights;
                 ^
1 error generated.
*** [nvidia_linux.o] Error code 1

make[3]: stopped in /usr/ports/x11/nvidia-driver-304/work/NVIDIA-FreeBSD-x86_64-304.123/src
1 error

make[3]: stopped in /usr/ports/x11/nvidia-driver-304/work/NVIDIA-FreeBSD-x86_64-304.123/src
*** [_sub.all] Error code 2

make[2]: stopped in /usr/ports/x11/nvidia-driver-304/work/NVIDIA-FreeBSD-x86_64-304.123
1 error

make[2]: stopped in /usr/ports/x11/nvidia-driver-304/work/NVIDIA-FreeBSD-x86_64-304.123
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/x11/nvidia-driver-304
*** Error code 1

Stop.
make: stopped in /usr/ports/x11/nvidia-driver-304
Comment 1 Bugzilla Automation freebsd_committer 2014-11-06 13:28:18 UTC
Auto-assigned to maintainer danfe@FreeBSD.org
Comment 2 Chris Hutchinson 2014-11-07 21:36:24 UTC
(In reply to Bugzilla Automation from comment #1)
> Auto-assigned to maintainer danfe@FreeBSD.org

I can confirm this port is UN-buildable on 11-CURRENT
11.0-CURRENT #1 r274134: Nov  5 12:56:14 PST 2014 amd64
svn info /usr/ports/ Revision: 372176
nvidia-driver-304-304.88_2

Pertinent output from the build failure:

...
function-growth=1000 -c nvidia_dev.c
--- nvidia_ctl.o ---
gcc48: error: unrecognized command line option '-fformat-extensions'
--- nvidia_dev.o ---
gcc48: error: unrecognized command line option '-fformat-extensions'
*** [nvidia_dev.o] Error code 1

make[3]: stopped in /usr/ports/x11/nvidia-driver-304/work/NVIDIA-FreeBSD-x86_64-304.88/src
--- nvidia_ctl.o ---
*** [nvidia_ctl.o] Error code 1

make[3]: stopped in /usr/ports/x11/nvidia-driver-304/work/NVIDIA-FreeBSD-x86_64-304.88/src
2 errors

make[3]: stopped in /usr/ports/x11/nvidia-driver-304/work/NVIDIA-FreeBSD-x86_64-304.88/src
*** [_sub.all] Error code 2

make[2]: stopped in /usr/ports/x11/nvidia-driver-304/work/NVIDIA-FreeBSD-x86_64-304.88
1 error

Thank you for all your time, and consideration.

--Chris
Comment 3 Alexey Dokuchaev freebsd_committer 2014-11-15 16:53:45 UTC
*** Bug 194958 has been marked as a duplicate of this bug. ***
Comment 4 Alexey Dokuchaev freebsd_committer 2014-11-15 16:55:54 UTC
Should be fixed in ports r372606.

"gcc48: error: unrecognized command line option '-fformat-extensions'" problem would be investigated and addresses separately.