Bug 194922 - [UPDATE] multimedia/gstreamer1 to 1.4.4
Summary: [UPDATE] multimedia/gstreamer1 to 1.4.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Koop Mast
URL:
Keywords:
: 187645 187646 187649 (view as bug list)
Depends on:
Blocks: 195603
  Show dependency treegraph
 
Reported: 2014-11-10 10:47 UTC by Olivier Duchateau
Modified: 2014-12-17 08:55 UTC (History)
3 users (show)

See Also:
olivierd: maintainer-feedback? (multimedia)


Attachments
Patch to update multimedia/gstreamer1 (7.02 KB, patch)
2014-11-10 10:47 UTC, Olivier Duchateau
no flags Details | Diff
Update of multimedia/gstreamer1-plugins to 1.4.4 (7.87 KB, patch)
2014-11-10 10:51 UTC, Olivier Duchateau
no flags Details | Diff
Update multimedia/gstreamer1-plugins-good to 1.4.4 (3.30 KB, patch)
2014-11-10 10:53 UTC, Olivier Duchateau
no flags Details | Diff
Update multimedia/gstreamer1-plugins-bad to 1.4.4 (9.19 KB, patch)
2014-11-10 10:54 UTC, Olivier Duchateau
no flags Details | Diff
Update multimedia/gstreamer1-plugins-gnonlin to 1.4.0 (1.15 KB, patch)
2014-11-10 10:58 UTC, Olivier Duchateau
no flags Details | Diff
Update multimedia/py-gstreamer1 to 1.4.0 (1.97 KB, patch)
2014-11-10 11:00 UTC, Olivier Duchateau
no flags Details | Diff
graphics/gstreamer1-plugins-gl (726 bytes, text/plain)
2014-11-10 11:01 UTC, Olivier Duchateau
no flags Details
multimedia/gstreamer1-editing-services (5.64 KB, text/plain)
2014-11-10 11:08 UTC, Olivier Duchateau
no flags Details
Patch Mk/bsd.gstreamer.mk (2.13 KB, patch)
2014-11-10 11:10 UTC, Olivier Duchateau
no flags Details | Diff
Update multimedia/gstreamer1-libav to 1.4.4 (2.34 KB, patch)
2014-11-11 07:17 UTC, Olivier Duchateau
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Duchateau freebsd_committer 2014-11-10 10:47:59 UTC
Created attachment 149247 [details]
Patch to update multimedia/gstreamer1

Update GStreamer to 1.4.4 and related ports

- Mk/bsd.gstreamer.mk
- multimedia/gstreamer1-plugins
- multimedia/gstreamer1-plugins-good
- multimedia/gstreamer1-plugins-bad

- multimedia/py-gstreamer1 (1.4.0)
- multimedia/gstreamer1-plugins-gnonlin (1.4.0)

Add new ports:

- graphics/gstreamer1-plugins-gl (1.4.4, required by multimedia/pitivi >= 0.94)
- multimedia/gstreamer1-editing-services (1.4.0, required by multimedia/pitivi >= 0.94)
Comment 1 Bugzilla Automation freebsd_committer 2014-11-10 10:47:59 UTC
Auto-assigned to maintainer multimedia@FreeBSD.org
Comment 2 Olivier Duchateau freebsd_committer 2014-11-10 10:51:24 UTC
Created attachment 149248 [details]
Update of multimedia/gstreamer1-plugins to 1.4.4

Update "meta port" multimedia/gstreamer1-plugins to 1.4.4

- Improve support of multimedia/gstreamer1-plugins-bad
- Little bit cleanup Makefile
- Branch new plugin (gl)
Comment 3 Olivier Duchateau freebsd_committer 2014-11-10 10:53:04 UTC
Created attachment 149249 [details]
Update multimedia/gstreamer1-plugins-good to 1.4.4

- Update to 1.4.4
- Remove @dirrm* in pkg-plist
Comment 4 Olivier Duchateau freebsd_committer 2014-11-10 10:54:30 UTC
Created attachment 149250 [details]
Update multimedia/gstreamer1-plugins-bad to 1.4.4

- Update to 1.4.4
- Remove @dirm* in pkg-plist
Comment 5 Olivier Duchateau freebsd_committer 2014-11-10 10:58:05 UTC
Created attachment 149251 [details]
Update multimedia/gstreamer1-plugins-gnonlin to 1.4.0

- Update to 1.4.0
- Force to use only python3 (otherwise this plugin is incompatible with Pitivi 0.94)
Comment 6 Olivier Duchateau freebsd_committer 2014-11-10 11:00:17 UTC
Created attachment 149252 [details]
Update multimedia/py-gstreamer1 to 1.4.0

- Update to 1.4.0
- Force to use only python3 (otherwise it's incompatible with Pitivi >= 0.94)
Comment 7 Olivier Duchateau freebsd_committer 2014-11-10 11:01:59 UTC
Created attachment 149253 [details]
graphics/gstreamer1-plugins-gl

Add new plugin, graphics/gstreamer1-plugins-gl (Pitivi >= 0.94 needs glimagesink).
Comment 8 Olivier Duchateau freebsd_committer 2014-11-10 11:08:05 UTC
Created attachment 149254 [details]
multimedia/gstreamer1-editing-services

Add multimedia/gstreamer1-editing-services

Python bindings are not installed, because files are placed into ${LOCALBASE}/lib/python2.7/site-packages/ even with python3. Pitivi (>= 0.94) uses GObject Introspection, so they files are not necessary.
Comment 9 Olivier Duchateau freebsd_committer 2014-11-10 11:10:53 UTC
Created attachment 149255 [details]
Patch Mk/bsd.gstreamer.mk

Add gl, python, and gnonlin plugins.
Comment 10 Olivier Duchateau freebsd_committer 2014-11-10 11:12:38 UTC
*** Bug 187645 has been marked as a duplicate of this bug. ***
Comment 11 Olivier Duchateau freebsd_committer 2014-11-10 11:15:09 UTC
*** Bug 187649 has been marked as a duplicate of this bug. ***
Comment 12 Olivier Duchateau freebsd_committer 2014-11-11 07:17:43 UTC
Created attachment 149277 [details]
Update multimedia/gstreamer1-libav to 1.4.4

- Update to 1.4.4
- Remove unneeded patch
Comment 13 Koop Mast freebsd_committer 2014-11-11 15:40:29 UTC
I don't have the time atm to look at the diffs themself. I was working on a update myself. But that was blocking because I noticed the cdparanoia plugin being broken, at runtime. Could you check if that is the case?

Cc'ing cdparanoia maintainer danfe@. He has a WIP update but had some regressions with it.
Comment 14 Olivier Duchateau freebsd_committer 2014-11-11 21:52:00 UTC
Cdparanoia plugin build fine, https://people.freebsd.org/~olivierd/gstreamer1-plugins-cdparanoia.log

This plugin is broken since GStreamer1 was imported in ports tree. It can't play completely CDDA (tested with gst-launch-1.0 command line).
Comment 15 Koop Mast freebsd_committer 2014-11-21 13:42:59 UTC
working on this now
Comment 16 Koop Mast freebsd_committer 2014-11-21 13:56:05 UTC
*** Bug 187646 has been marked as a duplicate of this bug. ***
Comment 17 Tijl Coosemans freebsd_committer 2014-12-15 10:50:57 UTC
You may need to update cdparanoia itself.  I believe the Debian kFreeBSD project has patches for that.
Comment 18 Alexey Dokuchaev freebsd_committer 2014-12-15 11:53:45 UTC
Yes, Debian/kFreeBSD project, to be precise.  I've backported them and updated the port, but it was crashing for me on some simple commands like "get drive info", which should be fixed to get the port in committable state.

I will resume my work so I can get it done, since now it's blocking other ports.
Comment 19 commit-hook freebsd_committer 2014-12-16 13:35:47 UTC
A commit references this bug:

Author: kwm
Date: Tue Dec 16 13:35:12 UTC 2014
New revision: 374804
URL: https://svnweb.freebsd.org/changeset/ports/374804

Log:
  Big Gstreamer update:

  Update gstreamer, gstreamer-plugins, -good, -bad and -ugly ports to 1.4.4.
  Update gstreamer1-plugins-gnonlin to 1.4.0.
  Update py-gstreamer1 and py3-gstreamer1 to 1.4.0.

  Add multimedia/gstreamer1-editing-services. GES is a high-level library
  for facilitating the creation of audio/video non-linear editors.

  Add pulseaudio plugin now that pulseaudio is updated and add the gl plugin.

  Drop :keepla from USES=libtool.
  Drop @dirrm[try] from plists and drop gnomehier from USE_GNOME
  Switch to optionhelpers in multimedia/gstreamer1.

  PR:		194922 (merged with my own WIP)
  Submitted by:	olivierd

Changes:
  head/Mk/bsd.gstreamer.mk
  head/audio/Makefile
  head/audio/gstreamer1-plugins-opus/Makefile
  head/audio/gstreamer1-plugins-pulse/
  head/audio/gstreamer1-plugins-pulse/Makefile
  head/graphics/Makefile
  head/graphics/gstreamer1-plugins-gl/
  head/graphics/gstreamer1-plugins-gl/Makefile
  head/graphics/gstreamer1-plugins-gl/pkg-plist
  head/graphics/gstreamer1-plugins-libcaca/Makefile
  head/graphics/gstreamer1-plugins-opencv/Makefile
  head/graphics/gstreamer1-plugins-openjpeg/Makefile
  head/graphics/gstreamer1-plugins-webp/Makefile
  head/graphics/gstreamer1-plugins-zbar/Makefile
  head/multimedia/Makefile
  head/multimedia/gstreamer1/Makefile
  head/multimedia/gstreamer1/distinfo
  head/multimedia/gstreamer1/files/patch-libs_gst_base_gstbasesrc.c
  head/multimedia/gstreamer1/pkg-plist
  head/multimedia/gstreamer1-editing-services/
  head/multimedia/gstreamer1-editing-services/Makefile
  head/multimedia/gstreamer1-editing-services/distinfo
  head/multimedia/gstreamer1-editing-services/pkg-descr
  head/multimedia/gstreamer1-editing-services/pkg-plist
  head/multimedia/gstreamer1-libav/Makefile
  head/multimedia/gstreamer1-libav/distinfo
  head/multimedia/gstreamer1-libav/files/
  head/multimedia/gstreamer1-libav/pkg-descr
  head/multimedia/gstreamer1-libav/pkg-plist
  head/multimedia/gstreamer1-plugins/Makefile
  head/multimedia/gstreamer1-plugins/Makefile.common
  head/multimedia/gstreamer1-plugins/distinfo
  head/multimedia/gstreamer1-plugins/files/patch-ext_libvisual_visual.c
  head/multimedia/gstreamer1-plugins/pkg-plist
  head/multimedia/gstreamer1-plugins-bad/files/
  head/multimedia/gstreamer1-plugins-bad/pkg-plist
  head/multimedia/gstreamer1-plugins-dvdread/Makefile
  head/multimedia/gstreamer1-plugins-gnonlin/Makefile
  head/multimedia/gstreamer1-plugins-gnonlin/distinfo
  head/multimedia/gstreamer1-plugins-good/Makefile
  head/multimedia/gstreamer1-plugins-good/files/patch-sys_oss_gstosshelper.c
  head/multimedia/gstreamer1-plugins-good/pkg-plist
  head/multimedia/gstreamer1-plugins-mpeg2enc/Makefile
  head/multimedia/gstreamer1-plugins-resindvd/Makefile
  head/multimedia/gstreamer1-plugins-ugly/pkg-plist
  head/multimedia/gstreamer1-plugins-x264/Makefile
  head/multimedia/py-gstreamer1/Makefile
  head/multimedia/py-gstreamer1/distinfo
  head/multimedia/py-gstreamer1/pkg-plist
  head/multimedia/py3-gstreamer1/Makefile
  head/multimedia/py3-gstreamer1/distinfo
  head/multimedia/py3-gstreamer1/pkg-plist
Comment 20 Koop Mast freebsd_committer 2014-12-16 13:36:48 UTC
Merged with my WIP version and committed, thanks!