Bug 194992 - graphics/poppler: add support for Qt 5
Summary: graphics/poppler: add support for Qt 5
Status: Closed DUPLICATE of bug 192068
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-13 11:50 UTC by Max Brazhnikov
Modified: 2014-11-25 12:55 UTC (History)
1 user (show)

See Also:
makc: maintainer-feedback? (gnome)


Attachments
poppler-qt5 (5.58 KB, patch)
2014-11-13 11:50 UTC, Max Brazhnikov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Max Brazhnikov freebsd_committer 2014-11-13 11:50:55 UTC
Created attachment 149374 [details]
poppler-qt5

- add poppler-qt5 port and related patches
- patch configure script to fix Qt 5 detection

Resulting library doesn't link to qt5-testlib, the dependence on Qt5 testlib probably could be removed at all (the patch for Makefile.in already removes tests subdirectory), but configure script must be fixed to not check for Qt5Test in the first place.
I suppose the same applies for poppler-qt4 and its dependence on Qt4 qtestlib.
Comment 1 Bugzilla Automation freebsd_committer 2014-11-13 11:50:55 UTC
Auto-assigned to maintainer gnome@FreeBSD.org
Comment 2 Olivier Duchateau freebsd_committer 2014-11-13 18:49:40 UTC

*** This bug has been marked as a duplicate of bug 192068 ***
Comment 3 commit-hook freebsd_committer 2014-11-25 12:55:24 UTC
A commit references this bug:

Author: makc
Date: Tue Nov 25 12:55:05 UTC 2014
New revision: 373403
URL: https://svnweb.freebsd.org/changeset/ports/373403

Log:
  graphics/poppler:
  - Update to 0.26.3
  - Add LICENSE_FILE
  - Adjust dependencies
  - Add new option, CURL
  - Switch to USES=libtool
  - Set proper install target instead of manual post-install stripping
  - Add Qt5 support
  - Use ${MOC} variable provided by Mk/bsd.qt.mk and
    remove needless pre-configure patching

  PR:		192068, 194992
  Submitted by:	olivierd, makc
  Exp-run by:	antoine
  Approved by:	kwm

Changes:
  head/graphics/Makefile
  head/graphics/poppler/Makefile
  head/graphics/poppler/distinfo
  head/graphics/poppler/files/patch-qt5_Makefile.in
  head/graphics/poppler/files/patch-qt5_src_Makefile.in
  head/graphics/poppler/files/patch-utils_Makefile.in
  head/graphics/poppler/pkg-plist
  head/graphics/poppler-glib/Makefile
  head/graphics/poppler-glib/pkg-plist
  head/graphics/poppler-qt4/Makefile
  head/graphics/poppler-qt4/pkg-plist
  head/graphics/poppler-qt5/
  head/graphics/poppler-qt5/Makefile
  head/graphics/poppler-qt5/pkg-plist
  head/graphics/poppler-utils/Makefile