Bug 195001 - audio/jack depends on db48, which will be removed soon
Summary: audio/jack depends on db48, which will be removed soon
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Many People
Assignee: Juergen Lock
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-14 06:06 UTC by TsurutaniNaoki
Modified: 2014-11-28 19:37 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TsurutaniNaoki 2014-11-14 06:06:29 UTC
audio/jack depends on db48 from a few months ago.
	is there any reason why this ports depends it ?

Fix:
add "+" at the end of the line with "USE_BDB=48".
	if there are any reason to prevent it, please add comments at somewhere.
Comment 1 Hans Petter Selasky freebsd_committer 2014-11-14 07:38:18 UTC
Hi,

I added this dependency to get the latest JACK port to build, because it included some DB header files. Maybe it is not needed. Just make sure that JACK builds clean in a jail, after your changes, if any.

--HPS
Comment 2 TsurutaniNaoki 2014-11-14 21:47:49 UTC
Sorry, I have no jail or recent clean OS.
I think simply depending db48 or later version will solve the problem.
Comment 3 Hans Petter Selasky freebsd_committer 2014-11-15 10:34:55 UTC
Sounds good to me. Can you try uninstalling the old dependency and check that the port compiles with the new one?

--HPS
Comment 4 Juergen Lock freebsd_committer 2014-11-28 18:34:10 UTC
Still builds in poudriere with USE_BDB=        48+ - using databases/db5.  Hans, can you test it still runs for you?
Comment 5 Hans Petter Selasky freebsd_committer 2014-11-28 18:37:53 UTC
Hi, are you on IRC?
--HPS
Comment 6 Juergen Lock freebsd_committer 2014-11-28 18:42:25 UTC
I'll join in a bit...
Comment 7 commit-hook freebsd_committer 2014-11-28 19:36:23 UTC
A commit references this bug:

Author: nox
Date: Fri Nov 28 19:35:49 UTC 2014
New revision: 373578
URL: https://svnweb.freebsd.org/changeset/ports/373578

Log:
  - Switch USE_BDB from 48 to 48+ .
  - Bump PORTREVISION.

  PR:		195001
  Submitted by:	turutani@scphys.kyoto-u.ac.jp

Changes:
  head/audio/jack/Makefile
Comment 8 Juergen Lock freebsd_committer 2014-11-28 19:37:34 UTC
Committed (after confirmed still working), thanks!