Bug 195002 - [MAINTAINER] dns/noip: Conditional'ize IFT_FAITH for kernels without faith(4)
Summary: [MAINTAINER] dns/noip: Conditional'ize IFT_FAITH for kernels without faith(4)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-qa, patch
Depends on:
Blocks:
 
Reported: 2014-11-14 06:11 UTC by Stanisław Halik
Modified: 2015-01-02 16:55 UTC (History)
4 users (show)

See Also:
sthalik: maintainer-feedback+


Attachments
patch with IFT_FAITH conditionalized (2.17 KB, text/plain)
2014-11-14 06:11 UTC, Stanisław Halik
no flags Details
PR195002 dns/noip: Remove unnecessary interface type patch causing IFT_FAITH build errors (1.20 KB, patch)
2014-12-31 11:00 UTC, Ben Woods
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stanisław Halik 2014-11-14 06:11:48 UTC
Created attachment 149391 [details]
patch with IFT_FAITH conditionalized

Hey,

Attached is a new version of patch-noip2.

As per <https://github.com/freebsd/freebsd/commit/b5d711d3a6940afdd3615f7ffc2dcfa3faacd446> faith(4) got removed from the kernel and headers.

cheers,
-sh
Comment 1 Bugzilla Automation freebsd_committer 2014-11-14 06:11:48 UTC
Maintainer CC'd
Comment 2 Thomas Zander freebsd_committer 2014-12-25 17:43:03 UTC
Would you like to update your mail address in the port Makefile or keep it?
Comment 3 Stanislaw Halik 2014-12-27 11:24:34 UTC
The mail still works, was a mistake.

Is the update PR otherwise well-formed? This is the first time it needs an update.
Comment 4 Thomas Zander freebsd_committer 2014-12-27 12:08:24 UTC
(In reply to sthalik from comment #3)
> The mail still works, was a mistake.
> 
> Is the update PR otherwise well-formed? This is the first time it needs an
> update.

Well, it's a small patch, so it would be easy for a committer to know how to proceed, but it's not quite how a patch should be submitted.
For example:
- Your patch changes the content of the default package, so you'd need to bump PORTREVISION
- Your patch should be the output of "svn diff" relative to ${PORTSDIR}/dns/noip
- It's always more than welcome if you attached poudriere build logs for supported architectures and releases
- You should have tested the builds with default OPTIONS, with all OPTIONS selected and with all OPTIONS deselected

Hope this helps
Comment 5 Ben Woods freebsd_committer 2014-12-31 11:00:14 UTC
Created attachment 151149 [details]
PR195002 dns/noip: Remove unnecessary interface type patch causing IFT_FAITH build errors

Actually, the last hunk of dns/noip/files/patch-noip2.c which is the cause of this IFT_FAITH build error is no longer required. This patch was added to the FreeBSD ports tree a LONG time ago. It was there in October 2003 (around the time of FreeBSD 4.9 release), before FreeBSD had a version of PF or any of the interface types being excluded by that patch.

Today, that part of the upstream code will work verbatim without any changes... so I have removed it with the attached patch.

This patch that I have attached is intended replace the maintainers original patch attached to this bug report.
Comment 6 Ben Woods freebsd_committer 2014-12-31 11:02:52 UTC
For a historical version of dns/noip/files/patch-noip2.c from October 2003, see the link below.
https://svnweb.freebsd.org/ports/head/dns/noip/files/patch-noip2.c?revision=90325&view=markup

For the interface types defined at the time of FreeBSD 4.9 release, see the link below.
https://github.com/freebsd/freebsd/blob/release/4.9.0/sys/net/if_types.h
Comment 8 Stanislaw Halik 2015-01-02 11:08:28 UTC
As was spotted by Ben Woods, patching the file only to undo parts of the patch is obviously incorrect. Please use his patch provided instead, it was an omission to suggest including the #ifdef originally.
Comment 9 commit-hook freebsd_committer 2015-01-02 16:55:31 UTC
A commit references this bug:

Author: adamw
Date: Fri Jan  2 16:55:27 UTC 2015
New revision: 376054
URL: https://svnweb.freebsd.org/changeset/ports/376054

Log:
  Remove portions of patch relying upon faith(4) that are no longer necessary.

  PR:		195002
  Submitted by:	Stanislaw Halik (maintainer)
  Patch by:	Ben Woods
  Approved by:	maintainer

Changes:
  head/dns/noip/Makefile
  head/dns/noip/files/patch-noip2.c
Comment 10 Adam Weinberger freebsd_committer 2015-01-02 16:55:58 UTC
Committed. Thanks, Stanislaw and Ben!