Bug 195017 - X230 laptop suspend fails sometimes
Summary: X230 laptop suspend fails sometimes
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: Jean-Sébastien Pédron
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-14 20:51 UTC by Hiren Panchasara
Modified: 2015-01-31 23:49 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hiren Panchasara freebsd_committer 2014-11-14 20:51:42 UTC
It usually works but sometimes it doesn't suspend and give me this on dmesg:

drmn0: GEM idle failed, resume might fail
acpi0: device_suspend failed
ahcich0: Timeout on slot 25 port 0
ahcich0: is 00000000 cs 02000000 ss 02000000 rs 02000000 tfd d0 serr 00000000 cmd 0000d917
(ada0:ahcich0:0:0:0): WRITE_FPDMA_QUEUED. ACB: 61 08 10 e6 79 40 0e 00 00 00 00 00
(ada0:ahcich0:0:0:0): CAM status: Command timeout
(ada0:ahcich0:0:0:0): Retrying command

Harddisk looks okay from smartctl tests.
Comment 1 Lars Engels freebsd_committer 2014-11-23 18:35:53 UTC
I can confirm this. Seing the same on my X230. It worked some months ago, so this is a regression.
Comment 2 Lars Engels freebsd_committer 2014-11-23 18:45:08 UTC
Forget to mention: FreeBSD 11.0-CURRENT #6 r274322M, amd64
Comment 3 Hiren Panchasara freebsd_committer 2014-11-25 23:13:08 UTC
dumbell@,

Can following revision be the source of the problem?

http://svnweb.freebsd.org/changeset/base/271705

I am just guessing and haven't tried reverting this.
Comment 4 Hiren Panchasara freebsd_committer 2014-12-31 20:43:21 UTC
(In reply to Hiren Panchasara from comment #3)
> dumbell@,
> 
> Can following revision be the source of the problem?
> 
> http://svnweb.freebsd.org/changeset/base/271705
> 
> I am just guessing and haven't tried reverting this.

My preliminary testing shows that reverting this rev fixes the problem. I could suspend/resume N number of times without any problems.
Comment 5 Lars Engels freebsd_committer 2015-01-28 23:39:08 UTC
Can r271705 then reverted, please?
Comment 6 Lars Engels freebsd_committer 2015-01-28 23:53:14 UTC
The first suspend / resume cycle works flawlessly, but the second one gives the error that Hiren posted on 2014-11-14 21:51:42 CET
Comment 7 Jean-Sébastien Pédron freebsd_committer 2015-01-30 22:19:54 UTC
I can't reproduce the error anymore with HEAD from today (r277948), though I had a different one (OpenGL applications either crashed or their windows was garbage).

Do you still have the issue?
Comment 8 Lars Engels freebsd_committer 2015-01-31 23:49:56 UTC
Yes, I can confirm that with r277858 suspend works reliably again.

Thanks to you and kib!