Bug 195020 - ls formatting broken
Summary: ls formatting broken
Status: Closed Feedback Timeout
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 10.1-STABLE
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-14 23:16 UTC by Richard Wagner
Modified: 2015-07-07 16:01 UTC (History)
2 users (show)

See Also:


Attachments
photo of broken ls formatting (165.18 KB, image/jpeg)
2014-11-14 23:16 UTC, Richard Wagner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Wagner 2014-11-14 23:16:35 UTC
Created attachment 149420 [details]
photo of broken ls formatting

After using cat to print a file to the screen (/boot/loader.efi in this case) subsequent uses of ls (with no switches) produces output that is not aligned.

This is reproducible and requires a system reboot to correct.

I'm using 10.1-RELEASE which has been clean installed.
Comment 1 oliver 2014-11-18 19:09:19 UTC
Don't know if you are fooling around but in case you aren't: 

Binary data can always mess up your terminal as there may be control characters in it, which your terminal interprets. 

You need to use "cat -v" when displaying binary files or call "reset" or "stty sane" afterwards to clean up your terminal. This may work. 

if you need to see binary data use xxd etc.

This is not a bug.
Comment 2 Marcus von Appen freebsd_committer freebsd_triage 2015-02-18 11:54:22 UTC
Updated 10.1-BETA and 10.1-RC versioned bugs to 10.1-STABLE.
Comment 3 Glen Barber freebsd_committer 2015-07-07 16:01:28 UTC
As the last reply suggests, this is expected behavior.