Bug 195072 - 11.0-CURRENT-i386 mini-memstick image doesn't boot
Summary: 11.0-CURRENT-i386 mini-memstick image doesn't boot
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: CURRENT
Hardware: i386 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-16 15:47 UTC by Juan Ramón Molina Menor
Modified: 2016-05-31 08:36 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Ramón Molina Menor 2014-11-16 15:47:41 UTC
When the latest FreeBSD-11.0-CURRENT-i386-20141113-r274463-mini-memstick.img is transferred to an USB key with the official procedure (dd), the resulting stick:
- does not get recognized by boot menus in three different computers I have tried;
- gpart show [da0] output is null, the geom does not seem to exist;
- to my surprise, mount /dev/da0 /mnt works and I can browse the contents of the stick.

On the other hand, the same procedure with the latest FreeBSD-10.1-PRERELEASE-i386-20141026-r273706-mini-memstick.img works at least in two of the three computers:
- it's recognized by boot menus, it boots without issues;
- gpart show [da0] outputs the expected information: BSD schema, slice, label.

I have repeated three times switching from one image to the other, downloading them freshly and the issue is fully reproducible.

I'm on FreeBSD-10.1-RELEASE installed on an old MSI MS-7142 (K8MM-V) motherboard. The two other computers are an Intel Desktop Board DG41RQ (neither of the images boot on this one) and a HP Compaq 6730b.
Comment 1 Juan Ramón Molina Menor 2014-11-16 15:49:36 UTC
Also, I seem to remember that these memstick images were absent at least for i386 until recently, something was wrong with them, I guess.
Comment 2 Juan Ramón Molina Menor 2014-11-16 17:34:34 UTC
The problem does not exist with amd64 images! Well, the Intel Desktop Board DG41RQ still does not see the stick, but the other two computers can. It's definitely a problem with i386 images.