Bug 195099 - databases/cassandra2: JVM crashes on 2.1.1
Summary: databases/cassandra2: JVM crashes on 2.1.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2014-11-17 12:14 UTC by Leonid Shalupov
Modified: 2017-03-05 09:30 UTC (History)
5 users (show)

See Also:
koobs: maintainer-feedback+


Attachments
JVM error log (28.03 KB, text/plain)
2014-11-17 12:14 UTC, Leonid Shalupov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Shalupov 2014-11-17 12:14:12 UTC
Created attachment 149509 [details]
JVM error log

I installed Cassandra 2.1.1 from ports on FreeBSD 10.0.

It crashes right after start, no changes made to configuration.

Related discussion in freebsd-stable: http://lists.freebsd.org/pipermail/freebsd-stable/2014-October/080834.html

Related Cassandra bug: https://issues.apache.org/jira/browse/CASSANDRA-8325
Comment 1 Bugzilla Automation freebsd_committer 2014-11-17 12:14:12 UTC
Maintainer CC'd
Comment 2 ari 2014-12-15 21:59:07 UTC
I think this port should be marked as BROKEN since I've been unable to find any circumstance under which it works. Perhaps someone else can confirm that they can reproduce? There has been lots of discussion on the Apache bug tracker and perhaps this is a FreeBSD Java problem.
Comment 3 admins 2014-12-29 15:22:30 UTC
(In reply to ari from comment #2)
> I think this port should be marked as BROKEN since I've been unable to find
> any circumstance under which it works. Perhaps someone else can confirm that
> they can reproduce? There has been lots of discussion on the Apache bug
> tracker and perhaps this is a FreeBSD Java problem.

I would agree to mark the port as BROKEN. Although I made the port works using Sun Java I can't name it production ready.

FYI, I found what recent OpenJDK upgrade brakes all previous versions of Cassandra. Would anyone confirm this?
Comment 4 Lacey Powers 2015-07-20 23:06:37 UTC
This patch, attached to CASSANDRA-8325, lets me build and run Cassandra 2.2.0 on FreeBSD 10.1-RELEASE-p14. 

It needs a little cleanup, it doesn't apply super cleanly.

https://issues.apache.org/jira/secure/attachment/12689758/untested_8325.patch

Is there interest in applying this patch for the ports builds and getting Cassandra working again?

Thought I'd mention it, since this patch showed up after the last comment on this thread. =)
Comment 5 Martin Wilke freebsd_committer 2017-03-04 14:38:45 UTC
Hi,

Is this PR still relevant?
Comment 6 ari 2017-03-05 01:18:40 UTC
Since https://issues.apache.org/jira/browse/CASSANDRA-8325 was not fixed, this port should be marked as BROKEN, or a patch added to make it work.

So, I don't think this bug should be closed until something is done.
Comment 7 Martin Wilke freebsd_committer 2017-03-05 09:29:47 UTC
I have marked the port broken.
Comment 8 commit-hook freebsd_committer 2017-03-05 09:30:03 UTC
A commit references this bug:

Author: miwi
Date: Sun Mar  5 09:29:34 UTC 2017
New revision: 435462
URL: https://svnweb.freebsd.org/changeset/ports/435462

Log:
  - Mark BROKEN keep on crashing with OpenJDK

  PR:		195099
  Submitted by:	Leonid Shalupov
  Approved by:	maintainer

Changes:
  head/databases/cassandra2/Makefile