Bug 195124 - emulators/linux-f10 : doesn't install from binary packages
Summary: emulators/linux-f10 : doesn't install from binary packages
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-emulation (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-17 22:48 UTC by Adrian Chadd
Modified: 2015-01-21 10:26 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Chadd freebsd_committer 2014-11-17 22:48:31 UTC
Hi,

I'm running FreeBSD-HEAD i386 with the binary package repository.

I can't install linux-f10:

root@lucy-11i386:/home/adrian # pkg install linux-f10
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
pkg: linux-f10 has a missing dependency: linux-f10-flashplugin
pkg: No packages available to install matching 'linux-f10' have been found in the repositories

.. so what's the story?
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-11-20 04:19:26 UTC
Fix synopsis and assign.
Comment 2 commit-hook freebsd_committer 2014-12-17 16:57:04 UTC
A commit references this bug:

Author: xmj
Date: Wed Dec 17 16:56:58 UTC 2014
New revision: 374864
URL: https://svnweb.freebsd.org/changeset/ports/374864

Log:
  emulators/linux-f10: fix RUN_DEPENDS

  - fix RUN_DEPENDS structure:
    ${PKGBASE}>0:${PORTSDIR}/category/portname ...
  - bump PORTVERSION

  PR:		195124
  DiffRev:	placeholder
  Submitted by:	adrian
  Approved by:	swills (mentor)

Changes:
  head/emulators/linux-f10/Makefile
Comment 3 Johannes Jost Meixner freebsd_committer 2015-01-21 10:26:06 UTC
While the build should work in theory (given that all packages were tested to build, dependencies are correct, etc.), due to unfixed/unfixable vulnerabilities in other Fedora 10 ports (libaudiofile, looking at you) we will never be able to fix the build of this meta-port and its dependencies.

Please upgrade to our shiny new CentOS 6.6 stack.