Bug 195160 - ia64 cpu_halt() reboots system instead of halting
Summary: ia64 cpu_halt() reboots system instead of halting
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 10.1-RELEASE
Hardware: ia64 Any
: --- Affects Some People
Assignee: freebsd-ia64 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-19 05:27 UTC by rebecca+freebsd@bluestop.org
Modified: 2021-06-22 16:03 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rebecca+freebsd@bluestop.org 2014-11-19 05:27:56 UTC
The cpu_halt() function is apparently supposed to stop the CPU, for example when a panic occurs - the x64 version is implemented via an infinite loop running the hlt instruction.

On ia64 the implementation instead calls efi_reset_system() (http://fxr.watson.org/fxr/source/ia64/ia64/machdep.c?v=FREEBSD10;im=bigexcerpts#L402), which does a warm reboot and is probably not the expected behavior.
Comment 1 Alexey Dokuchaev freebsd_committer 2021-06-22 16:03:37 UTC
Unfortunately, there's not much we can do about this issue now since FreeBSD 10.x, which is the last branch that supported ia64, went out of support a while ago; here's the official deorbit announcement:

    https://lists.freebsd.org/pipermail/freebsd-ia64/2014-May/004043.html

Hence I'm closing this PR.