Bug 195183 - Unable to reboot after updating to 10.1 if IPFW is running
Summary: Unable to reboot after updating to 10.1 if IPFW is running
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 10.1-RELEASE
Hardware: amd64 Any
: Normal Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-19 20:55 UTC by Gerard Seibert
Modified: 2015-06-04 14:37 UTC (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerard Seibert 2014-11-19 20:55:16 UTC
FreeBSD scorpio.seibercom.net 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401: Tue Nov 11 21:02:49 UTC 2014     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

I updated from FreeBSD-10 to 10.1 using freebsd-update. I ran the process as instructed. However, when I tried to reboot the system, it hung for 30 minutes. I had to manually shut it down. The culprit was IPFW. It just refused to shutdown and release the system. I have confirmed this behavior with three other users so far.
Comment 1 Midori Kato 2014-11-20 17:49:53 UTC
Hi,

Have you tried ipfw configuration on 10.0-RELEASE? Did you see the same problem?
Comment 2 Gerard Seibert 2014-11-20 18:06:11 UTC
(In reply to Midori Kato from comment #1)
> Hi,
> 
> Have you tried ipfw configuration on 10.0-RELEASE? Did you see the same
> problem?

I might have explained this problem incorrectly. The system refused to shut down after the initial update from FreeBSD 10 to FreeBSD-10.1. After that, it works fine as far as I can tell. I rarely reboot, so there might still be a problem that I am not aware of.

I believe that "freebsd-update" should check for a running IPFW and either shut it down or advise the user that it is running and might cause a problem when asked to do a reboot of the system to complete the installation.
Comment 3 Walter Hop 2015-01-21 21:26:12 UTC
I am pretty sure that #195458 is the same issue as this, however in my case, ipfw was not needed to get the reboot hang in 10.1.

If you still can reproduce, it would be interesting to see if you're running UFS+softupdates and if the hang disappears when you disabling softupdates.
Comment 4 Allan Jude freebsd_committer 2015-03-20 03:22:39 UTC
(In reply to Gerard Seibert from comment #2)

Which stage of the upgrade were you at?

1. FreeBSD 10.0 kernel and world, run freebsd-update upgrade
2. run freebsd-update install, installed: 10.1 kernel, 10.0 world running: 10.0/10.0
2. reboot
3. running kern/world: 10.1/10.0
4. freebsd-update install (2nd time): installed: 10.1/10.1. running: 10.1/10.0
5. reboot
6. running kern/world: 10.1/10.1
7. freebsd-update install (3rd time, removed old shlibs), running: 10.1/10.1
8. reboot
Comment 5 Walter Hop 2015-06-04 11:28:42 UTC
I'm pretty sure this was really #195458 happening and this PR can be closed.