Bug 195199 - [NEW PORT]: x11/slop: Make a screen selection and print the selection coordinates to stdout
Summary: [NEW PORT]: x11/slop: Make a screen selection and print the selection coordin...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Pawel Pekala
URL:
Keywords: easy, patch
: 194848 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-20 00:32 UTC by Neel Chauhan
Modified: 2014-12-31 11:39 UTC (History)
2 users (show)

See Also:


Attachments
Shar file for the new x11/slop port (1.51 KB, text/plain)
2014-11-20 00:32 UTC, Neel Chauhan
no flags Details
Poudriere Build Log for x11/slop 3.1.14 (18.15 KB, text/x-log)
2014-11-20 00:33 UTC, Neel Chauhan
no flags Details
shar file for x11/slop 4.1.15 (1.50 KB, text/plain)
2014-12-30 21:54 UTC, Neel Chauhan
no flags Details
Poudriere Build Log for graphics/slop 4.1.15 (17.41 KB, text/x-log)
2014-12-30 21:55 UTC, Neel Chauhan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan freebsd_committer 2014-11-20 00:32:04 UTC
Created attachment 149621 [details]
Shar file for the new x11/slop port

slop (Select Operation) is an application that collects a screen selection from the user and prints the selection's coordinates to stdout.
Comment 1 Neel Chauhan freebsd_committer 2014-11-20 00:33:34 UTC
Created attachment 149622 [details]
Poudriere Build Log for x11/slop 3.1.14

I have also attached the Poudriere Build Log for the new x11/slop port.
Comment 2 Neel Chauhan freebsd_committer 2014-11-20 00:33:51 UTC
*** Bug 194848 has been marked as a duplicate of this bug. ***
Comment 3 Neel Chauhan freebsd_committer 2014-11-20 00:35:58 UTC

*** This bug has been marked as a duplicate of bug 195125 ***
Comment 4 Neel Chauhan freebsd_committer 2014-11-20 00:36:54 UTC
(In reply to Neel Chauhan from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 195125 ***

Well, Sorry for Comment #3. My mistake.
Restored this port to "Needs Triage".
Comment 5 Pawel Pekala freebsd_committer 2014-12-30 18:45:06 UTC
XUSE_GCC=	yes

Any particular reason on insisting to build with gcc?
Builds fine with clang for me.
Comment 6 Neel Chauhan freebsd_committer 2014-12-30 21:54:55 UTC
Created attachment 151131 [details]
shar file for x11/slop 4.1.15

Here is a updated shar file with the following changes:
 * Updated to version 4.1.15
 * Removed USE_GCC
The Poudriere Build Log will follow.
-Neel
Comment 7 Neel Chauhan freebsd_committer 2014-12-30 21:55:36 UTC
Created attachment 151132 [details]
Poudriere Build Log for graphics/slop 4.1.15

Also, Here is the Poudriere Build Log.
-Neel
Comment 8 commit-hook freebsd_committer 2014-12-31 11:33:52 UTC
A commit references this bug:

Author: pawel
Date: Wed Dec 31 11:32:52 UTC 2014
New revision: 375877
URL: https://svnweb.freebsd.org/changeset/ports/375877

Log:
  slop (Select Operation) is an application that collects a screen selection
  from the user and prints the selection's coordinates to stdout.

  WWW: http://www.github.com/naelstrof/slop

  PR:		195199
  Submitted by:	Neel Chauhan <neel@neelc.org>

Changes:
  head/x11/Makefile
  head/x11/slop/
  head/x11/slop/Makefile
  head/x11/slop/distinfo
  head/x11/slop/pkg-descr
Comment 9 commit-hook freebsd_committer 2014-12-31 11:38:53 UTC
A commit references this bug:

Author: pawel
Date: Wed Dec 31 11:38:19 UTC 2014
New revision: 46129
URL: https://svnweb.freebsd.org/changeset/doc/46129

Log:
  For x11/slop

  PR:		195199

Changes:
  head/en_US.ISO8859-1/articles/contributors/contrib.additional.xml