Bug 195290 - x11/cinnamon crashes when attempting to play video
Summary: x11/cinnamon crashes when attempting to play video
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-22 19:03 UTC by ucsdboy
Modified: 2014-12-30 20:17 UTC (History)
2 users (show)

See Also:


Attachments
compressed copy of stderr of startx process (2.61 KB, application/gzip)
2014-11-22 19:03 UTC, ucsdboy
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ucsdboy 2014-11-22 19:03:27 UTC
Created attachment 149726 [details]
compressed copy of stderr of startx process

When I attempt to watch video, cinnamon and X will crash. This appears to be across the board, whether I use VLC, watch a video in YouTube, or even if there is video advertisement on webpage in FireFox.

I redirected stderr from startx to a file. I've attached it to this bug.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-11-22 19:19:52 UTC
Fix synopsis and assign.
Comment 2 gustau.perez 2014-11-24 10:22:02 UTC
Cinnamon 2.4 is on the works. When it gets tested I'll cook a fix for that (if the bug's still present)
Comment 3 gustau.perez 2014-12-19 10:39:13 UTC
Cinnamon 2.4 made it into the gnome-3.14 branch in the freebsd-gnome-ports git repo. I tested and was able to play videos (Intel Ivy card here). 

Could you test that git branch and report back?
Comment 4 commit-hook freebsd_committer 2014-12-30 20:14:36 UTC
A commit references this bug:

Author: kwm
Date: Tue Dec 30 20:14:00 UTC 2014
New revision: 375852
URL: https://svnweb.freebsd.org/changeset/ports/375852

Log:
  Update cinnamon to 2.4, this should fix [1] and [2].
  Update totem to 3.14 now that we have gstreamer 1.4 and minor gnome updates.
  Update evolution suite to 3.12.9.
  Make sure gtk30 pulls in adwait-icon-theme, since it now the default theme [3].

  PR:		195290 [1], 195289 [2], 195455 [3]
  Obtained from:	gnome devel repo

Changes:
  head/Mk/bsd.gnome.mk
  head/accessibility/orca/Makefile
  head/accessibility/orca/distinfo
  head/databases/evolution-data-server/Makefile
  head/databases/evolution-data-server/distinfo
  head/deskutils/california/Makefile
  head/deskutils/california/distinfo
  head/deskutils/california/pkg-plist
  head/deskutils/gnote/Makefile
  head/deskutils/gnote/distinfo
  head/deskutils/nemo-extensions/Makefile
  head/deskutils/nemo-extensions/distinfo
  head/devel/libsoup/Makefile
  head/devel/libsoup/distinfo
  head/devel/libsoup-gnome/Makefile
  head/editors/gedit/Makefile
  head/editors/gedit/distinfo
  head/games/gnome-chess/Makefile
  head/games/gnome-chess/distinfo
  head/games/hitori/Makefile
  head/games/hitori/distinfo
  head/games/hitori/pkg-plist
  head/graphics/GraphicsMagick/Makefile
  head/graphics/librsvg2/Makefile
  head/graphics/librsvg2/distinfo
  head/graphics/librsvg2/pkg-plist
  head/lang/cjs/Makefile
  head/lang/cjs/distinfo
  head/lang/cjs/pkg-plist
  head/mail/evolution/Makefile
  head/mail/evolution/distinfo
  head/mail/evolution-ews/Makefile
  head/mail/evolution-ews/distinfo
  head/mail/evolution-mapi/Makefile
  head/mail/evolution-mapi/distinfo
  head/mail/geary/Makefile
  head/mail/geary/distinfo
  head/mail/geary/pkg-plist
  head/misc/cinnamon-translations/Makefile
  head/misc/cinnamon-translations/distinfo
  head/misc/cinnamon-translations/pkg-plist
  head/misc/gnome-devel-docs/Makefile
  head/misc/gnome-devel-docs/distinfo
  head/misc/gnome-devel-docs/pkg-plist
  head/multimedia/totem/Makefile
  head/multimedia/totem/distinfo
  head/multimedia/totem/files/patch-configure
  head/multimedia/totem/pkg-plist
  head/net/glib-networking/Makefile
  head/net/glib-networking/distinfo
  head/net/glib-networking/pkg-plist
  head/net/gnome-online-miners/Makefile
  head/net/gnome-online-miners/distinfo
  head/net/libgweather/Makefile
  head/net/libgweather/distinfo
  head/net/libgweather/pkg-plist
  head/net/vinagre/Makefile
  head/net/vinagre/distinfo
  head/sysutils/cinnamon-control-center/Makefile
  head/sysutils/cinnamon-control-center/distinfo
  head/sysutils/cinnamon-control-center/files/patch-configure.ac
  head/sysutils/cinnamon-control-center/files/patch-panels_Makefile.am
  head/sysutils/cinnamon-control-center/files/patch-unused-panels_user-accounts_um-utils.c
  head/sysutils/cinnamon-control-center/pkg-plist
  head/sysutils/cinnamon-settings-daemon/Makefile
  head/sysutils/cinnamon-settings-daemon/distinfo
  head/sysutils/cinnamon-settings-daemon/pkg-plist
  head/sysutils/consolekit/pkg-plist
  head/sysutils/tracker/Makefile
  head/sysutils/tracker/distinfo
  head/sysutils/tracker/pkg-plist
  head/x11/cinnamon/Makefile
  head/x11/cinnamon/distinfo
  head/x11/cinnamon/pkg-plist
  head/x11/cinnamon-desktop/Makefile
  head/x11/cinnamon-desktop/distinfo
  head/x11/cinnamon-desktop/pkg-plist
  head/x11/cinnamon-menus/Makefile
  head/x11/cinnamon-menus/distinfo
  head/x11/cinnamon-screensaver/Makefile
  head/x11/cinnamon-screensaver/distinfo
  head/x11/cinnamon-screensaver/files/patch-src_gs-debug.c
  head/x11/cinnamon-screensaver/files/patch-src_gs-fade.c
  head/x11/cinnamon-screensaver/files/patch-src_gs-listener-dbus.c
  head/x11/cinnamon-session/Makefile
  head/x11/cinnamon-session/distinfo
  head/x11/cinnamon-session/files/patch-cinnamon-session_csm-consolekit.c
  head/x11/gnome-shell/Makefile
  head/x11/gnome-shell/distinfo
  head/x11/gnome-shell-extensions/Makefile
  head/x11/gnome-shell-extensions/distinfo
  head/x11/gnome-shell-extensions/files/
  head/x11-fm/nautilus/Makefile
  head/x11-fm/nautilus/distinfo
  head/x11-fm/nemo/Makefile
  head/x11-fm/nemo/distinfo
  head/x11-fm/nemo/files/patch-libnemo-private_nemo-action.c
  head/x11-fm/nemo/files/patch-src_nemo-bookmark-list.c
  head/x11-fm/nemo/files/patch-src_nemo-icon-view.c
  head/x11-fm/nemo/files/patch-src_nemo-list-view.c
  head/x11-fm/nemo/files/patch-src_nemo-notebook.c
  head/x11-fm/nemo/pkg-plist
  head/x11-themes/gnome-themes-standard/Makefile
  head/x11-themes/gnome-themes-standard/distinfo
  head/x11-themes/gnome-themes-standard/pkg-plist
  head/x11-toolkits/gtk30/Makefile
  head/x11-toolkits/gtk30/distinfo
  head/x11-toolkits/vte3/Makefile
  head/x11-toolkits/vte3/distinfo
  head/x11-toolkits/vte3/pkg-plist
  head/x11-wm/metacity/Makefile
  head/x11-wm/metacity/distinfo
  head/x11-wm/muffin/Makefile
  head/x11-wm/muffin/distinfo
  head/x11-wm/muffin/pkg-plist
  head/x11-wm/mutter/Makefile
  head/x11-wm/mutter/distinfo
Comment 5 Koop Mast freebsd_committer 2014-12-30 20:17:56 UTC
Cinnamon was updated to the 2.4 series. The problem was not present during testing with this version, please reopen this bug report if the problem is still present.
Thanks for reporting.