Bug 195309 - misc/mc 4.8.13 does not display man files
Summary: misc/mc 4.8.13 does not display man files
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-23 15:54 UTC by 214748mv
Modified: 2015-03-24 00:10 UTC (History)
1 user (show)

See Also:


Attachments
New patch file patch-misc__ext.d__text.sh.in (770 bytes, text/plain)
2014-11-23 15:54 UTC, 214748mv
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description 214748mv 2014-11-23 15:54:11 UTC
Created attachment 149749 [details]
New patch file patch-misc__ext.d__text.sh.in

Pressing F3 key on a man file (eg. /usr/share/man/man1/cp.1.gz), MC displays an error message.
The attached patch solves the problem for me:
- copy patch-misc__ext.d__text.sh.in in /usr/ports/misc/mc/files/
- rebuild MC
Comment 1 Kurt Jaeger freebsd_committer 2015-01-13 18:03:54 UTC
I tested mc and could not reproduce the problem.
Comment 2 214748mv 2015-01-14 22:34:55 UTC
Just upgraded MC via pkg to mc-4.8.13_3 and the problem is still here, for me.
The MC error message is the same as with the command :
$ man -l
Illegal option -l
Usage:
 man [-adho] [-t | -w] [-M manpath] [-P pager] [-S mansect]
     [-m arch[:machine]] [-p [eprtv]] [mansect] page [...]
 man -f page [...] -- Emulates whatis(1)
 man -k page [...] -- Emulates apropos(1)

The patch only remove the option '-l'. The '-l' option is available in Linux not in FreeBSD.
I'm running:
$ uname -a 
FreeBSD ativ 11.0-CURRENT FreeBSD 11.0-CURRENT #2 r276956M: Sun Jan 11 22:39:42 CET 2015     root@ativ:/usr/obj/usr/src/sys/GENERIC  amd64
Comment 3 Kurt Jaeger freebsd_committer 2015-03-23 15:09:00 UTC
There is a new version of mc and a PR for it:

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=198829
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2015-03-24 00:10:43 UTC
Assign to resolving committer