Bug 195342 - editors/gedit does not build, issue on port devel/py3-gobject3
Summary: editors/gedit does not build, issue on port devel/py3-gobject3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: i386 Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-24 18:07 UTC by hardy.schumacher
Modified: 2014-12-09 16:09 UTC (History)
4 users (show)

See Also:


Attachments
Logfile from build of editors/gedit (26.87 KB, text/plain)
2014-11-24 18:07 UTC, hardy.schumacher
no flags Details
patch for py-gobject3 (422 bytes, patch)
2014-12-03 15:17 UTC, Antoine Brodin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description hardy.schumacher 2014-11-24 18:07:41 UTC
Created attachment 149782 [details]
Logfile from build of editors/gedit

Port editors/gedit does not build due to issue on port devel/py3-gobject3.
Port devel/py3-gobject3 shows error on installation (see attached logfile).

Bug appeared on FreeBSD 9.3-RELEASE-p5 on i386 platform.
Comment 1 Bugzilla Automation freebsd_committer 2014-11-24 18:07:41 UTC
Maintainers CC'd
Comment 2 Kyle L. 2014-11-29 00:15:58 UTC
I can confirm I am seeing the same error. In my case, I am building 10.1-amd64.
Comment 3 oleg.nauman 2014-11-30 16:13:50 UTC
The same error on 10.1-STABLE i386
Comment 4 Antoine Brodin freebsd_committer 2014-12-03 15:17:51 UTC
Created attachment 150142 [details]
patch for py-gobject3

Can you try with attached patch?  it's for devel/py-gobject3 but similar patch should apply to devel/py3-gobject3 too
Comment 5 oleg.nauman 2014-12-03 17:05:36 UTC
Hello Antoine,

Your patch fixes the build.

Thank you
Comment 6 oleg.nauman 2014-12-03 17:11:10 UTC
Well it seems devel/py-gobject3 experiencing the same build failure..
Comment 7 commit-hook freebsd_committer 2014-12-09 15:56:21 UTC
A commit references this bug:

Author: kwm
Date: Tue Dec  9 15:55:41 UTC 2014
New revision: 374402
URL: https://svnweb.freebsd.org/changeset/ports/374402

Log:
  Restore the UNAME_M fix which was accidently reverted in the gnome3 import.
  This fixes the build on architechtures where MACHINE and MACHINE_ARCH to
  differ. But put it in the -common port so it shared between both versions
  of py-gobject3. [1]

  Work around python plist issue [2]

  PR:		188856 [1], 195342 [2], 195738 [2], 195748 [2]
  Sumbitted by:	sbruno [1], mva[2]

Changes:
  head/devel/pygobject3-common/Makefile