Bug 195446 - [PATCH] sysutils/rsnapshot: Fix FTBFS with >= lang/perl5.18
Summary: [PATCH] sysutils/rsnapshot: Fix FTBFS with >= lang/perl5.18
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Johannes Jost Meixner
URL:
Keywords:
: 195926 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-27 11:40 UTC by David O'Rourke
Modified: 2014-12-20 12:59 UTC (History)
7 users (show)

See Also:


Attachments
Corrects missing =back issue allowing rsnapshot to build successfully. (252 bytes, patch)
2014-11-27 11:40 UTC, David O'Rourke
no flags Details | Diff
harmonize patch (1.68 KB, patch)
2014-12-07 09:25 UTC, Johannes Jost Meixner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David O'Rourke 2014-11-27 11:40:00 UTC
Created attachment 149938 [details]
Corrects missing =back issue allowing rsnapshot to build successfully.

This patch fixes rsnapshot-1.3.1 so that it will build properly when used with lang/perl5.18.
Comment 1 Bugzilla Automation freebsd_committer 2014-11-27 11:40:00 UTC
Maintainers CC'd
Comment 2 VK freebsd_triage 2014-12-06 12:22:29 UTC
I tested this and it works, patches rsnapshot-program.pl to have the manpages built (and therefore the port entirely) under Perl 5.18.4.

Thanks.

The same patch (extra =back line) is applied on Gentoo and rsnapshot-1.3.1 too it seems.
Comment 3 Johannes Jost Meixner freebsd_committer 2014-12-07 09:25:20 UTC
Created attachment 150300 [details]
harmonize patch

Patch attached deprecates original attachment by David O'Rourke, removes the if clause for 5.18 and the BROKEN labelling, and bumps PORTREVISION.
Comment 4 Warren Block freebsd_committer 2014-12-10 02:34:03 UTC
Next time, I'll try to remember to check for an existing bug report before I create my own patch.  It appears to be identical to yours.  The problem was identified here: https://github.com/DrHyde/rsnapshot/issues/8
Comment 5 commit-hook freebsd_committer 2014-12-17 12:05:39 UTC
A commit references this bug:

Author: xmj
Date: Wed Dec 17 12:04:47 UTC 2014
New revision: 374842
URL: https://svnweb.freebsd.org/changeset/ports/374842

Log:
  sysutils/rsnapshot: unbreak with Perl 5.18

  - Backport an upstreamed patch which unbreaks rsnapshot with Perl >= 5.18.
  - Bump PORTREVISION

  PR:		195446
  Differential Revision:	https://reviews.freebsd.org/D1324
  Submitted by:	David O'Rourke <dor.bsd@fastmail.fm>
  Approved by:	remko (maintainer)
  Approved by:	koobs (mentor)

Changes:
  head/sysutils/rsnapshot/Makefile
  head/sysutils/rsnapshot/files/
  head/sysutils/rsnapshot/files/patch-rsnapshot-program.pl
Comment 6 Johannes Jost Meixner freebsd_committer 2014-12-17 12:06:36 UTC
Committed, with minor changes. Thanks!
Comment 7 Pawel Pekala freebsd_committer 2014-12-20 12:59:37 UTC
*** Bug 195926 has been marked as a duplicate of this bug. ***