Bug 195456 - editors/libreoffice fails to configure
Summary: editors/libreoffice fails to configure
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-27 19:58 UTC by rkoberman
Modified: 2015-06-01 17:19 UTC (History)
1 user (show)

See Also:
rkoberman: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rkoberman 2014-11-27 19:58:28 UTC
Not sure whether this is a libreoffice or autotools issue.
/usr/local/bin/autom4te-2.69 is present:
# ls /usr/local/bin/autom4te-2.69
-r-xr-xr-x  1 root  wheel  32210 Dec 27  2013 /usr/local/bin/autom4te-2.69*

# cd /usr/ports/editors/libreoffice
# make configure
===>  Found saved configuration for libreoffice-4.0.6_1
===>   libreoffice-4.3.4 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by libreoffice-4.3.4 for building
===>  Extracting for libreoffice-4.3.4
=> SHA256 Checksum OK for libreoffice/libreoffice-4.3.4.1.tar.xz.
=> SHA256 Checksum OK for libreoffice/libreoffice-help-4.3.4.1.tar.xz.
=> SHA256 Checksum OK for libreoffice/1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz.
=> SHA256 Checksum OK for libreoffice/4b87018f7fff1d054939d19920b751a0-collada2gltf-master-cb1d97788a.tar.bz2.
=> SHA256 Checksum OK for libreoffice/OpenCOLLADA-master-6509aa13af.tar.bz2.
===>  Patching for libreoffice-4.3.4
===>  Applying extra patch /usr/ports/editors/libreoffice/files/disable-cppunittester
===>  Applying extra patch /usr/ports/editors/libreoffice/files/extra-libc++
===>  Applying extra patch /usr/ports/editors/libreoffice/files/extra-libc++.i386
===>  Applying FreeBSD patches for libreoffice-4.3.4
===>   libreoffice-4.3.4 depends on package: p5-Archive-Zip>=0 - found
===>   libreoffice-4.3.4 depends on executable: zip - found
===>   libreoffice-4.3.4 depends on file: /usr/local/lib/libboost_regex.a - found
===>   libreoffice-4.3.4 depends on file: /usr/local/libdata/pkgconfig/cppunit.pc - found
===>   libreoffice-4.3.4 depends on executable: dmake - found
===>   libreoffice-4.3.4 depends on file: /usr/local/bin/gperf - found
===>   libreoffice-4.3.4 depends on package: mdds>=0.9.0 - found
===>   libreoffice-4.3.4 depends on executable: gpatch - found
===>   libreoffice-4.3.4 depends on executable: ucpp - found
===>   libreoffice-4.3.4 depends on executable: vigra-config - found
===>   libreoffice-4.3.4 depends on executable: bash - found
===>   libreoffice-4.3.4 depends on executable: gsed - found
===>   libreoffice-4.3.4 depends on executable: bison - found
===>   libreoffice-4.3.4 depends on executable: gmake - found
===>   libreoffice-4.3.4 depends on executable: pkgconf - found
===>   libreoffice-4.3.4 depends on file: /usr/local/bin/python2.7 - found
===>   libreoffice-4.3.4 depends on executable: update-mime-database - found
===>   libreoffice-4.3.4 depends on executable: update-desktop-database - found
===>   libreoffice-4.3.4 depends on file: /usr/local/include/glm/glm.hpp - found
===>   libreoffice-4.3.4 depends on file: /usr/local/libdata/pkgconfig/glproto.pc - found
===>   libreoffice-4.3.4 depends on file: /usr/local/libdata/pkgconfig/dri2proto.pc - found
===>   libreoffice-4.3.4 depends on file: /usr/local/libdata/pkgconfig/glproto.pc - found
===>   libreoffice-4.3.4 depends on file: /usr/local/libdata/pkgconfig/dri2proto.pc - found
===>   libreoffice-4.3.4 depends on file: /usr/local/libdata/pkgconfig/xaw7.pc - found
===>   libreoffice-4.3.4 depends on file: /usr/local/libdata/pkgconfig/xrandr.pc - found
===>   libreoffice-4.3.4 depends on package: gstreamer-plugins>=0.10.0 - found
===>   libreoffice-4.3.4 depends on file: /usr/local/bin/automake-1.14 - found
===>   libreoffice-4.3.4 depends on file: /usr/local/bin/autoconf-2.69 - found
===>   libreoffice-4.3.4 depends on executable: gtk-update-icon-cache - found
===>   libreoffice-4.3.4 depends on file: /usr/local/bin/intltool-extract - found
===>   libreoffice-4.3.4 depends on file: /usr/local/bin/perl5.18.4 - found
===>   libreoffice-4.3.4 depends on shared library: libapr-1.so - found (/usr/local/lib/libapr-1.so.0.5.1)
===>   libreoffice-4.3.4 depends on shared library: libicutu.so - found (/usr/local/lib/libicutu.so.53.1)
===>   libreoffice-4.3.4 depends on shared library: liblangtag.so - found (/usr/local/lib/liblangtag.so.1.3.0)
===>   libreoffice-4.3.4 depends on shared library: liborcus-0.8.so - found (/usr/local/lib/liborcus-0.8.so.0.0.0)
===>   libreoffice-4.3.4 depends on shared library: libcurl.so - found (/usr/local/lib/libcurl.so.7)
===>   libreoffice-4.3.4 depends on shared library: libcairo.so - found (/usr/local/lib/libcairo.so.2.11200.16)
===>   libreoffice-4.3.4 depends on shared library: libGLEW.so - found (/usr/local/lib/libGLEW.so.1)
===>   libreoffice-4.3.4 depends on shared library: libgraphite2.so - found (/usr/local/lib/libgraphite2.so.3.0.1)
===>   libreoffice-4.3.4 depends on shared library: libjpeg.so - found (/usr/local/lib/libjpeg.so.11)
===>   libreoffice-4.3.4 depends on shared library: liblcms2.so - found (/usr/local/lib/liblcms2.so.2.0.6)
===>   libreoffice-4.3.4 depends on shared library: libcdr-0.1.so - found (/usr/local/lib/libcdr-0.1.so.1.0.1)
===>   libreoffice-4.3.4 depends on shared library: libetonyek-0.1.so - found (/usr/local/lib/libetonyek-0.1.so.1.0.1)
===>   libreoffice-4.3.4 depends on shared library: libfreehand-0.1.so - found (/usr/local/lib/libfreehand-0.1.so.1.0.0)
===>   libreoffice-4.3.4 depends on shared library: libgltf-0.0.so - found (/usr/local/lib/libgltf-0.0.so.0.0.2)
===>   libreoffice-4.3.4 depends on shared library: libwpg-0.3.so - found (/usr/local/lib/libwpg-0.3.so.3.0.0)
===>   libreoffice-4.3.4 depends on shared library: libpng15.so - found (/usr/local/lib/libpng15.so.15)
===>   libreoffice-4.3.4 depends on shared library: libpoppler.so - found (/usr/local/lib/libpoppler.so.46.0.0)
===>   libreoffice-4.3.4 depends on shared library: liblpsolve55.so - found (/usr/local/lib/liblpsolve55.so)
===>   libreoffice-4.3.4 depends on shared library: libcmis-0.4.so - found (/usr/local/lib/libcmis-0.4.so.4.0.1)
===>   libreoffice-4.3.4 depends on shared library: libharfbuzz.so - found (/usr/local/lib/libharfbuzz.so.0.928.0)
===>   libreoffice-4.3.4 depends on shared library: libmspub-0.1.so - found (/usr/local/lib/libmspub-0.1.so.1.0.1)
===>   libreoffice-4.3.4 depends on shared library: libnss3.so - found (/usr/local/lib/nss/libnss3.so.1)
===>   libreoffice-4.3.4 depends on shared library: libclucene-core.so - found (/usr/local/lib/libclucene-core.so.2.3.3.4)
===>   libreoffice-4.3.4 depends on shared library: libexpat.so - found (/usr/local/lib/libexpat.so.6.0.0)
===>   libreoffice-4.3.4 depends on shared library: libhunspell-1.3.so - found (/usr/local/lib/libhunspell-1.3.so.0.0.0)
===>   libreoffice-4.3.4 depends on shared library: libhyphen.so - found (/usr/local/lib/libhyphen.so.0.3.0)
===>   libreoffice-4.3.4 depends on shared library: libabw-0.1.so - found (/usr/local/lib/libabw-0.1.so.1.0.0)
===>   libreoffice-4.3.4 depends on shared library: libe-book-0.1.so - found (/usr/local/lib/libe-book-0.1.so.1.0.1)
===>   libreoffice-4.3.4 depends on shared library: libexttextcat-2.0.so - found (/usr/local/lib/libexttextcat-2.0.so.0.0.0)
===>   libreoffice-4.3.4 depends on shared library: libmwaw-0.3.so - found (/usr/local/lib/libmwaw-0.3.so.3.0.3)
===>   libreoffice-4.3.4 depends on shared library: libodfgen-0.1.so - found (/usr/local/lib/libodfgen-0.1.so.1.0.1)
===>   libreoffice-4.3.4 depends on shared library: librevenge-0.0.so - found (/usr/local/lib/librevenge-0.0.so.0.0.1)
===>   libreoffice-4.3.4 depends on shared library: libvisio-0.1.so - found (/usr/local/lib/libvisio-0.1.so.1.0.0)
===>   libreoffice-4.3.4 depends on shared library: libwpd-0.10.so - found (/usr/local/lib/libwpd-0.10.so.10.0.0)
===>   libreoffice-4.3.4 depends on shared library: libwps-0.3.so - found (/usr/local/lib/libwps-0.3.so.3.0.0)
===>   libreoffice-4.3.4 depends on shared library: libxml2.so - found (/usr/local/lib/libxml2.so.2.9.2)
===>   libreoffice-4.3.4 depends on shared library: libxslt.so - found (/usr/local/lib/libxslt.so.2)
===>   libreoffice-4.3.4 depends on shared library: libmythes-1.2.so - found (/usr/local/lib/libmythes-1.2.so.0.0.0)
===>   libreoffice-4.3.4 depends on shared library: librdf.so - found (/usr/local/lib/librdf.so.0.0.0)
===>   libreoffice-4.3.4 depends on shared library: libserf-1.so - found (/usr/local/lib/libserf-1.so.1.3.0)
===>   libreoffice-4.3.4 depends on shared library: libcups.so - found (/usr/local/lib/libcups.so.2)
===>   libreoffice-4.3.4 depends on shared library: libdbus-glib-1.so - found (/usr/local/lib/libdbus-glib-1.so.2.2.2)
===>   libreoffice-4.3.4 depends on shared library: libldap-2.4.so.2 - found (/usr/local/lib/libldap-2.4.so.2.10.3)
===>   libreoffice-4.3.4 depends on shared library: libGL.so - found (/usr/local/lib/libGL.so)
===>   libreoffice-4.3.4 depends on shared library: libGLU.so - found (/usr/local/lib/libGLU.so.1.3.1)
===>   libreoffice-4.3.4 depends on shared library: libatk-1.0.so - found (/usr/local/lib/libatk-1.0.so.0.21409.1)
===>   libreoffice-4.3.4 depends on shared library: libgconf-2.so - found (/usr/local/lib/libgconf-2.so.4.1.5)
===>   libreoffice-4.3.4 depends on shared library: libgdk_pixbuf-2.0.so - found (/usr/local/lib/libgdk_pixbuf-2.0.so.0.3100.1)
===>   libreoffice-4.3.4 depends on shared library: libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so.0.4200.0)
===>   libreoffice-4.3.4 depends on shared library: libpcre.so - found (/usr/local/lib/libpcre.so.3)
===>   libreoffice-4.3.4 depends on shared library: libgtk-x11-2.0.so - found (/usr/local/lib/libgtk-x11-2.0.so.0.2400.25)
===>   libreoffice-4.3.4 depends on shared library: libIDL-2.so - found (/usr/local/lib/libIDL-2.so.0.0.0)
===>   libreoffice-4.3.4 depends on shared library: libxml2.so - found (/usr/local/lib/libxml2.so.2.9.2)
===>   libreoffice-4.3.4 depends on shared library: libORBit-2.so - found (/usr/local/lib/libORBit-2.so.0.1.0)
===>   libreoffice-4.3.4 depends on shared library: libpango-1.0.so - found (/usr/local/lib/libpango-1.0.so.0.3600.8)
===>  Configuring for libreoffice-4.3.4
===>   FreeBSD 10 autotools fix applied to /usr/ports/editors/libreoffice/work/libreoffice-4.3.4.1/aclocal.m4
===>   FreeBSD 10 autotools fix applied to /usr/ports/editors/libreoffice/work/libreoffice-4.3.4.1/configure
/usr/local/bin/autom4te-2.69: not found
aclocal-1.14: error: echo failed with exit status: 127
*** Error code 127

Stop.
make[1]: stopped in /usr/ports/editors/libreoffice
Comment 1 Bugzilla Automation freebsd_committer 2014-11-27 19:58:28 UTC
Auto-assigned to maintainer office@FreeBSD.org
Comment 2 rkoberman 2015-05-29 05:23:25 UTC
It appears the latest update to autoconf-2.69. I believe that this can be closed.