Bug 195464 - [NEW PORT] devel/PHPUnit4: A unit testframework for PHP
Summary: [NEW PORT] devel/PHPUnit4: A unit testframework for PHP
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords: patch, patch-ready
Depends on:
Blocks:
 
Reported: 2014-11-28 10:17 UTC by Torsten Zühlsdorff
Modified: 2015-03-02 06:30 UTC (History)
4 users (show)

See Also:
ports: maintainer-feedback+


Attachments
the new port (1.69 KB, text/plain)
2014-11-28 10:17 UTC, Torsten Zühlsdorff
ports: maintainer-approval-
Details
Updated shar for 4.4.5, with mentioned changes. (1.72 KB, text/plain)
2015-02-04 17:34 UTC, fullermd
no flags Details
Updated for 4.5.0 (1.72 KB, text/plain)
2015-02-07 02:00 UTC, fullermd
koobs: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten Zühlsdorff 2014-11-28 10:17:36 UTC
Created attachment 149949 [details]
the new port

PHPUnit 4 is released long ago. Version3 (devel/pear-PHPUnit3) is no longer supported. Also installation via pear will be removed in future. The port closes the gap and allows the PHP developer to run their tests.

Portlint says:
root@hera:/usr/ports/devel/PHPUnit4 # portlint -A
looks fine.
Comment 1 fullermd 2015-02-04 17:33:39 UTC
I for one would very much like to see this brought in.

Here's an adjusted version with some changes I suggest:

- Just call it 'phpunit'; the mixed-case name just makes things harder, and the version number in the directory would only become necessary if we start carrying multiple versions.  We can deal with that if it ever happens.

- Correct LICENSE.

- Adjust the "build" process in a few ways.
  - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM + messing with STRIP
  - Use an explicit do-extract target override, rather than EXTRACT_ONLY fakery to avoid doing any extraction, and then extra ugliness by overriding WRKSRC to point at DISTDIR.  Ugh.
  - Explicitly copying into WRKDIR in a custom do-extract, then INSTALL_SCRIPT'ing in a custom do-install, is IMO a lot cleaner and most self-documenting.

- Update to the now-current version, since this submission is a couple months old now.  (I note that the next minor version is actually due in the next couple days).


This installs cleanly on my system, and runs/passes/fails some of my phpunit tests as expected in some quick testing.
Comment 2 fullermd 2015-02-04 17:34:55 UTC
Created attachment 152559 [details]
Updated shar for 4.4.5, with mentioned changes.
Comment 3 fullermd 2015-02-07 02:00:13 UTC
Created attachment 152648 [details]
Updated for 4.5.0

And now 4.5.0 is out, so here's the updated version for that (with aforementioned changes).
Comment 4 Torsten Zühlsdorff 2015-02-09 09:31:17 UTC
Update works fine. I've created an poudriere test:
http://ports.toco-domains.de/poudriere-test-logs/phpunit-4.5.0.log

Thanks for your patch. Its much nicer than my work; i learned from it :)
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2015-02-16 04:09:59 UTC
Torsten,

Can you please approve attachment 152648 [details] and obsolete attachment 149949 [details]
Comment 6 Torsten Zühlsdorff 2015-02-16 19:47:15 UTC
Kubilay,

i'm sorry, this is my first time to approve something. How do i do this? I've already obsoleted my old patch and set the maintainer-feedback flag "+". Is that all or do i miss something?

Thanks and greetings,
Torsten
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2015-02-16 23:05:11 UTC
(In reply to Torsten Zühlsdorff from comment #6)

Perfect, almost there :) You just need to set the flag next to the patch (attachment) you want to approve. 

You can do this by clicking "Details" and then setting maintainer-approval to "+"

Note the difference between maintainer-FEEDBACK, and maintainer-APPROVAL :)

The former is for acknowledging your RESPONSES as maintainer at the ISSUE level, the latter is for adding your APPROVAL for changes at the ATTACHMENT/PATCH level.

Hope that helps :)
Comment 8 Torsten Zühlsdorff 2015-02-17 09:06:26 UTC
Mh... i do not have the possibility to do this. If i click on Details of the  attachment, i just see the text:

koobs: maintainer‑approval? (ports)

But there is no field to change something? Is this an error or do i overlook something?

Thanks,
Torsten
Comment 9 Kubilay Kocak freebsd_committer freebsd_triage 2015-02-17 12:43:25 UTC
Quite possibly a permissions issue. I'll investigate, and in the meantime I have set the flag for you.
Comment 10 Kurt Jaeger freebsd_committer 2015-02-21 19:36:18 UTC
Build-Testing @work
Comment 11 commit-hook freebsd_committer 2015-02-21 20:16:08 UTC
A commit references this bug:

Author: pi
Date: Sat Feb 21 20:15:13 UTC 2015
New revision: 379546
URL: https://svnweb.freebsd.org/changeset/ports/379546

Log:
  New port: devel/phpunit 4.5.0

  PHPUnit is a regression testing framework used by the developer
  who implements unit tests in PHP. It is the most recent version
  of PHPUnit, but no longer distributed over PEAR.

  WWW: http://www.phpunit.de

  Note: This will probably replace devel/pear-PHPUnit3 soon.

  PR:		195464
  Submitted by:	Torsten Z?hlsdorff <ports@toco-domains.de>, fullermd@over-yonder.net

Changes:
  head/devel/Makefile
  head/devel/phpunit/
  head/devel/phpunit/Makefile
  head/devel/phpunit/distinfo
  head/devel/phpunit/pkg-descr
Comment 12 Kurt Jaeger freebsd_committer 2015-02-21 20:17:59 UTC
Committed, thanks.

Now we need to retire devel/pear-PHPUnit3.