Bug 195489 - security/gnupg: Needs to conflict with dirmngr
Summary: security/gnupg: Needs to conflict with dirmngr
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jun Kuriyama
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-28 22:26 UTC by Raphael Kubo da Costa
Modified: 2014-12-28 14:18 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (kuriyama)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael Kubo da Costa freebsd_committer 2014-11-28 22:26:28 UTC
If one's updating from gnupg 2.0.x to 2.1.x, there's nothing in the latter's Makefile to make it conflict with security/dirmngr, which is a runtime dependency of security/gnupg20.

Which means that the upgrade only fails at the end:
===>   Registering installation for gnupg-2.1.0_1
pkg-static: gnupg-2.1.0_1 conflicts with dirmngr-1.1.0_12 (installs files into the same place).  Problematic file: /usr/local/bin/dirmngr
Comment 1 Bugzilla Automation freebsd_committer 2014-11-28 22:26:28 UTC
Auto-assigned to maintainer kuriyama@FreeBSD.org
Comment 2 Jun Kuriyama freebsd_committer 2014-12-28 14:18:02 UTC
Fix committed, thanks!