Bug 195674 - [PATCH] dns/unbound: Update to v1.5.0
Summary: [PATCH] dns/unbound: Update to v1.5.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Sergey Matveychuk
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-04 07:51 UTC by lightside
Modified: 2014-12-05 18:54 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (sem)


Attachments
Proposed patch (since 373710 revision) (3.61 KB, patch)
2014-12-04 07:51 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64, default options) (10.58 KB, application/x-zip-compressed)
2014-12-04 07:52 UTC, lightside
no flags Details
The poudriere testport log (FreeBSD 10 amd64, with libevent enabled) (10.96 KB, application/x-zip-compressed)
2014-12-04 07:53 UTC, lightside
no flags Details
The poudriere testport log (FreeBSD 10 amd64, with all options enabled) (12.27 KB, application/x-zip-compressed)
2014-12-04 07:53 UTC, lightside
no flags Details
Proposed patch (since 373710 revision) (3.95 KB, patch)
2014-12-04 08:40 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64, with all options enabled) (12.24 KB, application/x-zip-compressed)
2014-12-04 08:41 UTC, lightside
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description lightside 2014-12-04 07:51:43 UTC
Created attachment 150176 [details]
Proposed patch (since 373710 revision)

Patch to update dns/unbound port from 1.4.22 to 1.5.0 version.

Look following link for changes:
http://www.unbound.net/download.html

- Removed FreeBSD 10 check for libevent, because of upstream fixes (as stated in changelog)
- Converted files/patch-Makefile.in to sed patch, which is position independent
- Changed pkg-plist
Comment 1 Bugzilla Automation freebsd_committer 2014-12-04 07:51:43 UTC
Auto-assigned to maintainer sem@FreeBSD.org
Comment 2 lightside 2014-12-04 07:52:28 UTC
Created attachment 150177 [details]
The poudriere testport log (FreeBSD 10 amd64, default options)
Comment 3 lightside 2014-12-04 07:53:09 UTC
Created attachment 150178 [details]
The poudriere testport log (FreeBSD 10 amd64, with libevent enabled)
Comment 4 lightside 2014-12-04 07:53:54 UTC
Created attachment 150179 [details]
The poudriere testport log (FreeBSD 10 amd64, with all options enabled)
Comment 5 lightside 2014-12-04 08:40:52 UTC
Created attachment 150180 [details]
Proposed patch (since 373710 revision)

Removed BROKEN line from files/pkg-message.in.
Comment 6 lightside 2014-12-04 08:41:29 UTC
Created attachment 150181 [details]
The poudriere testport log (FreeBSD 10 amd64, with all options enabled)
Comment 7 lightside 2014-12-04 09:24:37 UTC
I can confirm that unbound works on FreeBSD 10 with libevent option enabled:
# uname -r
10.0-RELEASE-p12

# cat /var/db/ports/dns_unbound/options
# This file is auto-generated by 'make config'.
# Options for unbound-1.5.0
_OPTIONS_READ=unbound-1.5.0
_FILE_COMPLETE_OPTIONS_LIST=DOCS ECDSA GOST LIBEVENT MUNIN PYTHON THREADS
OPTIONS_FILE_SET+=DOCS
OPTIONS_FILE_SET+=ECDSA
OPTIONS_FILE_UNSET+=GOST
OPTIONS_FILE_SET+=LIBEVENT
OPTIONS_FILE_UNSET+=MUNIN
OPTIONS_FILE_UNSET+=PYTHON
OPTIONS_FILE_SET+=THREADS

# ldd /usr/local/sbin/unbound
/usr/local/sbin/unbound:
	libssl.so.7 => /usr/lib/libssl.so.7 (0x8008be000)
	libutil.so.9 => /lib/libutil.so.9 (0x800b28000)
	libevent-2.0.so.5 => /usr/local/lib/libevent-2.0.so.5 (0x800d3a000)
	libcrypto.so.7 => /lib/libcrypto.so.7 (0x800f7d000)
	libthr.so.3 => /lib/libthr.so.3 (0x801368000)
	libc.so.7 => /lib/libc.so.7 (0x80158d000)

# /usr/local/sbin/unbound -h | grep libs
linked libs: libevent 2.0.21-stable (it uses kqueue), OpenSSL 1.0.1e-freebsd 11 Feb 2013

# top | grep unbound
  772 unbound          2  20    0 38648K  9732K kqread  2   0:00   0.00% unbound
Comment 8 commit-hook freebsd_committer 2014-12-05 18:53:38 UTC
A commit references this bug:

Author: sem
Date: Fri Dec  5 18:52:55 UTC 2014
New revision: 374077
URL: https://svnweb.freebsd.org/changeset/ports/374077

Log:
  - Update to 1.5.0
  - Removed FreeBSD 10 check for libevent, because of upstream fixes (as stated in changelog)
  - Converted files/patch-Makefile.in to sed patch, which is position independent

  PR:		195674
  Submitted by:	lightside@gmx.com

Changes:
  head/dns/unbound/Makefile
  head/dns/unbound/distinfo
  head/dns/unbound/files/patch-Makefile.in
  head/dns/unbound/files/pkg-message.in
  head/dns/unbound/pkg-plist
Comment 9 Sergey Matveychuk freebsd_committer 2014-12-05 18:54:47 UTC
Thank you