Bug 195698 - dns/dnscrypt-proxy support for multiple service instances
Summary: dns/dnscrypt-proxy support for multiple service instances
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Carlo Strub
URL: http://forums.freebsd.org/threads/run...
Keywords: easy, feature, patch
: 195697 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-05 01:36 UTC by Igor Pavlov
Modified: 2015-09-14 22:30 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (freebsd)


Attachments
dnscrypt-proxy rc-script (2.61 KB, text/plain)
2014-12-05 01:36 UTC, Igor Pavlov
no flags Details
multi and single RC in one port (6.12 KB, patch)
2015-04-06 22:49 UTC, Leo Vandewoestijne
freebsd: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Pavlov 2014-12-05 01:36:32 UTC
Created attachment 150213 [details]
dnscrypt-proxy rc-script

I would like to suggest a modified rc-script to support for multiple dnscrypt_proxy instances.

One can use it in this way in the /etc/rc.conf:

dnscrypt_proxy_enable="YES"
dnscrypt_proxy_instances="dnscrypt_proxy_1 dnscrypt_proxy_2 dnscrypt_proxy_3"
dnscrypt_proxy_1_resolver="dnscrypt.eu-nl"
dnscrypt_proxy_1_flags="-a 127.0.0.2"
dnscrypt_proxy_2_resolver="dnscrypt.eu-dk"
dnscrypt_proxy_2_flags="-a 127.0.0.3"
dnscrypt_proxy_3_resolver="cloudns-can"
dnscrypt_proxy_3_flags="-a 127.0.0.4"

I have no experience in writing rc-scripts, so it can be quite buggy, but it works for me.
Comment 1 Bugzilla Automation freebsd_committer 2014-12-05 01:36:32 UTC
Maintainer CC'd
Comment 2 Igor Pavlov 2014-12-05 03:02:33 UTC
*** Bug 195697 has been marked as a duplicate of this bug. ***
Comment 3 John Marino freebsd_committer 2015-02-06 17:19:49 UTC
Change status from "new" to "open" since maintainer is aware of this proposal.  (the PR "timed out" but this isn't the type of thing that would get committed without approval)
Comment 4 Leo Vandewoestijne 2015-04-06 22:49:48 UTC
Created attachment 155292 [details]
multi and single RC in one port

Although I haven't been responsive, I did try to find for a perfect solution.
With the CSV file I would hope multiple -R flags would be(come) possible.

Personally I'd prefer to keep it simple, but I understand your point (and your use of it).

I'm aware the script at https://gist.github.com/steakknife/02832ff104df3483c012 is compatible with single-mode.

I haven't tested key-rollovers, which (I think) only dnscrypt.pl does seamlessly.
If that appears to work as intended then I'd like to fully merge it.
For now I made it an config option, so should please everyone (I hope).
Comment 5 commit-hook freebsd_committer 2015-09-14 22:29:16 UTC
A commit references this bug:

Author: cs
Date: Mon Sep 14 22:29:09 UTC 2015
New revision: 396939
URL: https://svnweb.freebsd.org/changeset/ports/396939

Log:
  Add support for multiple service instances

  PR:		195698
  Submitted by:	Igor <arabesc@bk.ru>
  Approved by:	maintainer

Changes:
  head/dns/dnscrypt-proxy/Makefile
  head/dns/dnscrypt-proxy/files/dnscrypt-proxy_multi.in
  head/dns/dnscrypt-proxy/files/pkg-message.in
  head/dns/dnscrypt-proxy/files/pkg-message_multi.in
Comment 6 Carlo Strub freebsd_committer 2015-09-14 22:30:44 UTC
Committed. Thank you very much.