Bug 195800 - [NEW PORT] games/narcissu2: Visual novel about an encounter of terminally ill
Summary: [NEW PORT] games/narcissu2: Visual novel about an encounter of terminally ill
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL:
Keywords:
Depends on: 195799
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-08 08:47 UTC by Jan Beich
Modified: 2015-09-05 23:22 UTC (History)
2 users (show)

See Also:


Attachments
shar, v0 (3.23 KB, text/plain)
2014-12-08 08:47 UTC, Jan Beich
no flags Details
|poudriere testport| log (10.1R i386) (21.40 KB, text/plain)
2014-12-08 08:48 UTC, Jan Beich
no flags Details
shar, v0.1 (3.23 KB, text/plain)
2014-12-08 15:57 UTC, Jan Beich
no flags Details
shar, v0.2 (3.24 KB, text/plain)
2015-01-31 19:06 UTC, Jan Beich
no flags Details
|poudriere testport -P| log (10.1R i386) (27.51 KB, text/plain)
2015-01-31 19:07 UTC, Jan Beich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2014-12-08 08:47:16 UTC
Created attachment 150338 [details]
shar, v0

Narcissu is a free visual novel by the doujin group stage-nana, telling
the story of a terminally ill young man and woman. It was made with
the NScripter engine. -- Wikipedia

This package includes English translation for both Narcissu and
Narcissu: Side 2nd.

WWW: http://www.neechin.net/narcissu/
Comment 1 Jan Beich freebsd_committer 2014-12-08 08:48:50 UTC
Created attachment 150339 [details]
|poudriere testport| log (10.1R i386)
Comment 2 Jan Beich freebsd_committer 2014-12-08 15:57:26 UTC
Created attachment 150353 [details]
shar, v0.1

- drop USES=tar as EXTRACT_SUFX isn't used
- tweak LICENSE_NAME to hint where LICENSE_TEXT came from
Comment 3 sasamotikomi 2015-01-31 14:30:31 UTC
(In reply to Jan Beich from comment #2)

Since you make onscripter port maybe you can remake it into native version?
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=196654

but a little problem English version narcissu (1) used onscripter-en branch I don't know merged or not any changes to original branch
http://unclemion.com/hg/onscripter-en/

and English version Narcissu -Side 2nd-  used PONScripter (maybe already merged)
http://unclemion.com/hg_onsen.cgi/ponscripter/

Original version in Japanese, isn't it should name as narcissu2-en?
Also isn't better make in modules I mean:
(original game)
narcissu
narcissu2
(original game)
narcissu-jp
narcissu-jp-doc/narcissu-doc-jp
narcissu2-jp
narcissu2-jp-doc/narcissu2-doc-jp
(transslate)
narcissu-en
narcissu2-en
narcissu2-en-doc/narcissu2-doc-en
Comment 4 Jan Beich freebsd_committer 2015-01-31 19:06:22 UTC
Created attachment 152422 [details]
shar, v0.2

(In reply to sasamotikomi from comment #3)
> Since you make onscripter port maybe you can remake it into native version?
> https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=196654

See bug 197229. If you're gonna play don't forget about bug 196655.

> but a little problem English version narcissu (1) used onscripter-en branch I don't know merged or not any changes to original branch
> http://unclemion.com/hg/onscripter-en/

onscripter-en can probably be replaced by devel/onscripter with ENGLISH option enabled. At least, it works fine for Tsukihime's English translation.

games/narcissu2 contains both Narcissu and Narcissu: Side 2nd. So does original Japanese version. Which game to play and whose translation to use you can select after pressing START in the menu.

> and English version Narcissu -Side 2nd-  used PONScripter (maybe already merged)
> http://unclemion.com/hg_onsen.cgi/ponscripter/

devel/ponscripter-sekai is supposed to be compatible. Its upstream maintainer released Narcissu 1st & 2nd on Steam and provides updated precompiled binaries on the Github page.

> Original version in Japanese, isn't it should name as narcissu2-en?

If there're going to be two (or more) versions of the game the one under games/ should probably be for English-speaking. There're no examples of -en suffixed ports under games/ but I see your point, it'd also allow avoiding CONFLICTS.

> Also isn't better make in modules I mean:
> (original game)
> narcissu
> narcissu2
> (original game)
> narcissu-jp
> narcissu-jp-doc/narcissu-doc-jp
> narcissu2-jp
> narcissu2-jp-doc/narcissu2-doc-jp
> (transslate)
> narcissu-en
> narcissu2-en
> narcissu2-en-doc/narcissu2-doc-en

Do you suggest repacking .nsa files? They're different for the original and English version.
Comment 5 Jan Beich freebsd_committer 2015-01-31 19:07:54 UTC
Created attachment 152423 [details]
|poudriere testport -P| log (10.1R i386)
Comment 6 Jan Beich freebsd_committer 2015-02-08 11:52:56 UTC
Hmm, prefix/suffix aren't consistent:

$ pkg query -x '%n-%v %o %Fp' narcissu | fgrep bin
ja-narcissu2-1 japanese/narcissu2 /usr/local/bin/narcissu2
narcissu2-en-1.1 games/narcissu2 /usr/local/bin/narcissu2-en
Comment 7 Jan Beich freebsd_committer 2015-02-09 03:24:25 UTC
https://reviews.freebsd.org/D1807
Comment 8 sasamotikomi 2015-02-19 23:01:40 UTC
(In reply to Jan Beich from comment #4)
I told about change original structure file and make him modular for easy translation replacement, because game have a lot of translations and will be good do it, it's just recommendation.   
https://vndb.org/v10
12 (include original) and 13 (Polish) coming soon it's good but:
Isn't good make a lot duplicate of same images and audio and problem anyway will be anyway duplicate when build as package:

If we make audio and image and script three different package anyway it's make duplicate when was build.

If we add all translation into one package package will be huge(will be problem?).

So will be good make basic script separate it from translation, just menu and loader translation with messenger like "if you want play in game {language} please install {package name} or press install [popup windows with kdesu/qsudo]"
but I understand it's really a lot of work.
Comment 9 commit-hook freebsd_committer 2015-09-05 22:48:34 UTC
A commit references this bug:

Author: jbeich
Date: Sat Sep  5 22:48:11 UTC 2015
New revision: 396196
URL: https://svnweb.freebsd.org/changeset/ports/396196

Log:
  games/narcissu2: add new port

  PR:		195800
  Reviewed by:	games (amdmi3)
  Approved by:	bapt (mentor, previous version)
  Differential Revision:	https://reviews.freebsd.org/D1807

  The anonymous protagonist is diagnosed with a terminal illness shortly
  after his twentieth birthday, and is admitted to a hospital in Mito,
  Ibaraki. There he meets Setsumi, a woman a few years older, who is
  also terminally ill. Finding that they both reject to die either in
  hospital or at home, they steal a car and run away together. -- VNDB

  This package includes English translation for both Narcissu and
  Narcissu: Side 2nd.

  http://www.neechin.net/narcissu/

Changes:
  head/games/Makefile
  head/games/narcissu2/
  head/games/narcissu2/Makefile
  head/games/narcissu2/distinfo
  head/games/narcissu2/pkg-descr
Comment 10 Jan Beich freebsd_committer 2015-09-05 23:22:17 UTC
Landed. Not sure sure I have time to address issues related to non-English versions.