Bug 195820 - [patch] graphics/darktable update to release 1.6.0
Summary: [patch] graphics/darktable update to release 1.6.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jean-Sébastien Pédron
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-09 09:18 UTC by martin
Modified: 2014-12-15 17:52 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (dumbbell)


Attachments
diff -ruN output (12.19 KB, patch)
2014-12-09 09:18 UTC, martin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description martin 2014-12-09 09:18:35 UTC
Created attachment 150390 [details]
diff -ruN output

I tried to make a patch for darktable 1.6.0. Please take a look at it.

Notes:

* The project seems to have moved to Github and I am not sure how to link to the release tag correctly. I tried to link to the official link specified in the release announcement.
* files contains patches for displaying the correct version (the old patches are not applicable anymore)
* extended the pkg-plist file
Comment 1 Bugzilla Automation freebsd_committer 2014-12-09 09:18:35 UTC
Auto-assigned to maintainer dumbbell@FreeBSD.org
Comment 2 Jean-Sébastien Pédron freebsd_committer 2014-12-14 00:30:54 UTC
Hi Martin!

Thank you for your contribution!

Here's a modified version of the patch:
http://people.freebsd.org/~dumbbell/darktable/ports-darktable-1.6.0.patch

There are some changes made to options:
    o  new option, LIBSECRET, enabled by default
    o  SLIDESHOW and SQUISH are enabled by default

USES=compiler:c++11-lib is used instead of checking OSVERSION and setting USE_GCC.
Comment 3 martin 2014-12-14 14:11:52 UTC
It does not download well from the specified source. Also the given size is too small. It should be 73 Megabyte. I think you are trying to download the Linux binaries. I made the same mistake when I tried to find the download location.

# make install
===>  License GPLv3 accepted by the user
===>  Found saved configuration for darktable-1.6.0
===>   darktable-1.6.0 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by darktable-1.6.0 for building
===>  Extracting for darktable-1.6.0
=> SHA256 Checksum mismatch for darktable-1.6.0.tar.xz.
===>  Refetch for 1 more times files: darktable-1.6.0.tar.xz 
===>  License GPLv3 accepted by the user
===>  Found saved configuration for darktable-1.6.0
===>   darktable-1.6.0 depends on file: /usr/local/sbin/pkg - found
=> darktable-1.6.0.tar.xz doesn't seem to exist in /usr/distfiles/.
=> Attempting to fetch https://github.com/darktable-org/darktable/releases/download/release-1.6.0/darktable-1.6.0.tar.xz
darktable-1.6.0.tar.xz                         22% of 2993 kB 4113  Bps 09m37s
fetch: transfer timed out
fetch: darktable-1.6.0.tar.xz appears to be truncated: 678324/3065488 bytes
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/darktable-1.6.0.tar.xz
fetch: http://distcache.FreeBSD.org/ports-distfiles/darktable-1.6.0.tar.xz: Not Found
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/distfiles/ and try again.
*** Error code 1

Stop.
make[2]: stopped in /root/darktable
*** Error code 1

Stop.
make[1]: stopped in /root/darktable
*** Error code 1

Stop.
make: stopped in /root/darktable
Comment 4 Jean-Sébastien Pédron freebsd_committer 2014-12-14 16:05:45 UTC
(In reply to martin from comment #3)
> It does not download well from the specified source.

I just tried again and the file downloaded properly.

> Also the given size is too small. It should be 73 Megabyte. I
> think you are trying to download the Linux binaries.

No, the link is correct: this is the one published on the 1.6 announcement:
http://www.darktable.org/2014/12/released-darktable-1-6/

I wonder why it timed out for you. Could you please try again?
Comment 5 martin 2014-12-14 21:06:54 UTC
Oh yes, I tried now and it worked, but still choking at 2 MB for a long time. I wonder why the snapshot is 73 MB and the source package 2,8 MB and why the snapshot downloads A LOT QUICKER. I originally have tried to download from this source, too, but I've had all this download errors and tried the snapshot.

After these initial download problems it installs fine for me and seems to work OK.
Comment 6 commit-hook freebsd_committer 2014-12-15 17:51:05 UTC
A commit references this bug:

Author: dumbbell
Date: Mon Dec 15 17:51:00 UTC 2014
New revision: 374758
URL: https://svnweb.freebsd.org/changeset/ports/374758

Log:
  graphics/darktable: Update to 1.6.0

  The release notes of this new stable branch are available on the
  darktable website:
  http://www.darktable.org/2014/12/released-darktable-1-6/

  The following changes was made to the options:

      o  LIBSECRET is a new option, turned off by default. When selected,
         darktable can use libsecret as a password storage backend. This
         can be useful for GNOME 3 users and it may be turned on by
         default in the future as the dependency is light.

      o  SLIDESHOW is turned on by default: the features received
         enhancements in 1.6.0.

      o  SQUISH is turned on by default. This library is used to compress
         thumbnail and it's recommanded by the darktable developers.

  PR:		195820
  Differential Revision:	https://reviews.freebsd.org/D1311
  Submitted by:	martin@sugioarto.com (earlier version)
  Reviewed by:	antoine
  Approved by:	antoine

Changes:
  head/graphics/darktable/Makefile
  head/graphics/darktable/distinfo
  head/graphics/darktable/files/
  head/graphics/darktable/pkg-plist