Bug 195829 - Update 9.2 to 9.3 make crash with using FIFOs and logger. mbuf(9)
Summary: Update 9.2 to 9.3 make crash with using FIFOs and logger. mbuf(9)
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 9.3-RELEASE
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-09 17:07 UTC by Ghislain POTIER
Modified: 2019-08-28 13:30 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ghislain POTIER 2014-12-09 17:07:59 UTC
Hi,

One block bug after migrate 9.2 to 9.3

Step To Reproduce :

- Fresh install and no tuning system

- Make a simple sample for testing
jot - 1 10000000 > sample.txt

- Modify syslog.conf :

With this line at the end of syslog.conf

tail -5 /etc/syslog.conf
...
!ppp
*.*                                             /var/log/ppp.log
!named
*.*                                             @127.0.0.1:515
!*

service syslogd restart

- Show statistics recorded by the memory management routines with netstat -m

while true; do netstat -m; echo; sleep 3; done

- Send data to syslog (1)
cat sample.txt | logger -t 'named'

---

root@92:/etc # uname -a
FreeBSD 92 9.2-RELEASE FreeBSD 9.2-RELEASE #0 r255898: Thu Sep 26 22:50:31 UTC 2013     root@bake.isc.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

netstat show this alternate two value each 3 seconds.

256/134/390/16640 mbuf clusters in use (current/cache/total/max)
256/128 mbuf+clusters out of packet secondary zone in use (current/cache)
0/2/2/8320 4k (page size) jumbo clusters in use (current/cache/total/max)
0/0/0/4160 9k jumbo clusters in use (current/cache/total/max)
0/0/0/2080 16k jumbo clusters in use (current/cache/total/max)
576K/373K/949K bytes allocated to network (current/cache/total)
0/0/0 requests for mbufs denied (mbufs/clusters/mbuf+clusters)
0/0/0 requests for mbufs delayed (mbufs/clusters/mbuf+clusters)
0/0/0 requests for jumbo clusters delayed (4k/9k/16k)
0/0/0 requests for jumbo clusters denied (4k/9k/16k)
0/0/0 sfbufs in use (current/peak/max)
0 requests for sfbufs denied
0 requests for sfbufs delayed
0 requests for I/O initiated by sendfile
0 calls to protocol drain routines

385/260/645 mbufs in use (current/cache/total)
256/134/390/16640 mbuf clusters in use (current/cache/total/max)
256/128 mbuf+clusters out of packet secondary zone in use (current/cache)
0/2/2/8320 4k (page size) jumbo clusters in use (current/cache/total/max)
0/0/0/4160 9k jumbo clusters in use (current/cache/total/max)
0/0/0/2080 16k jumbo clusters in use (current/cache/total/max)
608K/341K/949K bytes allocated to network (current/cache/total)
0/0/0 requests for mbufs denied (mbufs/clusters/mbuf+clusters)
0/0/0 requests for mbufs delayed (mbufs/clusters/mbuf+clusters)
0/0/0 requests for jumbo clusters delayed (4k/9k/16k)
0/0/0 requests for jumbo clusters denied (4k/9k/16k)
0/0/0 sfbufs in use (current/peak/max)
0 requests for sfbufs denied
0 requests for sfbufs delayed
0 requests for I/O initiated by sendfile
0 calls to protocol drain routines

(1) return 0

---

Same procedure for

uname -a
FreeBSD 93 9.3-RELEASE FreeBSD 9.3-RELEASE #0 r268512: Thu Jul 10 23:44:39 UTC 2014     root@snap.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

256/134/390/30332 mbuf clusters in use (current/cache/total/max)
256/128 mbuf+clusters out of packet secondary zone in use (current/cache)
0/2/2/15166 4k (page size) jumbo clusters in use (current/cache/total/max)
0/0/0/4493 9k jumbo clusters in use (current/cache/total/max)
0/0/0/2527 16k jumbo clusters in use (current/cache/total/max)
576K/48744K/49320K bytes allocated to network (current/cache/total)
3131056/0/0 requests for mbufs denied (mbufs/clusters/mbuf+clusters)
16/0/0 requests for mbufs delayed (mbufs/clusters/mbuf+clusters)
0/0/0 requests for jumbo clusters delayed (4k/9k/16k)
0/0/0 requests for jumbo clusters denied (4k/9k/16k)
0/0/0 sfbufs in use (current/peak/max)
0 requests for sfbufs denied
0 requests for sfbufs delayed
0 requests for I/O initiated by sendfile
0 calls to protocol drain routines

... some time

188371/5759/194130 mbufs in use (current/cache/total)
256/134/390/30332 mbuf clusters in use (current/cache/total/max)
256/128 mbuf+clusters out of packet secondary zone in use (current/cache)
0/2/2/15166 4k (page size) jumbo clusters in use (current/cache/total/max)
0/0/0/4493 9k jumbo clusters in use (current/cache/total/max)
0/0/0/2527 16k jumbo clusters in use (current/cache/total/max)
47604K/1715K/49320K bytes allocated to network (current/cache/total)
3175219/0/0 requests for mbufs denied (mbufs/clusters/mbuf+clusters)
16/0/0 requests for mbufs delayed (mbufs/clusters/mbuf+clusters)
0/0/0 requests for jumbo clusters delayed (4k/9k/16k)
0/0/0 requests for jumbo clusters denied (4k/9k/16k)
0/0/0 sfbufs in use (current/peak/max)
0 requests for sfbufs denied
0 requests for sfbufs delayed
0 requests for I/O initiated by sendfile
0 calls to protocol drain routines

194001/129/194130 mbufs in use (current/cache/total)
256/134/390/30332 mbuf clusters in use (current/cache/total/max)
256/128 mbuf+clusters out of packet secondary zone in use (current/cache)
0/2/2/15166 4k (page size) jumbo clusters in use (current/cache/total/max)
0/0/0/4493 9k jumbo clusters in use (current/cache/total/max)
0/0/0/2527 16k jumbo clusters in use (current/cache/total/max)
49012K/308K/49320K bytes allocated to network (current/cache/total)
3288207/0/0 requests for mbufs denied (mbufs/clusters/mbuf+clusters)
16/0/0 requests for mbufs delayed (mbufs/clusters/mbuf+clusters)
0/0/0 requests for jumbo clusters delayed (4k/9k/16k)
0/0/0 requests for jumbo clusters denied (4k/9k/16k)
0/0/0 sfbufs in use (current/peak/max)
0 requests for sfbufs denied
0 requests for sfbufs delayed
0 requests for I/O initiated by sendfile
0 calls to protocol drain routines

/!\ You lost the control of the system, sshd is broken and you can't logged on the console.

---

Testing on 

FreeBSD 101 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401: Tue Nov 11 21:02:49 UTC 2014     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64

No problem.
Comment 1 Gleb Popov freebsd_committer 2019-08-01 12:33:05 UTC
I tried reproduction steps on both 11.2 and 12.0. Everything seems to be working and mbuf values stay pretty low during the process. I don't see those huge

> 188371/5759/194130 mbufs in use

The only thing to mention is that

# cat sample.txt | logger -t 'named'

command takes visibly longer time to complete on 12.0, than on 11.2.

Can this PR can be closed, then?