Bug 195875 - [patch][maintainer] graphics/qgis: fix for FreeBSD<10.0 and update to 2.6.1
Summary: [patch][maintainer] graphics/qgis: fix for FreeBSD<10.0 and update to 2.6.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-11 06:07 UTC by Rainer Hurling
Modified: 2014-12-14 19:23 UTC (History)
3 users (show)

See Also:


Attachments
Patch containing update and fix for QGIS 2.6.1 (3.06 KB, patch)
2014-12-11 06:07 UTC, Bugzilla Automation
no flags Details | Diff
introduce devel/qscintilla2 in LIB_DEPENDS (3.94 KB, patch)
2014-12-14 16:29 UTC, Rainer Hurling
rhurlin: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Hurling 2014-12-11 06:07:36 UTC
Created attachment 150459 [details]
Patch containing update and fix for QGIS 2.6.1

- update 2.6.0 to 2.6.1
- fix a build error with base flex for 8.x and 9.x
- add dependency for graphics/py-psycopg2 (for QGIS extensions)


On 8.x and 9.x the systems flex version does not support options 'reentrant' 
and 'bison-bridge', please see exemplary build error logs for 9.x:

[1] http://beefy2.isc.freebsd.org/data/91amd64-default/2014-12-03_22h28m43s/logs/qgis-2.6.0.log
[2] http://beefy1.isc.freebsd.org/data/84i386-default/2014-12-05_18h55m43s/logs/qgis-2.6.0.log

After some analysis and intensive search I found a solution in 
net-mgmt/icinga2, thanks to Marco Steinbach (CoCo).


---------------
#portlint -AC:
WARN: /usr/ports/graphics/qgis/pkg-plist: [527]: enumerating info files in the plist is deprecated in favor of adding info files into the Makefile using the INFO macro.

Please note, that there is no info file within pkg-plist, instead it is a 
command from databases/grass.

---------------
Several Poudriere runs successful:
/poudriere/data/logs/bulk/HEADamd64-default-qgis/latest/log/qgis-2.6.1.log
/poudriere/data/logs/bulk/93amd64-default-qgis/latest/logs/qgis-2.6.1.log
/poudriere/data/logs/bulk/84i386-default-qgis/latest/logs/qgis-2.6.1.log

I can provide the logs, if needed.
Comment 1 Thomas Zander freebsd_committer 2014-12-14 13:05:10 UTC
This does not build with all OPTIONS deselected:

...
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
QSCINTILLA_INCLUDE_DIR
   used as include directory in directory /wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/src/gui
   used as include directory in directory /wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/src/providers/mssql
   used as include directory in directory /wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/src/providers/wfs
   used as include directory in directory /wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/src/providers/spatialite
   used as include directory in directory /wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/src/app
   used as include directory in directory /wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/src/app
   used as include directory in directory /wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/src/app
QSCINTILLA_LIBRARY
    linked by target "qgis_core" in directory /wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/src/core
    linked by target "qgis_gui" in directory /wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/src/gui

-- Configuring incomplete, errors occurred!
See also "/wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/CMakeFiles/CMakeOutput.log".
See also "/wrkdirs/usr/ports/graphics/qgis/work/qgis-QGIS-e2a51df/CMakeFiles/CMakeError.log".
*** Error code 1
Comment 2 Wen Heping freebsd_committer 2014-12-14 14:43:19 UTC
Seems qscintilla2 should be always depended. 

wen
Comment 3 Thomas Zander freebsd_committer 2014-12-14 15:06:51 UTC
(In reply to Wen Heping from comment #2)
> Seems qscintilla2 should be always depended. 

Yes, and it is always useful to test a port with all of its options selected *and* once with all options deselected before submitting. Latter is quite helpful in discovering unexpected dependencies.
Comment 4 Rainer Hurling 2014-12-14 16:29:44 UTC
Created attachment 150573 [details]
introduce devel/qscintilla2 in LIB_DEPENDS

Thanks to riggs@ for pointing out, that there is a missing dependency, only noticeable, if all OPTIONS are disabled. The updated patch should respect this.

- new LIB_DEPENDS devel/qscintilly2
- while here, sorting LIB_DEPENDS entries alphabetically
Comment 5 commit-hook freebsd_committer 2014-12-14 19:17:16 UTC
A commit references this bug:

Author: riggs
Date: Sun Dec 14 19:16:20 UTC 2014
New revision: 374719
URL: https://svnweb.freebsd.org/changeset/ports/374719

Log:
  - Update to 2.6.1
  - Fix build error for 8.x and 9.x (base flex)

  PR:		195875
  Submitted by:	rhurlin@gwdg.de (maintainer)

Changes:
  head/graphics/qgis/Makefile
  head/graphics/qgis/distinfo
  head/graphics/qgis/pkg-plist
Comment 6 Thomas Zander freebsd_committer 2014-12-14 19:23:31 UTC
No worries, thanks for double-checking and providing the updated patch so quickly.
Committed, thx!