Bug 195932 - audio/taglib - Does't seems to make a debug build
Summary: audio/taglib - Does't seems to make a debug build
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Jason E. Hale
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-13 05:28 UTC by martin
Modified: 2019-07-27 21:06 UTC (History)
20 users (show)

See Also:
bugzilla: maintainer-feedback? (jhale)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description martin 2014-12-13 05:28:40 UTC
audio/taglib doesn't seem to make a proper "release" build.

This is problematic, because loading some files results in heaps of errors:

  TagLib: MPEG::Header::parse() -- First byte did not match MPEG synch.
  TagLib: MPEG::Header::parse() -- Invalid sample rate.
  TagLib: MPEG::Header::parse() -- Invalid sample rate.

  [.. about a 100 similar lines skipped ...]

This can be reproduces with:

  #include <taglib/taglib.h>
  #include <taglib/fileref.h>

  int main() {
          TagLib::FileRef f("08 Dante's Inferno.mp3");
          return 0;
  }

Obviously you need the "right" file for this; which I can't attach here; email me in private if you want it.

If I manually build taglib outside of ports with these commands, everything works fine:

  cmake -DCMAKE_INSTALL_PREFIX=/usr/local -DCMAKE_BUILD_TYPE=Release .
  make
  make install

These commands are from the INSTALL file: https://github.com/taglib/taglib/blob/master/INSTALL


As far as I can see, the FreeBSD port passes -DCMAKE_BUILD_TYPE=Release? 'make -V CMAKE_BUILD_TYPE' gives me 'Release'...

I have never worked with CMake, and wasn't able to find an obvious solution.

I have no special settings in /etc/make.conf:

  WRKDIRPREFIX=/download/tmp/
  PERL_VERSION=5.16.2
  OPTIONS_UNSET=NLS DOCS
  WITH_PKGNG=y

I'm running FreeBSD 10.0; it is also not a new issue, I've seen its at September 2013 for the first time (..but didn't get around investigating it until now).
Comment 1 Bugzilla Automation freebsd_committer 2014-12-13 05:28:40 UTC
Auto-assigned to maintainer jhale@FreeBSD.org
Comment 2 perrymasterson 2016-10-06 10:59:14 UTC
MARKED AS SPAM
Comment 3 zoraya 2016-11-17 12:26:46 UTC
MARKED AS SPAM
Comment 4 james 2017-01-29 14:25:38 UTC
MARKED AS SPAM
Comment 5 Deathray 2017-02-08 11:14:33 UTC
MARKED AS SPAM
Comment 6 Maryjones 2017-03-04 12:48:27 UTC
MARKED AS SPAM
Comment 7 nikhilkanna.1234 2017-03-24 07:51:00 UTC
MARKED AS SPAM
Comment 8 Nick Crowe 2017-05-18 12:03:11 UTC
MARKED AS SPAM
Comment 9 samir satarke 2017-06-04 08:32:12 UTC
MARKED AS SPAM
Comment 10 Pooja 2017-07-28 05:05:52 UTC
MARKED AS SPAM
Comment 11 Pooja 2017-07-28 17:11:58 UTC
MARKED AS SPAM
Comment 12 Jason E. Hale freebsd_committer 2017-07-31 13:14:29 UTC
I'm closing this bug because it has turned into a spam thread.
Comment 13 James 2017-10-14 06:59:53 UTC
MARKED AS SPAM
Comment 14 kinjal 2017-10-14 09:50:05 UTC
MARKED AS SPAM
Comment 15 Full Essay Help 2017-11-08 11:29:48 UTC
MARKED AS SPAM
Comment 16 vali gholami 2017-11-26 20:42:31 UTC
MARKED AS SPAM
Comment 17 hermilie johnson 2017-11-29 11:37:44 UTC
MARKED AS SPAM
Comment 18 albertjohn 2017-12-20 09:45:16 UTC
MARKED AS SPAM
Comment 19 Ava Smith 2018-02-20 09:26:49 UTC
MARKED AS SPAM
Comment 20 hendry jullius 2018-07-04 05:30:46 UTC
MARKED AS SPAM
Comment 21 hendry jullius 2018-07-04 12:15:24 UTC
MARKED AS SPAM
Comment 22 hayes leona 2018-07-18 06:25:18 UTC
MARKED AS SPAM
Comment 23 Muhammad Ibrahim 2018-09-27 02:11:06 UTC
MARKED AS SPAM
Comment 24 flavinha1986 2019-07-27 21:06:35 UTC
This behavior has already been fixed. I tested my way https://filmesdesexo.blog and not occurs any problem.