Bug 195971 - Trap 12: page fault, in sbappendstream_locked()
Summary: Trap 12: page fault, in sbappendstream_locked()
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-14 17:53 UTC by Jean-Sébastien Pédron
Modified: 2015-03-11 20:27 UTC (History)
0 users

See Also:


Attachments
core.txt (214.36 KB, text/plain)
2014-12-14 17:53 UTC, Jean-Sébastien Pédron
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Sébastien Pédron freebsd_committer 2014-12-14 17:53:59 UTC
Created attachment 150577 [details]
core.txt

I had a panic while using VirtualBox. core.txt is attached. I have the full core dump available.

I just paste here what seems to be the most relevant part of the backtrace:

#8  0xffffffff809d1bed in sbappendstream_locked (sb=0xfffff8019920dd30, 
    m=0x0, flags=0)
    at /home/dumbbell/Projects/freebsd/src/GIT/sys/kern/uipc_sockbuf.c:641
#9  0xffffffff809d1cac in sbappendstream (sb=0xfffff8019920dd30, m=0x4, 
    flags=-2130627098)
    at /home/dumbbell/Projects/freebsd/src/GIT/sys/kern/uipc_sockbuf.c:667
#10 0xffffffff80b118ab in tcp_usr_send (so=0xfffff8019920dba0, flags=0, 
    m=0x0, nam=0x0, control=<value optimized out>, td=0xfffff800c02074a0)
    at /home/dumbbell/Projects/freebsd/src/GIT/sys/netinet/tcp_usrreq.c:850

m is NULL, which is unexpected to the following code:

void
sbappendstream_locked(struct sockbuf *sb, struct mbuf *m, int flags)
{
        SOCKBUF_LOCK_ASSERT(sb);

        KASSERT(m->m_nextpkt == NULL,("sbappendstream 0"));
        KASSERT(sb->sb_mb == sb->sb_lastrecord,("sbappendstream 1"));

Note that the panic occurs on line 641, which corresponds to:
        SOCKBUF_LOCK_ASSERT(sb);
Comment 1 Jean-Sébastien Pédron freebsd_committer 2014-12-14 18:00:35 UTC
As I use a Git checkout, the Subversion revision doesn't appear: it corresponds to r275576 for both world and kernel.
Comment 2 Jean-Sébastien Pédron freebsd_committer 2014-12-14 18:11:29 UTC
The panic seems reproducible.

I try to install Debian Wheezy in VirtualBox. The panic occurs as soon as I hit "Continue" on the HTTP proxy dialog (after choosing the package mirror). I'll investigate a bit and report back.

Some more informations:
    o  VirtualBox is 4.3.20_2 installed from a binary package
    o  Debian ISO is debian-7.7.0-amd64-netinst.iso
Comment 3 Jean-Sébastien Pédron freebsd_committer 2015-03-11 20:27:45 UTC
This was fixed in r275955.