Bug 195987 - graphics/sdl_image and graphics/sdl2_image: optionify LIB_DEPENDS
Summary: graphics/sdl_image and graphics/sdl2_image: optionify LIB_DEPENDS
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Marcus von Appen
URL:
Keywords:
: 197238 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-15 06:09 UTC by Jan Beich
Modified: 2015-02-07 08:22 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (mva)


Attachments
optionify, v1 (2.17 KB, patch)
2014-12-15 06:09 UTC, Jan Beich
no flags Details | Diff
|poudriere testport| log (10.1R i386) for graphics/sdl_image (74.93 KB, text/plain)
2014-12-15 06:19 UTC, Jan Beich
no flags Details
|poudriere testport| log (10.1R i386) for graphics/sdl2_image (73.41 KB, text/plain)
2014-12-15 06:20 UTC, Jan Beich
no flags Details
|poudriere testport| log (8.4R amd64) for graphics/sdl_image JPEG=off PNG=off TIFF=off WEBP=off (58.56 KB, text/plain)
2014-12-15 06:24 UTC, Jan Beich
no flags Details
|poudriere testport| log (8.4R amd64) for graphics/sdl2_image JPEG=off PNG=off TIFF=off WEBP=off (58.38 KB, text/plain)
2014-12-15 06:24 UTC, Jan Beich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2014-12-15 06:09:56 UTC
Created attachment 150599 [details]
optionify, v1

- track webp dep in sdl_image
- allow disabling rarely used tiff and webp
Comment 1 Bugzilla Automation freebsd_committer 2014-12-15 06:09:56 UTC
Auto-assigned to maintainer mva@FreeBSD.org
Comment 2 Jan Beich freebsd_committer 2014-12-15 06:12:47 UTC
(In reply to Jan Beich from comment #0)
> - track webp dep in sdl_image

Sorry, I forgot it was my local hack.
Comment 3 Jan Beich freebsd_committer 2014-12-15 06:19:57 UTC
Created attachment 150600 [details]
|poudriere testport| log (10.1R i386) for graphics/sdl_image
Comment 4 Jan Beich freebsd_committer 2014-12-15 06:20:23 UTC
Created attachment 150601 [details]
|poudriere testport| log (10.1R i386) for graphics/sdl2_image
Comment 5 Jan Beich freebsd_committer 2014-12-15 06:24:01 UTC
Created attachment 150602 [details]
|poudriere testport| log (8.4R amd64) for graphics/sdl_image JPEG=off PNG=off TIFF=off WEBP=off
Comment 6 Jan Beich freebsd_committer 2014-12-15 06:24:27 UTC
Created attachment 150603 [details]
|poudriere testport| log (8.4R amd64) for graphics/sdl2_image JPEG=off PNG=off TIFF=off WEBP=off
Comment 7 Marcus von Appen freebsd_committer freebsd_triage 2014-12-18 14:37:28 UTC
I'm a bit hesitant about this change, since misconfiguring one of those ports will break lots of consumers in either functionality or at build time.
I'm not sure, if the gained flexibility outweighs the amount of issues that may arise with it.
Comment 8 Jan Beich freebsd_committer 2014-12-18 15:23:52 UTC
That's a common issue. A few examples that I'm aware where disabling an option may lead to broken build/runtime in consumers.

  audio/soundtouch (INTEGER_SAMPLES)
  devel/guichan (SDL)
  devel/sdl20 (OPENGL)
  databases/sqlite3 (FTS4, THREADS)
  graphics/cairo (GLIB, XCB)
  graphics/gdk-pixbuf2 (PNG)
  graphics/ImageMagick (THREADS)
  graphics/py-pillow (JPEG)
  multimedia/ffmpeg (VDPAU, VAAPI)
  lang/perl5.* (THREADS)

pkg(8) already records options so now we're waiting for bsd.*.mk support. Not sure how similar to Gentoo it'd be.

 # from rlvm.ebuild
RDEPEND="media-libs/libsdl[opengl]
        >=dev-libs/boost-1.42
        media-libs/glew
        media-libs/sdl-image[jpeg,png]
        media-libs/sdl-ttf
        media-libs/sdl-mixer[vorbis]
        media-libs/libmad
        >=dev-games/guichan-0.8[opengl,sdl]
        x11-libs/gtk+:2"
Comment 9 Marcus von Appen freebsd_committer freebsd_triage 2015-02-06 06:15:04 UTC
*** Bug 197238 has been marked as a duplicate of this bug. ***
Comment 10 commit-hook freebsd_committer 2015-02-07 08:22:19 UTC
A commit references this bug:

Author: mva
Date: Sat Feb  7 08:21:47 UTC 2015
New revision: 378574
URL: https://svnweb.freebsd.org/changeset/ports/378574

Log:
  - Provide OPTION knobs for the LIB_DEPENDS of sdl_image and sdl2_image

  PR:		195987
  Submitted by:	jbeich@

Changes:
  head/graphics/sdl2_image/Makefile
  head/graphics/sdl_image/Makefile
Comment 11 Marcus von Appen freebsd_committer freebsd_triage 2015-02-07 08:22:45 UTC
Committed, thanks!