Bug 196015 - mail/cyrus-imapd24 LDFLAGS_UCDSNMP, clang build fails
Summary: mail/cyrus-imapd24 LDFLAGS_UCDSNMP, clang build fails
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Hajimu UMEMOTO
URL:
Keywords:
: 195994 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-16 08:44 UTC by vladimir.nikolic
Modified: 2014-12-19 15:00 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vladimir.nikolic 2014-12-16 08:44:18 UTC
Hello,

cyrus-imapd build fails, if SNMP support is enabled.
Variable:
LDFLAGS_UCDSNMP="-L${PERLLIBDIR} -R${PERLLIBDIR}"
causes build error:
cc: error: unknown argument: '-R/usr/local/lib/perl5/5.18/mach/CORE'

patch-configure should be updated with:
+      LDFLAGS_UCDSNMP="-L${PERLLIBDIR} -Wl,-R${PERLLIBDIR}"
instead of:
+      LDFLAGS_UCDSNMP="-L${PERLLIBDIR} -R${PERLLIBDIR}"

Regards
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-12-17 00:08:40 UTC
Fix Summary and assign.  ume@ maintains both -imap23 and -imap24 so even if the summary is wrong the assignment will be correct.
Comment 2 commit-hook freebsd_committer 2014-12-17 18:05:10 UTC
A commit references this bug:

Author: ume
Date: Wed Dec 17 18:04:22 UTC 2014
New revision: 374866
URL: https://svnweb.freebsd.org/changeset/ports/374866

Log:
  Fix build with clang when SNMP option is enabled.

  PR:		196015

Changes:
  head/mail/cyrus-imapd23/files/patch-configure
Comment 3 Hajimu UMEMOTO freebsd_committer 2014-12-17 18:08:27 UTC
Thank you for the report.
It should be fixed now.
Note that cyrus-imapd24 doesn't have this problem.
Comment 4 Hajimu UMEMOTO freebsd_committer 2014-12-19 15:00:12 UTC
*** Bug 195994 has been marked as a duplicate of this bug. ***