Bug 196090 - [patch] mail/mailgraph rc script bug and little enhancements
Summary: [patch] mail/mailgraph rc script bug and little enhancements
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Rong-En Fan
URL:
Keywords:
: 196089 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-18 11:08 UTC by geoffroy desvernay
Modified: 2014-12-26 16:16 UTC (History)
3 users (show)

See Also:
rafan: maintainer-feedback+


Attachments
proposed changes (2.08 KB, patch)
2014-12-18 11:09 UTC, geoffroy desvernay
no flags Details | Diff
proposed changes + take maintainership (2.34 KB, patch)
2014-12-20 09:44 UTC, geoffroy desvernay
rafan: maintainer-approval+
Details | Diff
[patch] fix broken rc script after last commit (569 bytes, text/plain)
2014-12-23 20:47 UTC, Olli Hauer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description geoffroy desvernay 2014-12-18 11:08:58 UTC
rc bug:

command_interpreter not set correctly, mailgraph can't start: changed to %%PERL%% to match shebang_fix

I propose here some minor improvements:
 - add customizable $mailgraph_maillog
 - use $mailgraph_chdir instead of %%DATADIR%% in rc script where possible (this makes user able to change it without recompiling the port)
 - check readability of maillog before start as mailgraph process is lanched with '>/dev/null 2>&1', thus hidding errors

HTH,
Comment 1 Bugzilla Automation freebsd_committer 2014-12-18 11:08:58 UTC
Auto-assigned to maintainer rafan@FreeBSD.org
Comment 2 geoffroy desvernay 2014-12-18 11:09:39 UTC
Created attachment 150713 [details]
proposed changes
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2014-12-19 23:47:44 UTC
*** Bug 196089 has been marked as a duplicate of this bug. ***
Comment 4 Rong-En Fan freebsd_committer 2014-12-20 03:12:05 UTC
looks good. one question, do you want to take maintainership of this port? I am no longer an active user.
Comment 5 geoffroy desvernay 2014-12-20 09:44:28 UTC
Created attachment 150798 [details]
proposed changes + take maintainership

Yes I may maintain it :)
Comment 6 commit-hook freebsd_committer 2014-12-20 13:26:54 UTC
A commit references this bug:

Author: rafan
Date: Sat Dec 20 13:25:58 UTC 2014
New revision: 375003
URL: https://svnweb.freebsd.org/changeset/ports/375003

Log:
  - rc script enhancements
  - pass maintainership
  - bump PORTREVISION

  PR:		196090
  Submitted by:	geoffroy desvernay <dgeo at centrale-marseille.fr>

Changes:
  head/mail/mailgraph/files/mailgraph.in
Comment 7 commit-hook freebsd_committer 2014-12-20 13:27:55 UTC
A commit references this bug:

Author: rafan
Date: Sat Dec 20 13:27:05 UTC 2014
New revision: 375004
URL: https://svnweb.freebsd.org/changeset/ports/375004

Log:
  - rc script enhancements
  - pass maintainership
  - bump PORTREVISION

  PR:             196090
  Submitted by:   geoffroy desvernay <dgeo at centrale-marseille.fr>

Changes:
  head/mail/mailgraph/Makefile
Comment 8 Krzysztof 2014-12-23 08:13:22 UTC
I've just upgraded mailgraph, but current rc script does not start correctly. I've made some changes which are correct (IMHO :-) ). Should I reopen this bug or make new one?
Comment 9 Olli Hauer freebsd_committer 2014-12-23 20:47:04 UTC
Created attachment 150922 [details]
[patch] fix broken rc script after last commit

variable wrapped in '' are not expanded and the following error is thrown during start.

su: unknown login: $mailgraph_user
MAILGRAPH CANNOT RUN: /var/log/maillog not readable by www
/usr/local/etc/rc.d/mailgraph: WARNING: failed precmd routine for mailgraph
Comment 10 Olli Hauer freebsd_committer 2014-12-23 20:48:22 UTC
Open PR since last patch broke the RC script.
Comment 11 commit-hook freebsd_committer 2014-12-25 13:44:07 UTC
A commit references this bug:

Author: ohauer
Date: Thu Dec 25 13:44:01 UTC 2014
New revision: 375551
URL: https://svnweb.freebsd.org/changeset/ports/375551

Log:
  - fix broken rc script from last commit.
    (var do not expandinside singel quote, so the port failed to start)
  - bump PORTREVISION

  PR:		196090 (followup)
  Approved by:	maintainer (implicit)

Changes:
  head/mail/mailgraph/Makefile
  head/mail/mailgraph/files/mailgraph.in
Comment 12 Olli Hauer freebsd_committer 2014-12-25 13:45:43 UTC
I've committed the rc script patch, else the ports has to be marked as broken!
Comment 13 geoffroy desvernay 2014-12-26 16:16:02 UTC
@ohauer: thank you ! And sorry for the wrong patch, not sufficiently tested :-/