Bug 196169 - [MAINTAINER] games/minecraft-server: Update to 1.8.1
Summary: [MAINTAINER] games/minecraft-server: Update to 1.8.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2014-12-20 23:05 UTC by Jonathan Price
Modified: 2015-01-01 20:22 UTC (History)
2 users (show)

See Also:


Attachments
See description for details (5.28 KB, text/plain)
2014-12-20 23:05 UTC, Jonathan Price
no flags Details
See comment for details (5.47 KB, patch)
2014-12-28 18:04 UTC, Jonathan Price
freebsd: maintainer-approval+
Details | Diff
Added missing entry from pkg-plist (5.50 KB, patch)
2014-12-28 19:44 UTC, Jonathan Price
freebsd: maintainer-approval+
Details | Diff
See notes (5.86 KB, patch)
2014-12-28 20:49 UTC, Jonathan Price
freebsd: maintainer-approval+
Details | Diff
Replaced ${INSTALL_SCRIPT} with ${CP} for java-args.txt (5.84 KB, patch)
2014-12-28 22:18 UTC, Jonathan Price
freebsd: maintainer-approval+
Details | Diff
Added missing file (6.30 KB, patch)
2014-12-29 11:06 UTC, Jonathan Price
freebsd: maintainer-approval+
Details | Diff
Portlint output (481 bytes, text/plain)
2014-12-29 11:07 UTC, Jonathan Price
freebsd: maintainer-approval+
Details
Build output (3.31 KB, text/plain)
2014-12-29 11:08 UTC, Jonathan Price
freebsd: maintainer-approval+
Details
Patch file (6.30 KB, patch)
2014-12-31 17:41 UTC, Jonathan Price
freebsd: maintainer-approval+
Details | Diff
Patch file (6.28 KB, patch)
2014-12-31 17:46 UTC, Jonathan Price
no flags Details | Diff
Poudriere output (19.46 KB, text/plain)
2014-12-31 17:51 UTC, Jonathan Price
freebsd: maintainer-approval+
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Price 2014-12-20 23:05:36 UTC
Created attachment 150821 [details]
See description for details

Summary of changes:
- Upgraded version from 1.8 to 1.8.1
- Moved "base" directory from /usr/local/share to /usr/local
- Adjusted installation / deinstallation messages

Regarding the directory move:
Inherited from the previous versions of this port (before I was maintainer), it stored the jar and configuration in /usr/local/share. Since then, I have learned that /usr/local/share should be reserved for static files, making this an unsuitable location to continue using. For this reason, I have decided to move it to /usr/local/minecraft-server. If somebody thinks there is a more suitable location I would be interested to know.

Also, if you uninstall the old version, and then install the new version, it just leaves eula.txt in /usr/local/share/minecraft-server (expected behaviour). However, if you upgrade over the old version, it doesn't remove any of the files from /usr/local/share/minecraft-server.

I have added a note to the install message mentioning about having to re-accept the EULA and mentioning that /usr/local/share/minecraft-server is now redundant and can be deleted.
Comment 1 Jonathan Price 2014-12-28 18:04:55 UTC
Created attachment 151041 [details]
See comment for details

Two fixes:
- Added a link to the EULA in %%ETCDIR%%, as it makes sense to.
- Updated pkg-message to reflect this change.
Comment 2 Jonathan Price 2014-12-28 19:44:13 UTC
Created attachment 151044 [details]
Added missing entry from pkg-plist
Comment 3 Jonathan Price 2014-12-28 20:49:09 UTC
Created attachment 151048 [details]
See notes

- Added %%ETCDIR%%/java-args.txt, so that the java arguments can be set without having to edit the file in %%PREFIX%%/bin
- Updated pkg-message to reflect the above change
- Removed redundant ETCDIR= line
- Removed redundant PORTREVISION= 0
Comment 4 Jonathan Price 2014-12-28 22:18:02 UTC
Created attachment 151051 [details]
Replaced ${INSTALL_SCRIPT} with ${CP} for java-args.txt
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2014-12-29 04:07:02 UTC
Thanks for your submission Jonathan

For this and future submissions:

- Attach portlint output
- Attach successful build output using poudriere (ideally), or:

make stage && make check-plist && make stage-qa && make package

These will help identify any outstanding issues and encourage committers to take and commit your patches since they are well tested.
Comment 6 Jonathan Price 2014-12-29 11:06:50 UTC
Created attachment 151062 [details]
Added missing file
Comment 7 Jonathan Price 2014-12-29 11:07:17 UTC
Created attachment 151063 [details]
Portlint output
Comment 8 Jonathan Price 2014-12-29 11:08:07 UTC
Created attachment 151064 [details]
Build output

Output from:
make stage
make check-plist
make stage-qa
make package
Comment 9 Jonathan Price 2014-12-29 11:10:29 UTC
(In reply to Kubilay Kocak from comment #5)
> Thanks for your submission Jonathan
> 
> For this and future submissions:
> 
> - Attach portlint output
> - Attach successful build output using poudriere (ideally), or:
> 
> make stage && make check-plist && make stage-qa && make package
> 
> These will help identify any outstanding issues and encourage committers to
> take and commit your patches since they are well tested.

Hi Kubilay,

Thanks for the advice. In running these tests I discovered that I had missed an svn add, causing one of the files to not be included in the diff. I have now fixed this and the tests run successfully. I have attached the output of both tests to the bug.

When I have some time shortly, I will have a look at using poudriere. In the meantime I have run the make stage etc.
Comment 10 Kubilay Kocak freebsd_committer freebsd_triage 2014-12-29 11:23:46 UTC
Perfect Jonathan, thank you for getting all this back to us
Comment 11 Jonathan Price 2014-12-31 17:41:49 UTC
Created attachment 151162 [details]
Patch file

My previous attachment had a malformed patch of pkg-plist, which caused one of the lines to duplicate. That has been fixed in this version.
Comment 12 Jonathan Price 2014-12-31 17:46:19 UTC
Created attachment 151163 [details]
Patch file

Adjusted permissions of bin/minecraft-server
Comment 13 Jonathan Price 2014-12-31 17:51:37 UTC
Created attachment 151164 [details]
Poudriere output

I believe I've done this correctly. I ran a poudriere testport and built this port. Attached is the log file that poudriere generated.
Comment 14 commit-hook freebsd_committer 2015-01-01 20:21:52 UTC
A commit references this bug:

Author: riggs
Date: Thu Jan  1 20:21:38 UTC 2015
New revision: 376029
URL: https://svnweb.freebsd.org/changeset/ports/376029

Log:
  Update to upstream version 1.8.1

  PR:		196169
  Submitted by:	freebsd@jonathanprice.org (maintainer)

Changes:
  head/games/minecraft-server/Makefile
  head/games/minecraft-server/distinfo
  head/games/minecraft-server/files/java-args.txt
  head/games/minecraft-server/files/minecraft-server
  head/games/minecraft-server/files/pkg-deinstall.in
  head/games/minecraft-server/files/pkg-message.in
  head/games/minecraft-server/pkg-plist