Bug 196176 - [PATCH] devel/libgit2: Update to 0.21.5
Summary: [PATCH] devel/libgit2: Update to 0.21.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Koop Mast
URL:
Keywords:
Depends on:
Blocks: 199662
  Show dependency treegraph
 
Reported: 2014-12-21 17:35 UTC by lightside
Modified: 2015-05-11 20:56 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (wg)


Attachments
Proposed patch (since 369517 revision) (2.00 KB, patch)
2014-12-21 17:35 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64) (25.36 KB, application/x-zip-compressed)
2014-12-21 17:36 UTC, lightside
no flags Details
Proposed patch (since 377075 revision) (1.65 KB, patch)
2015-01-15 12:33 UTC, lightside
no flags Details | Diff
Patch for 0.22.0 version (since 377075 revision) (4.10 KB, patch)
2015-01-15 15:01 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64) for 0.22.0 version (10.64 KB, application/x-zip-compressed)
2015-01-15 15:03 UTC, lightside
no flags Details
Proposed patch (since 377075 revision) (1.65 KB, patch)
2015-01-15 15:23 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64) (25.42 KB, application/x-zip-compressed)
2015-01-15 15:24 UTC, lightside
no flags Details
Proposed patch (since 377075 revision) (2.08 KB, patch)
2015-01-23 23:46 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64) (25.05 KB, application/x-zip-compressed)
2015-01-23 23:46 UTC, lightside
no flags Details
Update of libgit2 to 0.22.1. (4.74 KB, patch)
2015-01-24 09:51 UTC, Koop Mast
no flags Details | Diff
Companion update of libgit2-glib to 0.22.0. (4.79 KB, patch)
2015-01-24 09:52 UTC, Koop Mast
no flags Details | Diff
Proposed patch (since 377075 revision) (1.66 KB, patch)
2015-01-25 23:12 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64) (25.23 KB, application/x-zip-compressed)
2015-01-25 23:12 UTC, lightside
no flags Details
Patch for 0.22.1 version (since 377075 revision) (3.90 KB, patch)
2015-01-25 23:13 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64) for 0.22.1 version (27.00 KB, application/x-zip-compressed)
2015-01-25 23:14 UTC, lightside
no flags Details
Patch for v0.21.5 with dynamic plist (since 377075 revision) (3.41 KB, patch)
2015-01-28 06:51 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64) for v0.21.5 with dynamic plist (14.89 KB, application/x-bzip2)
2015-01-28 06:52 UTC, lightside
no flags Details
Proposed patch (since 377075 revision) (1.68 KB, patch)
2015-04-07 16:39 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64) (15.21 KB, application/x-bzip2)
2015-04-07 16:45 UTC, lightside
no flags Details
Proposed patch (since 377075 revision) (2.00 KB, patch)
2015-04-09 00:30 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64) (15.00 KB, application/x-bzip2)
2015-04-09 00:30 UTC, lightside
no flags Details
Patch for 0.22.2 version (since 377075 revision) (3.22 KB, patch)
2015-04-09 00:35 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64) for 0.22.2 version (15.98 KB, application/x-bzip2)
2015-04-09 00:37 UTC, lightside
no flags Details
Proposed patch (since 377075 revision) (2.01 KB, patch)
2015-04-11 10:38 UTC, lightside
no flags Details | Diff
Patch for 0.22.2 version (since 377075 revision) (3.23 KB, patch)
2015-04-11 10:39 UTC, lightside
no flags Details | Diff
Patch for devel/libgit2 port from 0.21.5 to 0.22.2 version (2.71 KB, patch)
2015-04-11 13:43 UTC, lightside
no flags Details | Diff
Patch for devel/libgit2-glib port from 0.0.24 to 0.22.4 version (7.08 KB, patch)
2015-04-11 13:45 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64): devel/libgit2-glib v0.22.4 (9.14 KB, application/x-bzip2)
2015-04-11 13:47 UTC, lightside
no flags Details
Patch for devel/libgit2-glib port from 0.0.24 to 0.22.4 version (7.10 KB, patch)
2015-04-11 13:58 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64): devel/libgit2-glib v0.22.4 (9.18 KB, application/x-bzip2)
2015-04-11 13:59 UTC, lightside
no flags Details
Patch for devel/libgit2-glib port from 0.0.24 to 0.22.4 version (7.07 KB, patch)
2015-04-13 18:07 UTC, lightside
no flags Details | Diff
Patch for devel/gitg port from 3.14.1 to 3.16.0 version (2.08 KB, patch)
2015-04-13 18:20 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64): devel/gitg v3.16.0 (19.23 KB, application/x-bzip2)
2015-04-13 18:21 UTC, lightside
no flags Details
Patch for devel/libgit2-glib port from 0.0.24 to 0.22.6 version (7.07 KB, patch)
2015-04-27 12:26 UTC, lightside
no flags Details | Diff
The poudriere testport log (FreeBSD 10 amd64): devel/libgit2-glib v0.22.6 (9.22 KB, application/x-bzip2)
2015-04-27 12:27 UTC, lightside
no flags Details
Proposed patch (since 385521 revision) (1.98 KB, patch)
2015-05-07 03:56 UTC, lightside
no flags Details | Diff
Patch for 0.22.2 version (since 385521 revision) (3.21 KB, patch)
2015-05-07 03:58 UTC, lightside
no flags Details | Diff
Patch for devel/libgit2 port from 0.21.5 to 0.22.2 version (2.68 KB, patch)
2015-05-07 03:59 UTC, lightside
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lightside 2014-12-21 17:35:40 UTC
Created attachment 150830 [details]
Proposed patch (since 369517 revision)

Patch to update devel/libgit2 port from 0.21.1 to 0.21.3 version.

- Added LICENSE_FILE
- Added THREADSAFE option to build libgit2 as threadsafe
Comment 1 Bugzilla Automation freebsd_committer 2014-12-21 17:35:40 UTC
Auto-assigned to maintainer wg@FreeBSD.org
Comment 2 lightside 2014-12-21 17:36:35 UTC
Created attachment 150831 [details]
The poudriere testport log (FreeBSD 10 amd64)
Comment 3 lightside 2015-01-15 12:33:01 UTC
Created attachment 151669 [details]
Proposed patch (since 377075 revision)

Looks like someone didn't use search before PR submit on 196662.
Update the patch for changes after 377075 revision.

Actually, there is new 0.22.0 version, but it requires more changes.
Comment 4 lightside 2015-01-15 12:39:32 UTC
Since the THREADSAFE (named as THREADS) option was implemented, the port doesn't block devel/gitg update.
Comment 5 lightside 2015-01-15 15:01:42 UTC
Created attachment 151681 [details]
Patch for 0.22.0 version (since 377075 revision)

The patch for 0.22.0 version is here. But new version breaks building of current (v0.0.24) devel/libgit2-glib port. Therefore not recommended.

Additional changes for 0.22.0 version:
- Add patch for ${WRKSRC}/src/openssl_stream.c, for correct build on FreeBSD
- Add sed patch to return FIND_PACKAGE for LIBSSH2
- Adapt pkg-plist for new version
Comment 6 lightside 2015-01-15 15:03:09 UTC
Created attachment 151682 [details]
The poudriere testport log (FreeBSD 10 amd64) for 0.22.0 version
Comment 7 lightside 2015-01-15 15:23:07 UTC
Created attachment 151683 [details]
Proposed patch (since 377075 revision)

The valid version to update is 0.21.4, before devel/libgit2-glib new version, which fixes issues for 0.22.0 version.

Look following link for changes:
https://github.com/libgit2/libgit2/compare/v0.21.1...v0.21.4
Comment 8 lightside 2015-01-15 15:24:04 UTC
Created attachment 151684 [details]
The poudriere testport log (FreeBSD 10 amd64)
Comment 9 lightside 2015-01-23 23:46:20 UTC
Created attachment 152066 [details]
Proposed patch (since 377075 revision)

There is new 0.21.5 maintenance release:
https://github.com/libgit2/libgit2/releases/tag/v0.21.5

It is possible to build devel/libgit2-glib (0.0.24) and devel/gitg (3.14.1) with it.
The proposed patch attached.

Also, there is new 0.22.1 maintenance release:
https://github.com/libgit2/libgit2/releases/tag/v0.22.1
Which corresponds to new devel/libgit2-glib 0.22.0 version:
https://git.gnome.org/browse/libgit2-glib/commit/?id=6adb228
But there are no release version for devel/gitg with fixes for API breaks of devel/libgit2-glib 0.22.0 version:
https://git.gnome.org/browse/gitg/commit/?id=ece73d4
https://git.gnome.org/browse/gitg/commit/?id=a1f43c1

Therefore, in case of new devel/gitg version (other than 3.14.1, which is already proposed on PR 196178), it might be possible to update libgit2 to 0.22.x, libgit2-glib to 0.22.x. While 0.21.5 version is valid for current update of devel/libgit2, which doesn't break mentioned port's release builds.

The patch for 0.22.0 version is obsolete, but could be used as reference, when needed.
Comment 10 lightside 2015-01-23 23:46:47 UTC
Created attachment 152067 [details]
The poudriere testport log (FreeBSD 10 amd64)
Comment 11 Koop Mast freebsd_committer 2015-01-24 09:51:41 UTC
Created attachment 152084 [details]
Update of libgit2 to 0.22.1.

patch-src__openssl_stream.c - Fix compile
patch-CMakeLists.txt - libgit2 switched to pkg-config for libssh2 detection (and probably others) but it has a typo in the pkg-config --cflags passings to cmake and doesn't have anything for pkg-config --libs.
Comment 12 Koop Mast freebsd_committer 2015-01-24 09:52:14 UTC
Created attachment 152085 [details]
Companion update of libgit2-glib to 0.22.0.
Comment 13 Koop Mast freebsd_committer 2015-01-24 10:47:08 UTC
I can't get gitg to build with the new libgit2/libgit2-glib 0.22.x versions, even with the 3.14.1 update from: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=196178
Comment 14 lightside 2015-01-24 11:29:39 UTC
Hello, Koop Mast.

(In reply to comment #13)
> I can't get gitg to build with the new libgit2/libgit2-glib 0.22.x versions,
> even with the 3.14.1 update from: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=196178

Yes, I explained this in comment #9.
The valid version is 0.21.5, not 0.22.x. For 0.22.x version there is a need for new devel/gitg release version, other than 3.14.1 (or conversion to USE_GITHUB and pointing to some commit, which has fixes).

Your fixes for 0.22.1 version is also mentioned in comment #5, with different approach of fixes.
Comment 15 lightside 2015-01-24 11:42:20 UTC
(In reply to comment #14)

What it looks in my case:
% pkg info gitg libgit2-glib libgit2
gitg-3.14.1
libgit2-glib-0.0.24_1
libgit2-0.21.5
Comment 16 lightside 2015-01-24 11:46:21 UTC
(In reply to comment #15)

The PORTREVISION of devel/libgit2-glib port should be bumped, of course. I manually rebuild/reinstalled all dependent ports.
Comment 17 lightside 2015-01-24 12:12:50 UTC
(In reply to comment #14)
> or conversion to USE_GITHUB and pointing to some commit

I meant similar approach, e.g.
MASTER_SITES=	http://git.gnome.org/browse/{GH_ACCOUNT}/snapshot/{GH_PROJECT}-${GH_TAGNAME}${EXTRACT_SUFX}?dummy=/

USES+=	tar:xz

WRKSRC=	${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME}

GH_ACCOUNT=	${PORTNAME}
GH_PROJECT=	${PORTNAME}
GH_COMMIT= bb7e974
GH_TAGNAME=	${GH_COMMIT}

It might download following commit:
https://git.gnome.org/browse/gitg/commit/?id=bb7e974
Comment 18 Koop Mast freebsd_committer 2015-01-25 19:30:33 UTC
I need the 0.22.x version of libgit2-glib for at least one port in the GNOME 3.15.x series, this is development so there is not a real big rush. But yes all ports should build with the new version.
Comment 19 lightside 2015-01-25 21:48:52 UTC
(In reply to comment #18)

The main point of my proposed PRs (196176, 196177, 196178) was to update devel/gitg port, where devel/libgit2 needed THREADSAFE CMake's option enabled and devel/libgit2-glib was broken. Now, these issues are resolved and it is possible to update devel/gitg to 3.14.1 version, which depends from maintainers/commiters.

Returning to devel/libgit2 discussion, based on developer(s) updates, they commited critical fixes to 0.21.x and 0.22.x at the same time:
https://github.com/libgit2/libgit2/releases/tag/v0.21.5
https://github.com/libgit2/libgit2/releases/tag/v0.22.1

So, they aware about dependent software. The logical step is to create devel/libgit for 0.21.x and 0.22.x versions, but this might require to do the same for devel/libgit2-glib port, while resolving a conflicts and other issues. And this is because of API breaks between versions. I didn't propose this.
Seems like, the maintainers consider to wait, which might work also, when it will resolve by itself. While timely updates of current opened PRs may lose its value over time and they might need to do updates by yourself.

As off-topic, there is the same situation for x11/nvidia (-driver, -settings, -xconfig) ports, where it's cheap to create own -devel versions of ports, than wait different maintainers to "catch up" with the same version, while NVidia ('s release manager(s)) releases them in the same time. On the other hand, I don't want to say something wrong about these maintainers. These situations just arise, and the cause is not a maintainer, but different responsibilities and interests, which not synchronized to do a resonance effect, as a whole.
Comment 20 lightside 2015-01-25 23:12:00 UTC
Created attachment 152135 [details]
Proposed patch (since 377075 revision)

Changed PORTVERSION option sub to SHLIB_VER2, which could be adapted from Makefile. Removed related sed patch.
Comment 21 lightside 2015-01-25 23:12:29 UTC
Created attachment 152136 [details]
The poudriere testport log (FreeBSD 10 amd64)
Comment 22 lightside 2015-01-25 23:13:58 UTC
Created attachment 152137 [details]
Patch for 0.22.1 version (since 377075 revision)

And there is a patch for 0.22.1 update, from my point of view.
Comment 23 lightside 2015-01-25 23:14:38 UTC
Created attachment 152138 [details]
The poudriere testport log (FreeBSD 10 amd64) for 0.22.1 version
Comment 24 lightside 2015-01-26 04:28:24 UTC
(In reply to comment #20)
> Changed PORTVERSION option sub to SHLIB_VER2

I meant name of variable for PLIST_SUB. This allows to use SHLIB_VER2 along with SHLIB_VER, without changing the pkg-plist file. The PORTVERSION is not right name for it, because SHLIB_VER2 changes from version to version, but not equal to PORTVERSION value sometimes.
Comment 25 lightside 2015-01-28 06:51:19 UTC
Created attachment 152294 [details]
Patch for v0.21.5 with dynamic plist (since 377075 revision)

Not sure, if somebody will be interested, but there is a version without pkg-plist, GH_COMMIT and PLIST_SUB. This is how maintainership-less port might look like. In a next update, just change the PORTVERSION, do "make makesum" and create patches for build, when needed. Check the plist with "make check-plist". Get the files list with following commands:
after stage:
% make -V TMPPLIST | xargs sort
after install:
% pkg info -l libgit2
for package with concrete version:
tar --include=/usr -tf libgit2-0.21.5.txz

This is possible because of current release method on GitHub and stage capabilities for ports.
Comment 26 lightside 2015-01-28 06:52:17 UTC
Created attachment 152295 [details]
The poudriere testport log (FreeBSD 10 amd64) for v0.21.5 with dynamic plist
Comment 27 Ben Woods freebsd_committer 2015-04-07 15:29:52 UTC
I have just tested this and have managed to get it working with the following combination:
libgit2-0.22.2
libgit2-glib-0.22.4
gitg-3.16.0

Apart from upgrading the PORTVERSION, distinfo and pkg-plist, the only changes required were:
 * add USES=pkgconfig to devel/libgit2 (as mentioned by Koop)
 * delete devel/libgit2-glib/files/patch-libgit2-glib__ggit-types.h

To avoid confusion from too many attachments, I have not attached my patches. Please let me know if you would like me to.
Comment 28 lightside 2015-04-07 16:09:46 UTC
(In reply to comment #27)

I think, the problem here is not about patches. The patches were up to date at the time of creation. The problem is no attention from maintainer and/or interested committer.
The mentioned program and libraries continues its development. There is no surprise, that new patches might be created.

Actually, this PR is only one remained. Other PRs (bug 196177 and bug 196178) were committed. They were interconnected.

I guess, you could create new PRs with your proposed changes, if you want to try to update devel/gitg port.
Comment 29 lightside 2015-04-07 16:39:11 UTC
Created attachment 155312 [details]
Proposed patch (since 377075 revision)

Adapted to new USE_GITHUB.
Comment 30 lightside 2015-04-07 16:45:23 UTC
Created attachment 155313 [details]
The poudriere testport log (FreeBSD 10 amd64)
Comment 31 lightside 2015-04-09 00:30:24 UTC
Created attachment 155353 [details]
Proposed patch (since 377075 revision)

Removed GH_ACCOUNT, which defined to the same value inside of Mk/bsd.sites.mk file.
Added '.ssl' file extension for OpenSSL patch, which allows to see differences between changed and original CMakeLists.txt file.
Comment 32 lightside 2015-04-09 00:30:51 UTC
Created attachment 155354 [details]
The poudriere testport log (FreeBSD 10 amd64)
Comment 33 lightside 2015-04-09 00:35:38 UTC
Created attachment 155355 [details]
Patch for 0.22.2 version (since 377075 revision)

Added patch for 0.22.2 version, in case of devel/gitg update to 3.16.0 (or greater)  version.
Otherwise, the 0.21.5 version (in attachment 155353 [details]) is still valid for current devel/gitg 3.14.1 version.
Comment 34 lightside 2015-04-09 00:37:02 UTC
Created attachment 155356 [details]
The poudriere testport log (FreeBSD 10 amd64) for 0.22.2 version
Comment 35 lightside 2015-04-11 10:38:15 UTC
Created attachment 155463 [details]
Proposed patch (since 377075 revision)

Changed PORTVERSION to DISTVERSIONFULL for DISTNAME, which allows more flexible changes, if needed.
Comment 36 lightside 2015-04-11 10:39:03 UTC
Created attachment 155464 [details]
Patch for 0.22.2 version (since 377075 revision)
Comment 37 lightside 2015-04-11 13:43:00 UTC
Created attachment 155469 [details]
Patch for devel/libgit2 port from 0.21.5 to 0.22.2 version

To Ben Woods:
If you don't mind, I could create PR for new (v3.16.0) devel/gitg port. I already have complete patch and poudriere testport log.

To Koop Mast:
Do you still need 0.22.x version of devel/libgit2 port for your mentioned other port?
I think, that you can process this PR, because of maintainer time-out.
Also I think, that better approach is to update to 0.21.5 (maintenance release) and then 0.22.2, with using the same PR. What do you think?
Comment 38 lightside 2015-04-11 13:45:46 UTC
Created attachment 155470 [details]
Patch for devel/libgit2-glib port from 0.0.24 to 0.22.4 version

The devel/libgit2-glib port already mentioned here, therefore I just updated it to new 0.22.4 version:
https://git.gnome.org/browse/libgit2-glib/diff/?id=v0.22.4&id2=v0.0.24
Comment 39 lightside 2015-04-11 13:47:18 UTC
Created attachment 155471 [details]
The poudriere testport log (FreeBSD 10 amd64): devel/libgit2-glib v0.22.4
Comment 40 lightside 2015-04-11 13:58:41 UTC
Created attachment 155472 [details]
Patch for devel/libgit2-glib port from 0.0.24 to 0.22.4 version

Added DOCS option for devel/libgit2-glib port.
Comment 41 lightside 2015-04-11 13:59:07 UTC
Created attachment 155473 [details]
The poudriere testport log (FreeBSD 10 amd64): devel/libgit2-glib v0.22.4
Comment 42 lightside 2015-04-13 18:07:59 UTC
Created attachment 155557 [details]
Patch for devel/libgit2-glib port from 0.0.24 to 0.22.4 version

Adapt patch in files directory for devel/libgit2-glib port, after ports r383894 changes for ports-mgmt/portlint v2.16.3.
Comment 43 lightside 2015-04-13 18:20:21 UTC
Created attachment 155560 [details]
Patch for devel/gitg port from 3.14.1 to 3.16.0 version

Added companion update for devel/gitg port from 3.14.1 to 3.16.0 version.
The Ben Woods might review it, if needed. The patch is trivial and for completion.
Comment 44 lightside 2015-04-13 18:21:32 UTC
Created attachment 155561 [details]
The poudriere testport log (FreeBSD 10 amd64): devel/gitg v3.16.0
Comment 45 Ben Woods freebsd_committer 2015-04-13 22:22:51 UTC
Actually, Koop has just recently taken maintainership of devel/gitg, so should probably be the one to review/approve your patch for it.

lightside: it looks like you are doing good work here. Hang in there, and I'm sure a committer will pick it up soon enough.
Comment 46 lightside 2015-04-27 12:26:51 UTC
Created attachment 156038 [details]
Patch for devel/libgit2-glib port from 0.0.24 to 0.22.6 version

Updated devel/libgit2-glib port to 0.22.6 version:
https://git.gnome.org/browse/libgit2-glib/diff/?id=v0.22.6&id2=v0.0.24
Changes to previous update:
https://git.gnome.org/browse/libgit2-glib/diff/?id=v0.22.6&id2=v0.22.4
Comment 47 lightside 2015-04-27 12:27:48 UTC
Created attachment 156039 [details]
The poudriere testport log (FreeBSD 10 amd64): devel/libgit2-glib v0.22.6
Comment 48 Michael Moll freebsd_committer 2015-05-06 17:05:53 UTC
take with wg@'s blessings via IRC
Comment 49 Michael Moll freebsd_committer 2015-05-06 21:47:05 UTC
kwm is working on it in https://reviews.freebsd.org/D2468
Comment 50 lightside 2015-05-07 02:43:45 UTC
Hello, Michael Moll.

(In reply to comment #49)
> kwm is working on it in https://reviews.freebsd.org/D2468

Ok, but what is done in this PR is not reflected in the mentioned review (to this time). I see a different approach for some moments. But may be this is ok, if maintainer agree about these changes and not what in this PR.

Nevertheless, this PR is still valid for 0.21.5 (maintenance release) version of devel/libgit2 port, before API/ABI changes in newer versions. The proposed (timely) updates for 0.22.x version was related to development of this library and dependent software, which required it.

Thanks for your attention and Koop Mast to take care about updates for 0.22.x version.
Comment 51 lightside 2015-05-07 03:56:41 UTC
Created attachment 156453 [details]
Proposed patch (since 385521 revision)

Updated patch(es) for devel/libgit2 port after ports r385521 changes (while GH_ACCOUNT define is not necessary in it: https://svnweb.freebsd.org/ports/head/Mk/bsd.sites.mk?revision=385521&view=markup#l540).
Comment 52 lightside 2015-05-07 03:58:19 UTC
Created attachment 156454 [details]
Patch for 0.22.2 version (since 385521 revision)
Comment 53 lightside 2015-05-07 03:59:26 UTC
Created attachment 156455 [details]
Patch for devel/libgit2 port from 0.21.5 to 0.22.2 version
Comment 54 commit-hook freebsd_committer 2015-05-11 20:56:12 UTC
A commit references this bug:

Author: kwm
Date: Mon May 11 20:56:05 UTC 2015
New revision: 386103
URL: https://svnweb.freebsd.org/changeset/ports/386103

Log:
  Update libgit2 to 0.22.1. [1]
  Update libgit2-glib to 0.22.8.
  Update gitg to 3.16.1.
  Update py-pygit2 to 0.22.0. [1][3]
  Update rubygem-rugged to 0.22.1b1. [2]

  This is done in one commit due to API/ABI breakage in libgit2.

  PR:		196176	(based on)
  Differential Revision:	https://reviews.freebsd.org/D2468
  Submitted by:	lightside@gmx.com
  Approved by:	maintainer (wg@ blanked) [1], ruby (swills@)[2]
  Reviewed by:	koobs@ [3]

Changes:
  head/devel/gitg/Makefile
  head/devel/gitg/distinfo
  head/devel/gitg/pkg-plist
  head/devel/libgit2/Makefile
  head/devel/libgit2/distinfo
  head/devel/libgit2/pkg-plist
  head/devel/libgit2-glib/Makefile
  head/devel/libgit2-glib/distinfo
  head/devel/libgit2-glib/files/patch-libgit2-glib__ggit-types.h
  head/devel/libgit2-glib/pkg-plist
  head/devel/py-pygit2/Makefile
  head/devel/py-pygit2/distinfo
  head/devel/rubygem-rugged/Makefile
  head/devel/rubygem-rugged/distinfo
Comment 55 Koop Mast freebsd_committer 2015-05-11 20:56:45 UTC
Committed thanks for keeping the patches uptodate.