Bug 196180 - [PATCH] multimedia/xmms segfaults when playing module files due to old MikMod plugin / modern libmikmod.so
Summary: [PATCH] multimedia/xmms segfaults when playing module files due to old MikMod...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Christian Weisgerber
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-21 18:41 UTC by Michael Lackner
Modified: 2014-12-25 21:22 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (naddy)


Attachments
patch-drv_xmms.c (427 bytes, text/x-csrc)
2014-12-21 18:41 UTC, Michael Lackner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Lackner 2014-12-21 18:41:19 UTC
Created attachment 150837 [details]
patch-drv_xmms.c

Problem:

On modern systems, the xmms MikMod plugin is broken, as the libmikmod.so version it depends on is too new. This affects many UNIX-style systems, including the xmms port on FreeBSD for at least version 10.x. This results in a segmentation fault when playing module/tracker files.

How to reproduce:

This can easily be reproduced by running xmms and by then trying to play a module/tracker file (.mod, .s3m, .it, .669, etc.). xmms will then terminate every time due to a segmentation fault.

Solution:

I have attached an adapted version of a patch for Input/mikmod/drv_xmms.c originally written by Jakob Steltner for ArchLinux, which fixes the issue for multimedia/xmms.

Additional information:

The original patch by Jakob Steltner can be found here: https://bugs.archlinux.org/task/32627
Comment 1 Bugzilla Automation freebsd_committer 2014-12-21 18:41:19 UTC
Auto-assigned to maintainer naddy@FreeBSD.org
Comment 2 commit-hook freebsd_committer 2014-12-23 21:10:19 UTC
A commit references this bug:

Author: naddy
Date: Tue Dec 23 21:09:46 UTC 2014
New revision: 375356
URL: https://svnweb.freebsd.org/changeset/ports/375356

Log:
  Fix segfault in MikMod plugin with modern libmikmod.

  PR:		196180
  Submitted by:	Michael Lackner
  Obtained from:	Jakob Steltner (Arch Linux)

Changes:
  head/multimedia/xmms/Makefile
  head/multimedia/xmms/files/patch-Input_mikmod_drv__xmms.c
Comment 3 Christian Weisgerber freebsd_committer 2014-12-23 21:11:42 UTC
Committed, thanks!
Comment 4 Michael Lackner 2014-12-25 21:22:55 UTC
I just unlocked and pulled xmms-1.2.11_26 from the packages collection, works beautifully!

Thanks for your work!