Bug 196182 - [PATCH] upgrade graphics/lensfun to 0.3.0
Summary: [PATCH] upgrade graphics/lensfun to 0.3.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords: needs-qa, patch
Depends on: 205006
Blocks:
  Show dependency treegraph
 
Reported: 2014-12-21 20:19 UTC by Matthieu Volat
Modified: 2015-12-25 09:09 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (danfe)


Attachments
Upgrade graphic/lensfun to 0.3.0 (4.19 KB, patch)
2014-12-21 20:19 UTC, Matthieu Volat
koobs: maintainer-approval? (danfe)
Details | Diff
Fix hugin with lensfun 0.3 (863 bytes, patch)
2015-03-05 20:34 UTC, Matthieu Volat
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Volat 2014-12-21 20:19:35 UTC
Created attachment 150840 [details]
Upgrade graphic/lensfun to 0.3.0

Lensfun 0.3.0 was released the 2014-09-30 and brings new lens correction profiles, fix for many lens names, etc etc (http://lensfun.sourceforge.net/changelog/2014/09/30/Release-0.3.0-Changelog/). It also moved its build sys to cmake.

Here is a patch against HEAD to bump the port version. My tests with graphic/darktable shows that liblensfun.so seems to be ABI compatible, but maybe dependencies should be rebuild in doubt...

portlint is happy, and here's plist check result:
# make check-plist
====> Checking for pkg-plist issues (check-plist)
===> Parsing plist
===> Checking for items in STAGEDIR missing from pkg-plist
===> Checking for items in pkg-plist which are not in STAGEDIR
===> No pkg-plist issues found (check-plist)
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-12-21 22:33:34 UTC
Fix typo in Summary and assign.
Comment 2 Matthieu Volat 2015-02-09 19:21:21 UTC
May I politely "bump" the issue? It's been more than a month...
Comment 3 Rodrigo Osorio freebsd_committer 2015-02-25 13:09:50 UTC
Since last patch the Makefile changes
and has a PORTREVISION who breaks the
patch. The problem is minor.

Here is the poudriere log :
http://www.bebik.net/poudriere/2015-02-25_14h03m52s/logs/lensfun-0.3.0.log

Now I have to test the port or "real" :)
Comment 4 Alexey Dokuchaev freebsd_committer 2015-02-25 18:06:44 UTC
(In reply to Matthieu Volat from comment #2)
> May I politely "bump" the issue? It's been more than a month...

I'm currently working on the update.  Proposed patch has a number of problems (e.g. it installs useless auxiliary scripts, does not mention BUILD_AUXFUN option while still keeping libpng dependency, python:build in USES after they switched to CMake).  Since lensfun.h was moved inside lenfsun subdirectory, all ports that use this library must be rechecked to see that they do not hardcode its location.

That said, no further attachments to this PR are necessary.
Comment 5 Alexey Dokuchaev freebsd_committer 2015-03-05 19:47:30 UTC
Final patch I'd want to commit is here: http://people.freebsd.org/~danfe/lensfun.diff

However, first I'd have to take care of the following ports.  It seems that API changed and there are 4 failures:

http://package22.nyi.freebsd.org/build.html?mastername=101amd64-default-lensfun&
+build=2015-03-04_16h20m00s

http://package22.nyi.freebsd.org/data/101amd64-default-lensfun/2015-03-04_16h20m
+00s/logs/errors/rawstudio-2.0_9.log
http://package22.nyi.freebsd.org/data/101amd64-default-lensfun/2015-03-04_16h20m
+00s/logs/errors/hugin-2013.0.0_5.log
http://package22.nyi.freebsd.org/data/101amd64-default-lensfun/2015-03-04_16h20m
+00s/logs/errors/digikam-4.2.0,2.log
http://package22.nyi.freebsd.org/data/101amd64-default-lensfun/2015-03-04_16h20m
+00s/logs/errors/gimp-lensfun-plugin-0.2.4.d_3.log
Comment 6 Matthieu Volat 2015-03-05 20:34:59 UTC
Created attachment 153863 [details]
Fix hugin with lensfun 0.3

Thanks, if it can help, the hugin breakage is very easy to fix: it's just a removed correction model which was not used according to the corresponding log message in lensfun git log ( http://sourceforge.net/p/lensfun/code/ci/048eb3c4e562b8d3b00068f6f42c7900865d3358/ ).

Patch added, but maybe I should submit it to the hugin maintainer...
Comment 7 commit-hook freebsd_committer 2015-03-31 08:09:17 UTC
A commit references this bug:

Author: danfe
Date: Tue Mar 31 08:08:54 UTC 2015
New revision: 382801
URL: https://svnweb.freebsd.org/changeset/ports/382801

Log:
  Update lensfun to version 0.3.0.  It contains few changes making consumer
  code incompatible with earlier versions; particularly, removal of CCI (the
  Color Contribution Index of the lens, as defined by ISO 6728-83) [1] and
  FOV1 ("field-of-view") [2] distortion model.

  Four ports had to be patched to build against new lensfun (all fall under
  `graphics' category): digikam-kde4, gimp-lensfun-plugin, hugin, rawstudio.

  PR:		196182
  Submitted by:	Matthieu Volat (heavily modified)
  Exp-run by:	antoine

  [1] https://sourceforge.net/p/lensfun/code/ci/f0c293
  [2] https://sourceforge.net/p/lensfun/code/ci/048eb3

Changes:
  head/graphics/digikam-kde4/Makefile
  head/graphics/digikam-kde4/files/patch-git-r2ad23d-lensfun-fix
  head/graphics/gimp-lensfun-plugin/Makefile
  head/graphics/gimp-lensfun-plugin/pkg-descr
  head/graphics/hugin/Makefile
  head/graphics/hugin/files/patch-src_hugin__base_lensdb_LensDB.cpp
  head/graphics/lensfun/Makefile
  head/graphics/lensfun/distinfo
  head/graphics/lensfun/files/
  head/graphics/lensfun/files/patch-CMakeLists.txt
  head/graphics/lensfun/pkg-plist
  head/graphics/rawstudio/Makefile
Comment 8 Alexey Dokuchaev freebsd_committer 2015-03-31 08:14:27 UTC
Committed as of ports r382801, thanks for your submission!