Bug 196345 - audio/espeak: Fix LIB_DEPENDS on portaudio and fix plist
Summary: audio/espeak: Fix LIB_DEPENDS on portaudio and fix plist
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Nicola Vitale
URL:
Keywords: easy, needs-qa, patch
Depends on:
Blocks:
 
Reported: 2014-12-29 04:43 UTC by Dmitry Marakasov
Modified: 2015-01-18 09:39 UTC (History)
1 user (show)

See Also:
nivit: maintainer-feedback+


Attachments
patch (828 bytes, patch)
2014-12-29 04:43 UTC, Dmitry Marakasov
koobs: maintainer-approval? (nivit)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Marakasov freebsd_committer 2014-12-29 04:43:46 UTC
Created attachment 151055 [details]
patch

- Depend on specific version of libportaudio, to not pick up library from portaudio2 and break the build
- Add empty directories to plist to fix stage-qa
Comment 1 Bugzilla Automation freebsd_committer 2014-12-29 04:43:46 UTC
Auto-assigned to maintainer nivit@FreeBSD.org
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2014-12-29 04:53:19 UTC
Are you sure we want to .0 suffix in the lib depends?
Comment 3 Dmitry Marakasov freebsd_committer 2014-12-29 12:39:00 UTC
That is the point - we must always use .0 and .2 to distinguish between audio/portaduio and audio/portaudio2. Actually, all portaudio-using ports should be fixed, however I've just ran into espeak on a live system.
Comment 4 commit-hook freebsd_committer 2015-01-14 18:37:02 UTC
A commit references this bug:

Author: amdmi3
Date: Wed Jan 14 18:36:24 UTC 2015
New revision: 377036
URL: https://svnweb.freebsd.org/changeset/ports/377036

Log:
  - Depend on specific version of libportaudio, to not pick up library from portaudio2 and break the build
  - Add empty directories to plist

  PR:		196345
  Submitted by:	amdmi3
  Approved by:	maintainer timeout (nivit)

Changes:
  head/audio/espeak/Makefile
  head/audio/espeak/pkg-plist