Bug 196355 - games/minetest: Cannot build (0.4.11), endian.h include location
Summary: games/minetest: Cannot build (0.4.11), endian.h include location
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2014-12-29 16:18 UTC by Thibault Payet
Modified: 2014-12-30 00:05 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (amdmi3)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thibault Payet 2014-12-29 16:18:30 UTC
Minetest can't build on FreeBSD, because the file endian.h are located at /usr/include/sys/endian.h
In fact in src/cguittfont/irrUString.h we have this include(at line 50):

#elif __MACH__
#include <machine/endian.h>
#else
#include <endian.h>
#endif
 
We can fix by changing <endian.h> to <sys/endian.h>. The best would be somethings 
like use a macro like __FREEBSD (defined if compiled on FreeBSD ) and have:
#elif __MACH__
#include <machine/endian.h>
#elif __FREEBSD
#include <sys/endian.h>
#else
#include <endian.h>
#endif
Comment 1 Bugzilla Automation freebsd_committer 2014-12-29 16:18:30 UTC
Auto-assigned to maintainer amdmi3@FreeBSD.org
Comment 2 Dmitry Marakasov freebsd_committer 2014-12-29 23:21:03 UTC
Please post the full build log, as I cannot reproduce this.
Comment 3 commit-hook freebsd_committer 2014-12-30 00:03:07 UTC
A commit references this bug:

Author: amdmi3
Date: Tue Dec 30 00:02:38 UTC 2014
New revision: 375811
URL: https://svnweb.freebsd.org/changeset/ports/375811

Log:
  - Fix build with FREETYPE enabled

  PR:		196355
  Submitted by:	monwarez@mailoo.org

Changes:
  head/games/minetest/files/patch-src__cguittfont__irrUString.h
Comment 4 Dmitry Marakasov freebsd_committer 2014-12-30 00:05:27 UTC
Please ignore the request, I was able to reproduce it - FREETYPE option needs to be enabled. Fixed, thanks!